Reply to topic

lost taskbar thumbnails, worked at some point

User avatar google01103
Manager
Posts
4970
Karma
17
OS
can't remember when it stopped working

not a system issue as it works for a different user

tool tips enabled in taskbar
taskbar thumbnails effect enabled
tooltips show but just app icon, name and desktop not thumbnail

renaming kwinrc and replacing kwin did not fix


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
luebking
Registered Member
Posts
933
Karma
7
The taskbar thumbnails are caused by the taskbar, not kwin.
So unless you see a giant empty popup (w/o the actual thumbnails only) the setting you're looking for is somewhere in the taskbar settings - or you're using a taskbar replacement that simply does not support this feature.
User avatar google01103
Manager
Posts
4970
Karma
17
OS
no using std task bar

Image


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
luebking
Registered Member
Posts
933
Karma
7
You need to have "Show tooltips" activated in the taskbar (seems) settings and "Taskbar Thumbnails" in "kcmshell4 kwincompositing"

In doubt restart plasma (kquitapp plasma-desktop; sleep 1; plasma-desktop) after activating the taskbar settings since the taskbar does not seem to monitor the property hinting the availability of the feature.
User avatar google01103
Manager
Posts
4970
Karma
17
OS
wt? every morning I restart KDE and thumbnails don't show, tooltips and thumbnails are enabled and now (as suggested) I restart Plasma and it works? weird, should not starting KDE (with empty session) in effect be the same as restarting Plasma ?

thanks,


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
luebking
Registered Member
Posts
933
Karma
7
Random guess:
plasma starts "too early", could be because of kwin starts threaded.
Consequence: the expected property is not there when in starts and since it's not monitored the feature remains unused.

Given the ability to turn on and off that effect at runtime (also if you eg. start w/o compositing and later on actiate it by hande), the taskbar should catch runtime updates.
-> file a bug against plasma / taskbar to monitor presence of _KDE_WINDOW_PREVIEW on the root window

Or don't use taskbars :P
User avatar google01103
Manager
Posts
4970
Karma
17
OS


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
shokanson
Registered Member
Posts
1
Karma
0
Thanks google01103 for share link and solve the problem. I visit this link and read your bug report.


plagiarismsoftware.net - plagiarism detection software

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, Baidu [Spider], bcooksley, Bing [Bot], Exabot [Bot], Google [Bot], Majestic-12 [Bot], mmistretta, MSNbot Media, onesandzeros, shmerl, Uri_Herrera, Yahoo [Bot]