Reply to topic

Kwin falls back to XRender after updating to KDE 4.10

User avatar Aoxo
Registered Member
Posts
20
Karma
0
I'm running VMWare Player on Win7 with Kubuntu 12.10 installed as a guest. Prior to updating to KDE 4.10, kwin seems to work with openGL just fine. I have wobbly windows and 3d games such as alien arena work. After updating to KDE 4.10, kwin will only allow XRender. I've tried reinstalling vmware tools (installing at the command line with vmware-install.pl), and also tried open-vm-tools. Nothing changes.

I've poked around google for hours at a time, several times...trying to find someone that has the same problem, but I'm unable to find anything helpful. My linux experience is limited, so I'm not quite sure how to go about identifying the problem. Over the last few weeks I've tried 4.10rc2, 4.10rc3, and now the release version of 4.10...I had hoped that the release version might not have this problem but it does.

Does anyone have any idea why OpenGL fails with kwin after updating to KDE 4.10? Any (novice level) tips? Should I just avoid KDE 4.10 until the dust settles?

Oh I should also mention I tried upgrading to Kubuntu 13.04 along with KDE 4.10....no dice...the update goes well but kwin still hates me.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
Please provide the output of the following command:
Code: Select all
qdbus org.kde.kwin /KWin org.kde.KWin.supportInformation


System Settings and Device Actions KCM maintainer
Image
User avatar Aoxo
Registered Member
Posts
20
Karma
0
http://pastebin.com/pS20jDvw

I don't know if it's helpful but I also ran that command on a copy of the same VM prior to updating KDE and compared the files. Here's the results:

http://pastebin.com/RKEk4f9R

Thanks for the assistance!
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
Does KWin indicate why it is falling back to XRender?
Have you tried setting OpenGL as the "Compositing type" in System Settings > Desktop Effects > Advanced?


System Settings and Device Actions KCM maintainer
Image
User avatar Aoxo
Registered Member
Posts
20
Karma
0
Yes I've tried to change the compositing type in system settings > desktop effects > advanced. On some occasions it will actually give me feedback when it fails. Generally what happens is a bar will appear in the window that tells me that 5 desktop effects could not be enabled. It will appear that the OpenGL setting took hold according to the dropdown box, but changing tabs to anything other than advanced..then going back to advanced will update the dropdown box and show XRender again. On the occasions when it gives a bit more feedback, this is the content:

Sorry - System Settings
Failed to activate desktop effects using the given configuration options. Settings will be reverted to the previous values.
Check your X configuration. You may also consider changing advanced options, especially the compositing type.


Unfortunately the message suggests I do what triggered the message in the first place, change the compositing type. I've also tried about every combination of settings on the advanced tab such as openGL 2 shaders, vsync, etc.

As far as "check your X configuration" goes I'm not sure what to make of that. I know with past distributions I had a file "/etc/X11/xorg.conf" but I haven't seen it in use with (K)ubuntu.

I've seen people suggest running "kwin --replace" at a command prompt to see the feedback. I've done thins and the results are here:

http://pastebin.com/8K6kNwUt

The font config and qdbus connection errors seem pretty typical when running a program in a terminal that probably shouldn't be. They occur with my original KDE 4.9 version of the VM as well, so they're at least not new. I think they're unrelated.

I've seen people referencing changes they made or considered making to "~/.kde/share/config/kwinrc". I did experiment and add "DisableChecks=true" to mine to see if it changed anything...it didn't. Here is the full contents of the file:

http://pastebin.com/5CTjDXE6

I have tried switching back to the default oxygen themes (plasma, windows, gtk, etc), but generally use qtcurve. Doesn't seem to make any difference.

I should also note that this is very much like what used to happen when using earlier releases of kubuntu with with earlier version of VMWare Player. It also occurred with earlier releases of Kubuntu with VirtualBox. However something changed about the time that (K)ubuntu 12.04 was released...or perhaps it had more to do with something on VMWare Player's end. I'm not certain. But for quite a while OpenGL has been working great and now it's breaking again.

As I mentioned, I thought perhaps that the vmware tools might need to be updated somehow but I think that the version of tools is sort of married to the version of VMWare Player itself. I have tried to figure out how to find a VMWare Tools "OSP", a deb package offered by a vmware repo that is operating system specific. I wasn't able to find enough information to be successful, and I think the only real upside might be that I would have it from vmware themselves and in a package format that can be managed better than using an install script.

I've come across a blog that discusses Kwin and openGL in modern terms (http://blog.martin-graesslin.com), and I think it's not light reading and much of it goes over my head. It sounds as if he's the KWin developer. I've combed through several of his posts but haven't found any direct references to my situation. It's definitely not a support site, and while I could potentially put in a comment or question...it's not a support site and I don't want to bother the man.

Last edited by Aoxo on Sun Feb 10, 2013 8:35 am, edited 1 time in total.
mgraesslin
KDE Developer
Posts
356
Karma
4
OS
try running:

KWIN_COMPOSE=O2 kwin --graphicssystem raster --replace &

and look at the output. I actually added "support" for VmWare drivers. Support in that case means that the drivers are detected, but it should work OOTB given that it's a gallium driver.
User avatar Aoxo
Registered Member
Posts
20
Karma
0
That fixed it I think!

http://pastebin.com/prLeDfZC

Instantly I have wobbly windows and transparency when moving windows. However, when I go to System Setting/Desktop Effects/Advanced, it still says Xrender/Native. I changed it to OpenGL/Raster and it didn't complain and everything still looks right.

So that forced openGL 2 and restarted kwin with raster graphics? Is it an issue with detection of the driver then? Is there anything else I should do or any other info you need?

Thank you sirs for the help : D

Back in the land of wobbly windows!

Opps, not so fast..
What is the best way to run that command? If I do it from a konsole window it doesn't...I don't know what the term is...finish :P If I close the terminal it causes problems. If I reboot the change doesn't stick. I tried it in Krunner and it didn't work. Do I need to apply this at startup somehow?
mgraesslin
KDE Developer
Posts
356
Karma
4
OS
the question is why it doesn't pick up OpenGL automatically as it seems to work when being enforced. Can you please paste your kwinrc?
User avatar Aoxo
Registered Member
Posts
20
Karma
0
The before picture of the kwinrc file is
http://pastebin.com/5CTjDXE6

after using that command in a terminal it is
http://pastebin.com/zh6kuMU1

"DisableChecks=true" is something I added in there, I should probably take it out again if it doesn't belong there.
mgraesslin
KDE Developer
Posts
356
Karma
4
OS
DisableChecks is IIRC completely useless nowadays.

I would try removing the GLLegacy line (or check "Use OpenGL2 Shaders").
User avatar Aoxo
Registered Member
Posts
20
Karma
0
I removed the disablechecks line.

I think the fact that GLLegacy is in the "after" version of the file might just be due to the way it was forced, or perhaps that was the state I left it in having tried it both ways. Originally "Use OpenGL 2 Shaders" was checked though. Still, toggling it doesn't seem to make any difference.

This is pretty much what used to happen a year or two ago with older versions of VMWare Player. Something happened, I guess VMWare got a driver sorted out and it shipped with ubuntu 12.04 from the looks of it. After upgrading both at some point it all started to just work. What it's doing now is exactly like what it did before things worked.

Did I mention im currenty testing this with kubuntu 13.04, but I've also tried just updating KDE using Kubuntu 12.10? Both showed the same symptoms.

I tried glxgears...it works (@3500+fps at the default size). When I close glxgears I get this message in the terminal:
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0" after 33439 requests (33439 known processed) with 0 events remaining.

That can't be good...

I tried glxinfo. Here's the results if it's of any use:

http://pastebin.com/XNLLcTH6

Last edited by Aoxo on Sun Feb 10, 2013 11:49 am, edited 3 times in total.
mgraesslin
KDE Developer
Posts
356
Karma
4
OS
seems like I need to give it another try. Working with the virtualized systems is not easy - as I described in http://blog.martin-graesslin.com/blog/2 ... alization/

Overall I would recommend you to just export the environment variable for the time being. You can do so by putting an executable script into ~/.kde/env/
User avatar Aoxo
Registered Member
Posts
20
Karma
0
Hmm I started to bark up that tree...I think I added "export KWIN_COMPOSE=02" to .profile and .bashrc with no success. I'll try to work that part out but thank you for the hint.

Thanks for you time on this too. I'm not sure why I get so devastated when wobbly windows don't work...but it's just not the same.

Update:
OK I created a file called forcegl.sh and put it in .kde/env and made it executable. I only put the following in it:
#! /bin/sh
export KWIN_COMPOSE=02


It didn't work! ...but printenv shows the variable...hang on a minute...thanks to copy/paste, I only just now noticed the subtle difference between 02 and O2. Brilliant! (ugh)
#! /bin/sh
export KWIN_COMPOSE=O2


Works great!
I also struggle with I, l, 1, and even | on occasion....

Last edited by Aoxo on Sun Feb 10, 2013 1:18 pm, edited 2 times in total.
luebking
Registered Member
Posts
917
Karma
7
export it from ~/.kde/env/exports.sh
where exports.sh needs to be executable, ".kde" might be ".kde4"

This is also controlled from the "kcmshell4 autostart" settings module
p0x8
Registered Member
Posts
1
Karma
0
I experienced the same issue (kwin silently reverting to XRender under VMWare following the 4.10 upgrade) on Arch Linux. Setting the KWIN_COMPOSE environment variable fixed it. It would be useful if kwin would output some sort of warning and/or debug information when changing user settings. I should also add that XRender exhibited a lot of rendering bugs, particularly with transparent/translucent borders (log out dialog, CPU/memory/disk monitor plasma widget, etc,).

Thanks Aoxo for the persistent troubleshooting. And the devs for providing a workaround.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], cristian.onet, Exabot [Bot], garthecho, Google [Bot], Hans, ingwa, koriun, madcoucal, newtonnickel, ooker, pedrorodriguez, rulet111, Yahoo [Bot]