Reply to topic

[SOLVED] Keystrokes sent to unfocused window in Thunderbird

User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
luebking wrote:Some "smart" feature that makes you spamming your fellas with html mails?

Ie. you start typing a textmail, then thunderbird "thinks" you want to write an html mail, replaces the editor and messes that up?
Can one downforce html mail creation? Has that any impact?


I'm not exactly sure how I have it set up. It seems that I have it set to send both plain and html from the preferences, but to compose in html from the account settings. However, I seem to remember that I had it set up to send plain unless I specifically selected html elements. (I'm not a spammer, honest! ;D )

Also, it changes from "variable width" to "sans-serif". Isn't the former html anyway? That's my default html font. In any case, I just sent a test email, and it's just plain.

funpro wrote:Unfortunately yes, I mean Unity. I know this is a KDE forum but this was the only mention I found about this issue.
Has someone updated to 13.10 and in that case, does it help?


No worries at all! I'm glad that you posted here, as it's useful information for me too.

I just upgraded to Kubuntu 13.10 today, so I'll see if this has fixed this bug for me. I'll post back if I hit it, or in a few days if it's all good.
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
Aaaaand, the bug is still there in Kubuntu 13.10. :'(
funpro
Registered Member
Posts
7
Karma
0
I suspect I found the cause: unclutter.

I'm not yet completely sure, but I just uninstalled unclutter and I can no longer reproduce the annoying behavior. I had unclutter hide my mouse pointer after 5 seconds of inactivity. I think that's when the focus was messed up, and later key presses sent to the wrong window.

Do you @sparhawk have unclutter running?
luebking
Registered Member
Posts
933
Karma
7
Did you run "unclutter -grab"?
funpro
Registered Member
Posts
7
Karma
0
Unfortunately I couldn't find where unclutter was being called at startup, so I just uninstalled it.
It was not found in Startup Applications. Do you know where it could be launched? (I'm on Unity. I know, this is a KDE forum).

By the way, the issue with the key presses is new in any case, so maybe something has changed lately, either in unclutter or in the system.
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
funpro wrote:I suspect I found the cause: unclutter.

I'm not yet completely sure, but I just uninstalled unclutter and I can no longer reproduce the annoying behavior. I had unclutter hide my mouse pointer after 5 seconds of inactivity. I think that's when the focus was messed up, and later key presses sent to the wrong window.

Do you @sparhawk have unclutter running?

YES I DO! Great find. How on earth did you figure that out? I'll kill it and see what happens.

FWIW I still get that switching in Thunderbird from variable width to sans-serif even after killing unclutter.

luebking wrote:Did you run "unclutter -grab"?

I run `unclutter -idle 3 -root`.

funpro wrote:Unfortunately I couldn't find where unclutter was being called at startup, so I just uninstalled it.
It was not found in Startup Applications. Do you know where it could be launched? (I'm on Unity. I know, this is a KDE forum).

Mine was in `~/.config/autostart/unclutter.desktop`, but I think I installed it there manually. I always forget the location of the numerous autostart directories, so one easy way to find it is to open a terminal and type in `locate autostart`. Or you could try `locate unclutter`.

The first command gives me the following reasonable directories.
Code: Select all
/etc/xdg/autostart
~/.config/autostart
~/.kde/share/autostart
/usr/share/autostart


funpro wrote:By the way, the issue with the key presses is new in any case, so maybe something has changed lately, either in unclutter or in the system.

Yes, I agree.
funpro
Registered Member
Posts
7
Karma
0
sparhawk wrote:How on earth did you figure that out?

I noticed that the focus changed at the same time the mouse pointer disappeared. Then I had to search for "program to hide mouse pointer", and I found unclutter :)

With a locate unclutter I find "/etc/X11/Xsession.d/90unclutter". I guess I should delete that, now that it's no longer installed.
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
funpro wrote:I noticed that the focus changed at the same time the mouse pointer disappeared.

I'm so used to the disappearing pointer, it didn't even register. Very good find. It seems to be fixed after a few hours, but I'll give it a week or so and post back if it's fixed. That's quite annoying though, because I do like unclutter. However, I'll file a bug for it, although I'm not sure if whose fault it is: mozilla, unclutter, or the distro.

funpro wrote:With a locate unclutter I find "/etc/X11/Xsession.d/90unclutter". I guess I should delete that, now that it's no longer installed.

Oh yes, good find. I actually did have to remove that too, to prevent startup. However, if you've uninstalled unclutter itself, this file will do nothing. (But you can delete it to keep a "clean" system.) Just out of interest, how did you uninstall unclutter? If you "purged" it instead, it might have removed this file.
funpro
Registered Member
Posts
7
Karma
0
I uninstalled it using the Ubuntu Software Center. I then removed other files found with 'locate', just to keep it clean as you say.

I also found unclutter nice when recording video tutorials, as I often had to make the effort to move the mouse away to not obstruct the code I was showing.
I'll have to figure out how to do this now.

I'm happy to have found some kind of fix anyway. Cheers!
luebking
Registered Member
Posts
933
Karma
7
In the non grabbing mode, unclutter afair creates an input window to occupy the mouse and forwards events (pot. crossing, wheel, buttons) to the client below, what might "confuse" either the WM or the client (FF/TB) - or both.

What focus policy do you use (click to focus, focus follows mouse?)
funpro
Registered Member
Posts
7
Karma
0
In my case, I don't know, but it should be the default. I never changed the focus policy nor the unclutter settings. (And I read that you need to download some tweaking application to change that in the Unity based Ubuntu, which I did not).
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
If you are using Plasma Desktop / KWin then the focus policy in effect can be checked in System Settings > Window Behaviour > Window Behaviour, Focus tab.


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
luebking wrote:In the non grabbing mode, unclutter afair creates an input window to occupy the mouse and forwards events (pot. crossing, wheel, buttons) to the client below, what might "confuse" either the WM or the client (FF/TB) - or both.

Is this explanation consistent with the fact that even after I "cancel" unclutter by moving the mouse, I still experience this bug?

luebking wrote:What focus policy do you use (click to focus, focus follows mouse?)

I'm using click to focus. Is that the option that is least likely to interfere?
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
Inspired by some of luebking's questions, I thought to try some of the different unclutter options. `-grab` might be worth trialling, but I've been trying `-noevents` for the last two days, and haven't come across this bug yet. This might be worth trying, funpro. To change the defaults at startup, reinstall unclutter (using the terminal) with:
Code: Select all
sudo apt-get install unclutter

Then modify `/etc/default/unclutter` with root permissions, e.g. with:
Code: Select all
sudo nano /etc/default/unclutter

Change
Code: Select all
EXTRA_OPTS="-idle 2 -root"

to
Code: Select all
EXTRA_OPTS="-idle 2 -root -noevents"

(In nano, press ctrl+x, y, <return>, to save.)

Now, to start unclutter with these settings, either restart X (or your computer), or manually start unclutter with
Code: Select all
unclutter -idle 2 -root -noevents &
disown -h

And then you can close the terminal.

You can check that unclutter is using these options with
Code: Select all
ps aux|grep [u]nclutter
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
After over a week of testing, I'm pretty sure that `-noevents` works fine. I'm marking this as solved!

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], Majestic-12 [Bot], mmistretta, MSNbot Media, onesandzeros, shmerl, Uri_Herrera, Yahoo [Bot]

cron