Reply to topic

Tracks missing on one PC but not the other.

User avatar Paul
Registered Member
Posts
16
Karma
0
OS
1. I have my music collection in /home/music
2. I use two PCs:
    On the first, /home is on one of the local hard disks,
    on the second /home is nfs mounted from the first

When I log in on the second PC I see my whole collection in the Local Collection browser but when I log in to the first PC I can only see a few tracks. I don't log in on both PCs at the same time. Any ideas why or what I could do about it?
User avatar Mamarok
Manager
Posts
2922
Karma
8
OS
Could you please specify the basics: Amarok version, KDE version, installation differences between the two PCs?


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
User avatar Paul
Registered Member
Posts
16
Karma
0
OS
Both PCs are pretty much the same, apart from the location of /home:

Amarok 2.6.0 (Build Date: Nov 14 2012)
KDE 4.9.3
All installed via Kubuntu 12.10 repositories
User avatar strohel
KDE Developer
Posts
53
Karma
0
OS
I'd suggest just starting Amarok from Konsole as `amarok --debug` and perform full rescan (accessible from config) - try to spot any obvious error messages (warning, many messages look suspicious while they are in fact harmless), perhaps try Konsoles's Edit -> Find and enter a part of a filename of a not found track.
User avatar Paul
Registered Member
Posts
16
Karma
0
OS
I did a full rescan on the first PC and now I can see all my tracks there, but now there are no tracks visible on the second PC! How does Amarok record the location of the local collection? The path name is the same on both PCs (/home/music), but is Amarok specifically looking for the local collection to be on a local hard disk and because it's an NFS mount on the second machine it thinks the local collection is missing?

I could not see any clues in the debug messages, unless this means anything:

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
User avatar strohel
KDE Developer
Posts
53
Karma
0
OS
Paul wrote:I did a full rescan on the first PC and now I can see all my tracks there, but now there are no tracks visible on the second PC! How does Amarok record the location of the local collection? The path name is the same on both PCs (/home/music), but is Amarok specifically looking for the local collection to be on a local hard disk and because it's an NFS mount on the second machine it thinks the local collection is missing?
Paul, aren't you actually sharing Amarok database and perhaps config files between the 2 PCs, are you? This is not supported, at least not with Dynamic Collection feature enabled (the dafault). See https://bugs.kde.org/show_bug.cgi?id=273046
User avatar Paul
Registered Member
Posts
16
Karma
0
OS
Yes, that's the answer. I wasn't aware of that bug report. Looks like I'll have to live without Amarok on my second machine :-( Thanks for your help.
User avatar strohel
KDE Developer
Posts
53
Karma
0
OS
Paul wrote:Yes, that's the answer.
We could've helped you much faster if you stated the important information right away.

Paul wrote:I wasn't aware of that bug report. Looks like I'll have to live without Amarok on my second machine :-( Thanks for your help.
Not at all! Just turn off Dynamic collection (see my comments in the bug), or just don't share same MySQL database - a different db name would be okay.
User avatar Paul
Registered Member
Posts
16
Karma
0
OS
For info: I've turned off Dynamic collection and now I get a full track listing on whichever machine most recently ran a full rescan, and no tracks listed on the other machine. Using a different database on each machine is difficult because (as I said) my home drive is shared on both machines so the Amarok config is the same. Don't worry, I'll live with it :-)
User avatar strohel
KDE Developer
Posts
53
Karma
0
OS
Paul wrote:For info: I've turned off Dynamic collection and now I get a full track listing on whichever machine most recently ran a full rescan, and no tracks listed on the other machine.
Please do note that there's Bug #265419 that prevents properly using Amarok with Dynamic Collection off until 2.7 Beta. With 2.7 Beta, it should really work fine. (please try, join #amarok on Freenote IRC if you need help updating, packages for Ubuntu should be available)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bcooksley, Bing [Bot], claydoh, Deusdies, Exabot [Bot], garthecho, Google [Bot], Hans, jpwhiting, La Ninje, Majestic-12 [Bot], Mamarok, MetaNova, MSN [Bot], renatoatilio, rossdv8, Uri_Herrera, Yahoo [Bot], šumski