Reply to topic

Need a little help with building amarok

divyasharma
Registered Member
Posts
1
Karma
0
Hello,

I'm new to KDE.
I'm following the instructions given here http://techbase.kde.org/Development/Tut ... pplication to build amarok.

However, when I run cmake, I get the following:
Code: Select all
divya@divya:~/devel/build/amarok$ sudo cmake -DCMAKE_INSTALL_PREFIX=$KDE_DEVELOPMENT_PATH -DCMAKE_BUILD_TYPE=debugfull ../../src/amarok
-- /home/divya/devel/src/amarok/cmake/modules
-- Taglib found: -L/usr/lib/i386-linux-gnu -ltag
-- Taglib-Extras found: -L/usr/lib -ltag-extras
-- Found Qt-Version 4.8.3 (using /usr/bin/qmake)
-- Found X11: /usr/lib/i386-linux-gnu/libX11.so
-- Found KDE 4.9 include dir: /usr/include
-- Found KDE 4.9 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Checking if the QtScript Qt Bindings are installed.
-- includes /usr/include/qt4/QtCore;/usr/include/qt4/QtScript;/usr/include;/usr/include/KDE;/usr/include/KDE;/usr/include;/usr/include/qt4/phonon;/usr/include/qt4/QtXmlPatterns;/usr/include/qt4/QtXml;/usr/include/qt4/QtWebKit;/usr/include/qt4/QtUiTools;/usr/include/qt4/QtTest;/usr/include/qt4/QtSvg;/usr/include/qt4/QtSql;/usr/include/qt4/QtScriptTools;/usr/include/qt4/QtScript;/usr/include/qt4/QtOpenGL;/usr/include/qt4/QtNetwork;/usr/include/qt4/QtHelp;/usr/include/qt4/QtDesigner;/usr/include/qt4/QtDesigner;/usr/include/qt4/QtDeclarative;/usr/include/qt4/QtDBus;/usr/include/qt4/Qt3Support;/usr/include/qt4/QtGui;/usr/include/qt4/QtCore;/usr/include/qt4/Qt;/usr/share/qt4/mkspecs/default;/usr/include/qt4;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include;/usr/include libraries Qt4::QtScript;Qt4::QtCore;Qt4::QtGui;-L/usr/lib;-lkdecore;-lkdeui
-- QtBindings not found. run `cd cmake/modules/bindingstest; mkdir build; cd build; cmake ..; make; ./bindingstest; echo $?` If it prints '0' then you're actually fine.
-- Found MySQL: /usr/include/mysql, -L/usr/lib/i386-linux-gnu -lmysqlclient -lpthread -lz -lm -lrt -ldl
-- Found MySQL Embedded: /usr/include/mysql, -L/usr/lib/i386-linux-gnu -lmysqld_pic -lpthread -lz -lm -lrt -lwrap -lcrypt -ldl -laio -L/usr/lib/mysql -lpthread
-- Found liblastfm: /usr/include/lastfm, /usr/lib/i386-linux-gnu/liblastfm.so, version 1.0.0
-- checking for one of the modules 'libavcodec'
-- checking for one of the modules 'libavformat'
-- Could NOT find FFmpeg  (missing:  LIBAVCODEC_INCLUDE_DIR LIBAVCODEC_LIBRARY LIBAVFORMAT_INCLUDE_DIR LIBAVFORMAT_LIBRARY LIBAVUTIL_INCLUDE_DIR LIBAVUTIL_LIBRARY)
CMake Warning at /usr/share/kde4/apps/cmake/modules/MacroOptionalFindPackage.cmake:32 (find_package):
  Could not find a configuration file for package "Mygpo-qt" that is
  compatible with requested version "1.0.6".

  The following configuration files were considered but not accepted:

    /usr/lib/cmake/mygpo-qt/Mygpo-qtConfig.cmake, version: 1.0.5

Call Stack (most recent call first):
  CMakeLists.txt:150 (macro_optional_find_package)


--    Include directory: /usr/include/gdk-pixbuf-2.0
-- Found MTP: /usr/lib/i386-linux-gnu/libmtp.so
CMake Error at CMakeLists.txt:180 (message):
  Building with mp3tunes support REQUIRES either OpenSSL or GNU Libgcrypt


-- Found MTP: /usr/lib/i386-linux-gnu/libmtp.so
-- Found X11: /usr/lib/i386-linux-gnu/libX11.so

-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
-----------------------------------------------------------------------------
   * kdelibs - The toolkit Amarok uses to build
   * mysqld - Embedded MySQL Libraries
   * mysql - MySQL Server Libraries
   * zlib - zlib
   * qca2 - Qt Cryptographic Architecture
   * QJson - Qt JSON Parser used for the Playdar Collection
   * liblastfm - Enable Last.Fm service, including scrobbling, song submissions, and suggested song dynamic playlists
   * libgpod - Support Apple iPod/iPad/iPhone audio devices
   * GDK-PixBuf - Support for artwork on iPod audio devices via GDK-PixBuf
   * libmtp - Enable Support for portable media devices that use the media transfer protocol
   * curl - cURL provides the necessary network libraries required by mp3tunes.
   * libxml2 - LibXML2 is an XML parser required by mp3tunes.
   * loudmouth - Loudmouth is the communication backend needed by mp3tunes for syncing.
   * Qt4 Glib support - Qt4 must be compiled with glib support for mp3tunes
   * gobject - Required by libgpod and mp3tunes.
   * glib2 - Required by libgpod and mp3tunes
   * clamz - Optional requirement to download songs from the Amazon MP3 store. Highly recommended on Linux, as the official downloader from Amazon is quite broken on many systems.
   * nepomuk-core - NepomukCore Libraries required by Nepomuk Collection
   * Soprano - Soprano libraries required by Nepomuk Collection
   * taglib - Support for Audio metadata.
   * taglib - Additional support for Audio metadata of mod, s3m, it and xm files.

-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
-----------------------------------------------------------------------------
   * qtscript-qt  <http://code.google.com/p/qtscriptgenerator/>
     QtScript Qt Bindings
   * ffmpeg (0.7 or higher)  <http://www.ffmpeg.org/>
     Libraries and tools for handling multimedia data
   * libmygpo-qt (1.0.6 or higher)  <http://wiki.gpodder.org/wiki/Libmygpo-qt>
     Enable gpodder.net service
   * openssl or libgcrypt  <http://www.openssl.org/ or http://www.gnupg.org/download/#libgcrypt>
     OpenSSL or GNU Libgcrypt provides cryptographic functions required by mp3tunes.

-----------------------------------------------------------------------------

-- Configuring incomplete, errors occurred!


Can somebody help me fix this?

Thanks.
User avatar Mamarok
Manager
Posts
2918
Karma
8
OS
Did you actually read the message? it says
Code: Select all
CMake Error at CMakeLists.txt:180 (message):
  Building with mp3tunes support REQUIRES either OpenSSL or GNU Libgcrypt

So you need to really check if you have all dependencies, the error message at the bottom is equally detailed and tells you exactly what you miss.

I also suggest you follow Amarok's own building instructions, as detailed here: http://community.kde.org/Amarok/Develop ... ment_HowTo, instead of a generic one.
The best choice is to actually use the instructions for the local build, pointing you to my blog: http://blogs.fsfe.org/myriam/2009/09/26 ... l-summary/

Please make sure you remove the distribution package for Amarok beforehand and make sure you follow each of the steps to the letter, especially setting the PATH and environment variables in step 3 and 4 of this instruction:


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day

 
Reply to topic

Bookmarks



Who is online

Registered users: Andreas Mair, Baidu [Spider], Bing [Bot], capslock, cloose, edmael, Exabot [Bot], Google [Bot], GreatEmerald, HmpfCBR, johngates, koriun, Majestic-12 [Bot], piedro, psbot [Picsearch], sledz, Sogou [Bot], TheraHedwig, tparrott, Yahoo [Bot]