Reply to topic

Damaged sound

flightman
Registered Member
Posts
44
Karma
0
OS

Damaged sound

Sat May 11, 2013 4:19 pm
Hi all,

when I play a file in Amarok, the sound is damaged. I don't know how to describe the sound, but it is something like "scratchy". Could this be fixed somehow?
Tested on mp3
OS: OpenSUSE 12.3
KDE: 4.10.2 "release 1"
Amarok: 2.7.0-185.1
Sound backend: VLC (phonon-backend-vlc 0.6.0-1.2)
Notes: Playing the same file in VLC, KMPLayer, even in Dolphin is OK

fli.
User avatar google01103
Manager
Posts
4956
Karma
17
OS

Re: Damaged sound  Topic is solved

Sat May 11, 2013 5:04 pm
1) the vlc backend seems old, you should be able to install 4.6.3git, it's in the playground repo. http://software.opensuse.org/package/phonon-backend-vlc

2) try the gstreamer backend


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS

Re: Damaged sound

Sat May 11, 2013 6:36 pm
As already mentioned: your vlc backend is quite outdated, current is 0.6.3, which came out even before Amarok 2.7.0.
Also try disabling ReplayGain, that could also interfere.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
flightman
Registered Member
Posts
44
Karma
0
OS

Re: Damaged sound

Sat May 11, 2013 7:18 pm
Thank you all for the replies. Unfortunately, the updated version of the vlc backend is not in "stable" repositories (or I didn't find it) and I don't want to mix stable/unstable packages (due to bad experiences from before :) ). However, the gstreamer backend works fine.
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS

Re: Damaged sound

Sat May 11, 2013 8:39 pm
Oh my, how can it not be in the stable repository? It came out several months ago, and long before Amarok 2.7.0 which is from January.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
User avatar google01103
Manager
Posts
4956
Karma
17
OS

Re: Damaged sound

Sat May 11, 2013 8:51 pm
Mamarok wrote:Oh my, how can it not be in the stable repository? It came out several months ago, and long before Amarok 2.7.0 which is from January.

in openSUSE (for whatever reason) it is the Playground repo

better question is where did the old one come from


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
wolfi323
Registered Member
Posts
228
Karma
0
OS

Re: Damaged sound

Sat May 11, 2013 10:53 pm
google01103 wrote:
Mamarok wrote:Oh my, how can it not be in the stable repository? It came out several months ago, and long before Amarok 2.7.0 which is from January.

in openSUSE (for whatever reason) it is the Playground repo

The reason is because VLC is not included in the main distro.
This has changed recently, so for the next openSUSE version phonon-backend-vlc and VLC (without some codecs) will be part of the distro.

better question is where did the old one come from

From Packman I assume. I don't know why they haven't updated it yet, though...

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], cristian.onet, Exabot [Bot], garthecho, Google [Bot], Hans, ingwa, koriun, madcoucal, newtonnickel, ooker, pedrorodriguez, Per, rulet111, Yahoo [Bot]