Reply to topic

Amarok volume change in application has no effect

User avatar Thaodan
Registered Member
Posts
32
Karma
0
OS
I have the issue that when I change the volume of Amarok in itself has no effect, but when I do it in a mixer like KMix or veromix it has a effect.
Additional Amarok sometimes is silenced when the track changes.
I tried to get an message via --debug option, but I go nothing so far.
DE: KDE 4.11
Amarok ver: 2.8
everything is up to date except sip python-sip and python-pyqt
User avatar Mamarok
Manager
Posts
2918
Karma
8
OS
Hm, that totally depends on your hardware configuration, so you should check whether you can change the master channel in KMix.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
User avatar markey
KDE Developer
Posts
2281
Karma
3
OS
Well, no, it doesn't depend on any hardware configuration. Amarok's internal volume is calculated in software by either libVLC or GStreamer.


--
Mark Kretschmann - Amarok Developer
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS
If you are using Pulseaudio, then it could be interfering - is it in use on your system?
Even if it was interfering though, the volume level should still change.


System Settings and Device Actions KCM maintainer
Image
User avatar Thaodan
Registered Member
Posts
32
Karma
0
OS
bcooksley wrote:If you are using Pulseaudio, then it could be interfering - is it in use on your system?
Even if it was interfering though, the volume level should still change.

Yes I use Pulseaudio (4.0).
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS
Which Phonon backend are you using? If it is VLC, please make sure the appropriate Pulseaudio plugin for VLC is installed.


System Settings and Device Actions KCM maintainer
Image
User avatar Thaodan
Registered Member
Posts
32
Karma
0
OS
bcooksley wrote:Which Phonon backend are you using? If it is VLC, please make sure the appropriate Pulseaudio plugin for VLC is installed.

Yes I use the VLC backend, the plugin is installed (or else I had no sound, there's no special package for this in Arch).
User avatar Thaodan
Registered Member
Posts
32
Karma
0
OS
I used phonon-git and phonon-vlc-git I rebuilded both and now everything works fine. I think it was because of the new KDE SC release.

 
Reply to topic

Bookmarks



Who is online

Registered users: afiestas, avishekk, Baidu [Spider], bcooksley, Bing [Bot], bjoernbalazs, brankko, colomar, Cris70, david_edmundson, einar, Exabot [Bot], ggael, Google [Bot], Heiko Tietze, joshaughnessy, ken300, koriun, La Ninje, lueck, Majestic-12 [Bot], metalbrick, mmagnusson, ooker, ozim, paulus3005, rossdv8, seal20, starbuck, stavallo, steltsop, steph, SysGhost, valoriez, vHanda, Yahoo [Bot]