Reply to topic

Connecting to iPhone, iPad or iPod touch failed

jeancf
Registered Member
Posts
3
Karma
0
Hi,

I am running openSUSE 13.1 x64 with KDE 4.11.2 and Amarok 2.8.0.
I have an iPod Touch 8GB version 6.1.3 model MC540NF/A

When I plug in my iPod on the USB port I get the following popup message:
Code: Select all
determined mount-point path to /tmp/kde-jeancf/amarok/imobiledevice_uuid_879e3043b4fc9aea08721566ff1d0abb77f99ded
calling `ifuse "-u" "879e3043b4fc9aea08721566ff1d0abb77f99ded" "-ofsname=afc://879e3043b4fc9aea08721566ff1d0abb77f99ded" "/tmp/kde-jeancf/amarok/imobiledevice_uuid_879e3043b4fc9aea08721566ff1d0abb77f99ded"` with timeout of 10s
command failed to start within timeout
Failed to mount iPhone on /tmp/kde-jeancf/amarok/imobiledevice_uuid_879e3043b4fc9aea08721566ff1d0abb77f99ded


Please help. Thanks.
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
What is the version of libgpod you have? If your iPod is the iPod Nano touch version 6, then it is not supported (yet). For more information, please see also http://www.gtkpod.org/wiki/Libgpod

FWIW: Amarok doesn't mount anything, you need libgpod to mount an iPod or iPhone, ideally in the latest version.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
jeancf
Registered Member
Posts
3
Karma
0
Hello,

Thanks for your quick reply.
It is an iPod Touch, not an iPod Nano Touch. The "About" section of settings show model MC540NF/A.
Here's the information about the libgpod library:

Code: Select all
jeancf@asus:~> sudo zypper se libgpod
Loading repository data...
Reading installed packages...

S | Name           | Summary                                                                      | Type   
--+----------------+------------------------------------------------------------------------------+--------
  | libgpod-devel  | Development files for libgpod                                                | package
  | libgpod-doc    | Documentation for libgpod                                                    | package
  | libgpod-lang   | Languages for package libgpod                                                | package
  | libgpod-sharp  | Library to Manipulate Songs and Playlists Stored on an iPod -- .NET Bindings | package
i | libgpod-tools  | Tools for libgpod                                                            | package
i | libgpod4       | Library to Manipulate Songs and Playlists Stored on an iPod                  | package
  | libgpod4-32bit | Library to Manipulate Songs and Playlists Stored on an iPod                  | package
jeancf@asus:~> sudo zypper if libgpod4
Loading repository data...
Reading installed packages...


Information for package libgpod4:
---------------------------------
Repository: openSUSE-13.1-1.10
Name: libgpod4
Version: 0.8.2-16.1.4
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 665.4 KiB
Summary: Library to Manipulate Songs and Playlists Stored on an iPod
Description:
libgpod is a library meant to abstract access to iPod content. It
provides an easy-to-use API to retrieve the list of files and
playlists stored on an iPod, modify them, and save them back to the iPod.
User avatar strohel
KDE Developer
Posts
53
Karma
0
OS
Hi,
libgpod (and thus Amarok) only supports iPod touch'es "Up to and including the 3rd generation if one song is added with itunes first" -- http://www.gtkpod.org/wiki/Home

It seems to me that your iPod touch is 4th generation - please consult https://en.wikipedia.org/wiki/IPod_touch#Models and see yourself.
jeancf
Registered Member
Posts
3
Karma
0
Too bad. Thanks for your help.

 
Reply to topic

Bookmarks



Who is online

Registered users: 16777216, alake, Baidu [Spider], Bing [Bot], Exabot [Bot], garthecho, Google [Bot], GordieGii, Hans, koriun, Majestic-12 [Bot], mmistretta, nezumi, onesandzeros, Yahoo [Bot]