Reply to topic

Gapless playback not working

lumpy211
Registered Member
Posts
8
Karma
0
OS

Gapless playback not working

Thu May 27, 2010 4:28 pm
I'm running Amarok 2.3.0 on Ubuntu 10.04.

I've ripped The Dark Side of the Moon as flac and tried listening to it in Amarok. There is indeed no audible silence between tracks; however, playback of the current track abruptly stops about a second early and immediately plays the next track.

It plays correctly and gaplessly in Banshee and Rhythmbox, so it is an accurate rip. Is this a known issue, and if so is there a workaround/fix in the works?
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS

Re: Gapless playback not working

Fri May 28, 2010 5:00 am
Which Multimedia backend are you using? System Settings > Multimedia > Backend.


System Settings and Device Actions KCM maintainer
Image
lumpy211
Registered Member
Posts
8
Karma
0
OS

Re: Gapless playback not working

Fri May 28, 2010 12:44 pm
Hi bcooksley,

Thanks for the reply. I'm using the standard Xine backend and have tried the Gstreamer backend as well but it seems that Gstreamer doesn't support gapless at all (massive ~1 second gap between songs).

Thanks again.
lumpy211
Registered Member
Posts
8
Karma
0
OS

Re: Gapless playback not working

Tue Jun 15, 2010 5:07 am
So nobody else has had trouble with this or knows of a workaround? I find that hard to believe...

I've not yet tried this on my Arch64 install because I can't get Amarok running at all on Arch (even after clearing out config files). This is happening on a fresh Ubuntu 10.04 install.
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS

Re: Gapless playback not working

Tue Jun 15, 2010 7:33 am
Just be aware that gapless playback is not supported by default for mp3, this is due to the format and would need a rather extensive workaround.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
lumpy211
Registered Member
Posts
8
Karma
0
OS

Re: Gapless playback not working

Tue Jun 15, 2010 12:38 pm
Mamarok wrote:Just be aware that gapless playback is not supported by default for mp3, this is due to the format and would need a rather extensive workaround.


Please read my first post. This is a FLAC rip.
imre_herceg
Registered Member
Posts
5
Karma
0
OS

Re: Gapless playback not working

Tue Jun 15, 2010 4:17 pm
Well, sorry pal. Amarok (or rather the Xine engine) does not support gapless playback, and it will not either, as the developers believe it does (how they do it, I cannot fathom), and do not want to fix something they do not believe to be broken.
You can see this bugzilla entry for Amarok 1.4 https://bugs.kde.org/show_bug.cgi?id=127652 RESOLVED WORKSFORME, although many people (obviously those who listen to music where gapless is essential) claim that it is not resolved and does not work for them. Since Xine has not implemented proper gapless playback (although they also say they did), obviously Amarok2 cannot do gapless playback.
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS

Re: Gapless playback not working

Tue Jun 15, 2010 8:21 pm
imre_herceg wrote:Well, sorry pal. Amarok (or rather the Xine engine) does not support gapless playback, and it will not either, as the developers believe it does (how they do it, I cannot fathom), and do not want to fix something they do not believe to be broken.
You can see this bugzilla entry for Amarok 1.4 https://bugs.kde.org/show_bug.cgi?id=127652 RESOLVED WORKSFORME

Besides the fact that you are comparing apples with oranges, it definitely did work in Amarok 1.4.x. Also nobody on our side pretended that the xine engine did support gapless playing, I don't know where you get that from.

We are currently working on a new VLC backend that should solve quite some problems of the xine backend, but gapless needs to be implemented separately, which is quite some work, and we don't have enough developer time to do this currently.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
lumpy211
Registered Member
Posts
8
Karma
0
OS

Re: Gapless playback not working

Tue Jun 15, 2010 8:58 pm
Mamarok wrote:
imre_herceg wrote:We are currently working on a new VLC backend that should solve quite some problems of the xine backend, but gapless needs to be implemented separately, which is quite some work, and we don't have enough developer time to do this currently.


Thanks for the reply! That's what I wanted to know :)
imre_herceg
Registered Member
Posts
5
Karma
0
OS

Re: Gapless playback not working

Tue Jun 15, 2010 9:26 pm
Mamarok wrote:Besides the fact that you are comparing apples with oranges, it definitely did work in Amarok 1.4.x. Also nobody on our side pretended that the xine engine did support gapless playing, I don't know where you get that from.


Well, I don't know what you mean by my comparing apples with oranges, Amarok 1.4 with Amarok 2.0? However, gapless playback definitely does not work in Amarok 1.4 on my computer and it never did. And if you read the bugzilla entry I quoted, you can see that only the developers said that gapless worked on their computers, all the other people complained that it did not.
As for the xine gapless playback, you are in contradiction. If Xine does not support gapless playback and Amarok is using the Xine engine, how can Amarok be gapless? Anyway, what I said is that Xine developers claim that they implemented gapless playback in version 1.1.1, but it did not work in 1.1.1, nor in any successive version, just as Amarok developers say Amarok does gapless playback, whereas it does not.
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS

Re: Gapless playback not working

Tue Jun 15, 2010 10:00 pm
Yes, Aamarok 2.x and Amarok 1.5.x have a completely different codebase, engine handling, sound handling, etc. and Amarok 2.x is a complete rewrite, so please do not compare what is not comparable. Gapless playback did work, provided you activate it in the settings.

Also please tell me where Amarok developers told you that gapless does work in Amarok 2.x? Source, please...


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
imre_herceg
Registered Member
Posts
5
Karma
0
OS

Re: Gapless playback not working

Tue Jun 15, 2010 10:32 pm
Mamarok wrote:Gapless playback did work, provided you activate it in the settings.


Well, I'm still using KDE 3.5 and Amarok 1.4.10 on openSUSE 11.1. So I use Amarok and libxine1 1.1.18.1 from the Packman repository.
Amongst the settings I cannot find any entry regarding gapless playback. Do you mean crossfading? I cannot set the duration of crossfading to less than 400 ms, which cuts this amount from the end of the first song. This way I cannot hear a gap, it is true, but not even the end of the song which should go seamlessly into the following. You cannot say this is gapless playback.
If you say Packman breaks gapless playback in Amarok 1.4 (which I doubt) and it works in Kubuntu please tell me which version and I will check it out, because I hate that I cannot get gapless playback in Amarok 1.4, although the developers said it worked and you also say it.
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS

Re: Gapless playback not working

Wed Jun 16, 2010 12:42 am
You are well aware that mp3 can't be played gapless, are you? This is inherent to the format, please see also here: http://en.wikipedia.org/wiki/Gapless_playback

I can't test Amarok 1.4.x and am not really willing to, since we do not support it anymore since more than a year. But I know for sure it worked when I was using Amarok 1.4.10 the last time, except for mp3, where you can't get gapless playing without crossfading. Don't expect miracles.

Also I did not say any of the things you try to put in my mouth, please stop these pointless accusations.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
User avatar Dieter Schroeder
Registered Member
Posts
714
Karma
7
OS

Re: Gapless playback not working

Wed Jun 16, 2010 6:40 pm
@Mamarok:
Same fault over and over again.
You're the only one, who's talking about mp3. The guys are talking about gapless playback of formats supporting it.
Amarok had no trigger to set gapless playback, only crossfade. You've mixed it up once. Do you remember?
And xine doesn't provide correct gapless playback. So no gapless in Amarok, too.
This is not comparing apples and oranges, this is comparing xine with xine.
If the phonon-vlc backend doesn't support proper gapless, you're screwed up again.
I wouldn't post just for posting only. Less is more sometimes.

m0nk


If men could get pregnant, abortion would be a sacrament.
imre_herceg
Registered Member
Posts
5
Karma
0
OS

Re: Gapless playback not working

Thu Jun 17, 2010 2:02 pm
Dieter Schroeder wrote:If the phonon-vlc backend doesn't support proper gapless, you're screwed up again.


Well, I tried vlc 1.1.0-rc1 on my openSUSE and it was not gapless. So my hopes are not high regarding this phonon-vlc backend.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], google01103, Hans, koriun, La Ninje, MSNbot Media, north, odysseus-art, pesto, SecretCode, Sentynel, Yahoo [Bot], z-uo