Reply to topic

Titelanzeige bei Radio-Streams wird nicht aktualisiert

Musikhörer
Registered Member
Posts
51
Karma
0
Nein, habe ich bisher noch nicht probiert. Da ich jetzt aber weiß, daß die Pause beim Start nicht durch eine invalide Konfigurationsdatei von Amarok verursacht wird, stellt sich die Frage, durch welche Einstellung oder welchen Parameter von KDE und/oder X11 sie verursacht wird, und was es mir bringt, wenn ich herausfinde, daß ein andere/neuer Benutzer dieses Problem nicht hat. Dann müsste ich nämlich immer noch sehr viele Dateien überprüfen. Das hört sich nach einer Aufgabe für einen verregneten Urlaub an... ;-)
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
Probiers einfach mal :)


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
Musikhörer
Registered Member
Posts
51
Karma
0
So, hat etwas gedauert, aber jetzt steht fest: neuer Benutzer, altes Spiel! Will sagen: auch ein neuer Benutzer, der Amarok noch nie benutzt hat, erfährt die Gedenkminute beim Starten von Amarok.

Allerdings sind mir folgende Dinge aufgefallen:

1. Die Verzögerung beim Start passiert erst ab dem 2. Start des Programms. Beim 1. Start ist Amarok sofort betriebsbereit.

2. Das Nichtreagieren beim Umschalten auf einen Stream, egal ob von Stream zu Stream (Wechsel der Radio-Station) oder von lokaler Datei auf einen Stream, passiert nur bei dem alten Benutzer.

3. Wenn ich das komplette Verzeichnis ~/.kde/share/apps/amarok/ sowie die Konfig-Dateien ~/.kde/share/config/amarok* lösche, verhält sich Amarok wie bei dem neuen Benutzer beschrieben.

4. Wenn ich Amarok starte und nach der Gedenkminute, wenn Amarok endlich seinen Fensterinhalt zeigt, schließe, sollte es eigentlich in den Systemabschnitt der Kontrollleiste minimieren. Dort taucht es aber nicht auf, obwohl ich das Symbol auf "immer sichtbar" gestellt habe. Erst wenn ich auf der Tastatur eine der Tasten für die Musiksteuerung betätige, erscheint das Symbol von Amarok im Systemabschnitt.

Wenn ich darüber nachdenke, komme ich zu dem Schluss, daß die Probleme mit Amarok ungefähr dann begonnen haben, nachdem ich mein System auf SSD umgestellt habe. Ich habe gelesen, daß eine SSD u.U. einigen Anwendungen Probleme bereiten kann. Könnte hier eine Fehlerquelle liegen, oder bin ich da völlig auf dem falschen Dampfer?
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
Dieser Lockup hat nix mit der SSD zu tun, sondern eher mit dBus, siehe auch diesen Thread: http://lists.kde.org/?l=kde-multimedia& ... 511241&w=2


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
Musikhörer
Registered Member
Posts
51
Karma
0
Da ich kein wirklicher Hardware-Spezialist und auch kein Programmierer bin, habe ich die Erklärung damals auch nicht richtig verstanden. Was ich verstanden habe, ist, daß eine SSD unter Umständen für einige Programme zu schnell sein kann, weil mit so kurzen Antwortzeiten nicht gerechnet wurde, als das Programm geschrieben wurde. Für mich als Laie klingt das durchaus plausibel, aber ob da etwas dran ist, oder ob das totaler Quatsch ist, mag ich nicht zu beurteilen. Aber ich glaube auch Dir, wenn Du sagst, daß Amarok da unschuldig ist.

Ich habe mir zwar die Diskussion, auf die Du verwiesen hast, durchgelesen, aber schlauer bin ich jetzt auch nicht wirklich. ;-) Aber die Quintessenz heißt wohl: dagegen können wir im Moment nichts tun, oder?
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
Ja, leider, das muss upstream, d.h. in dBus und MPRIS gefixt werden.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
Musikhörer
Registered Member
Posts
51
Karma
0
Jetzt bin ich aber ein wenig neugierig und naseweis geworden. Dieser Fehler existierte ja nicht immer. Weiß man (oder frau ;) ) denn schon, wann er sich im dbus-System eingeschlichen hat? Und wenn ja: reicht es denn nicht aus, ältere dbus-Pakete einzuspielen um den Fehler zunächst mal loszuwerden? (Neudeutsch: "downgrade")
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
Oh je, keine Ahnung, da bin ich eindeutig überfragt.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
User avatar Thaodan
Registered Member
Posts
32
Karma
0
OS
Abend, I möchte diesen Artikel mal kurz missbrauchen, wo steht das es ein neues Gstreamer Backend gibt? Ich hab keine Infos über eine Version 4.7 gefunden.
Bei Arch ist eigentlich ja immer das neueste Paket aber dort scheint auch 4.6.3 aktuell zu sein.
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
4.7 ist die nächst kommende Version, noch nicht released. Lies das bitte nochmal genau, die Nummerierung ist bei Mint und Kubuntu leider sehr unübersichtlich, weil irgend ein Paketierer sich vor einiger Zeit mal vertippt hatte, und man nicht nachträglich zurückgehen kann in Versionen. Also steht da auch "4.7.0really4.6.3".


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
User avatar Thaodan
Registered Member
Posts
32
Karma
0
OS
Mamarok wrote:4.7 ist die nächst kommende Version, noch nicht released. Lies das bitte nochmal genau, die Nummerierung ist bei Mint und Kubuntu leider sehr unübersichtlich, weil irgend ein Paketierer sich vor einiger Zeit mal vertippt hatte, und man nicht nachträglich zurückgehen kann in Versionen. Also steht da auch "4.7.0really4.6.3".

OK, ich war schon verwirrt (hatte auch ein Bugfix gehofft der fixt das, dass spielen von ton ab und zu in der Mitte abbricht).
Musikhörer
Registered Member
Posts
51
Karma
0
Hallo!

Ich noch mal...

Also der gstreamer scheint ja nur aus Fehlern zu bestehen: neuerdings bricht die Wiedergabe ab, wenn ich ein USB-Gerät an den Rechner stecke, egal ob Speicher, Telefon, oder Maus. >:(
Dabei hat meine Soundcard überhaupt nichts mit dem USB-Bus zu tun, denn es handelt sich um eine "Soundblaster Live" PCI-Karte.

Stelle ich dagegen in den KDE-Multimedia-Einstellungen das Backend auf VLC, passiert das nicht.
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
Musikhörer wrote:Hallo!

Ich noch mal...

Also der gstreamer scheint ja nur aus Fehlern zu bestehen: neuerdings bricht die Wiedergabe ab, wenn ich ein USB-Gerät an den Rechner stecke, egal ob Speicher, Telefon, oder Maus. >:(
Dabei hat meine Soundcard überhaupt nichts mit dem USB-Bus zu tun, denn es handelt sich um eine "Soundblaster Live" PCI-Karte.

Stelle ich dagegen in den KDE-Multimedia-Einstellungen das Backend auf VLC, passiert das nicht.


Ja, ist leider so, wir können da gar nichts tun. Gstreamer selbst ist schon ein Krampf, und das Phonon-Backend muss das einigermassen zum laufen bringen. Da Programmierarbeit bei KDE nicht bezahlt wird, und die Arbeit mit Gstreamer sehr unangenehm ist für jeden Programmierer, wird sich daran in absehbarer Zeit leider auch nichts ändern. Da hilf auch alles Klagen nichts, sorry.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bcooksley, Bing [Bot], brand, capslock, djarvie, Exabot [Bot], Google [Bot], GreatEmerald, jensreuterberg, jgrulich, jitseniesen, korakios, koriun, Kver, lazyit, lueck, Majestic-12 [Bot], MiceAreVeryNice, NickElliott, TheraHedwig, Tuukka, Yahoo [Bot]