Reply to topic

Krita crashes on creating new document

User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS
I've seen this error on bugs.kde.org and the forum before, it seems to be a problem in an update to the the cinnamon windows manager, not in Krita (as far as I can tell -- I haven't got a mint test system yet).
kettlefish
Registered Member
Posts
3
Karma
0
I checked my update manager history. The only updates I got this morning before running krita were alot of libqt4 packages. The update went from 4:4.8.4 +dfsg-0ubuntu9 to 4:4.8.4 +dfsg-0ubuntu9.1 but I don't seem to be able to force the version without causing alot of problems. Don't know if that helps

Oh forgot to say thanks for the quick reply ;)
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS
I guess I'll have to add another vm to my collection (30+ already) and see whether I can figure out what's going on. But please, in the meantime report the issue to the right place for Mint -- they might be interested, too.
kettlefish
Registered Member
Posts
3
Karma
0
Hello again.

Yes I just installed the mate desktop and krita works fine there, so it must be a cinnamon problem. Thanks for your help, I'll go and moan over there :D
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS
Thanks for testing!
User avatar Deevad
Registered Member
Posts
290
Karma
0
OS
Just happened for UbuntuStudio ; the XFCE 'buntu based distribution I test since a week or two, after a regretful update.
So, after the update ; ( all the qt4 package ) same issue happen to me. Same error, same crash. But with compiled source and master ...

I tried to update all the qt4 package using the Kubuntu backport ppa ; but the newer qt4 libs didn't changed anything to it.
I tried XFCE with or without the native compositor ; same result. I'm a bit stuck. I'll try to install another D.E. on the top for test probably openbox , but this type of issues really make me want to get rid of the 'buntu base desktop. :|


User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Does anyone have a backtrace for this (from the Developer Information tab). It may help in diagnosing a workaround.


System Settings and Device Actions KCM maintainer
Image
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS
I have got a vm setup now where i can reproduce the crash. It has krita lime installed + debug symbols, but i haven't got a build system setup on it yet, which makes tracing the bug a bit harder.
timthefish
Registered Member
Posts
6
Karma
0
Hi I'm having the same issue on xubuntu 13.04 with the regular version and Krita lime.

Krita is my only KDE application so I tried reinstalling all my KDE packages but no luck.

EDIT: I just installed OpenBox and Krita seems to work fine there.

Also another unrelated thing I noticed a while back is that I have many extra Krita entry's in my XF-menue (currently 13 of them).
They are all unselected by default so I only see them when I edit the menu and they don't seem to cause any issues.
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS
User avatar Deevad
Registered Member
Posts
290
Karma
0
OS
Code: Select all
sudo su
su <yourusername>
krita


and ... it works, Krita wont crash ... Why ?


User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS
Hm, I guess because *buntu really messed up something. I guess there is a permissions issue somewhere that causes an X11 error that is caught by an error handler installed by gdk -- and if you're root, you have all permissions.
User avatar Deevad
Registered Member
Posts
290
Karma
0
OS
Image

my last test and infos :
Well, this *buntu error totally crunched my productivity week. I went to Manjaro, and only VC 0.7.2-1 compile fine ( even available as package ) but it crunch Krita compilation. 0.7.0 version crash during compiling ( Animtim warned me ) ; and Krita is too slow without VC here. On OpenSuse, I had problems with printer/scanner and Ubuntu-One not syncing . So, I re-installed various 'Buntu ; for testing ; Installing them and configure them to see how hardware, Cintiq, dual Screen , dual tablet react... Krita from 2.6 till last master won't launch on everything Gnomy from 12.04 to 13.04 , Xfce / Unity / Gnome-Shell / Cinnamon. Too bad for my last XFCE 4.10 setup, I loved it ; UbuntuStudio / MintXFCE / Xubuntu are not usable anymore for me. Btw, Unity and Mint Cinnamon main had a lot of fails with dual screen worflow. Sad for both ; I still really like the design and polished gfx of both.
Lubuntu is ok, as well as openbox and the KDE family : latest Kubuntu 13.04 and Mint KDE 15 ( still RC ) are really not well made and buggy.
openbox --replace for trying to trick XFwm4 ; the XFCE windows manager didn't worked, btw. I tried that too.
I sounds like I 'll come back at the end to my good 'old Linux Mint KDE 14 ( based on 12.10, KDE 4.8 I think )...


User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Hmm, if I read that right you are basically logging back into yourself - indicating this may be an environment based issue.
Can you compare the output of the "env" command under a normal session and when you have switched into your normal user?


System Settings and Device Actions KCM maintainer
Image
User avatar Deevad
Registered Member
Posts
290
Karma
0
OS
Image
Sorry Bcooksley, I can't continue test about this, I'm back on Mint KDE 14, were the bug doesn't affect me ; I also tested Mint KDE 15 Rc , but this one is not stable.
So, I worked on minimal plasma theme and animation ; to make GTK2/GTK3 apps blended into the KDE apps theme ; while keeping a minimal amount of button, rounding, gradient. That's what I liked to my old XFCE sessions.



 
Reply to topic

Bookmarks



Who is online

Registered users: ab4bd, Baidu [Spider], BeS, Bing [Bot], Exabot [Bot], GeekQuack, ggael, ghevan, Google [Bot], google01103, igorm, jensreuterberg, kainz.a, maarten, mmistretta, Nuc!eoN, orbmiser, plfiorini, scummos, searchfgold6789, SecretCode, Steve T, TheraHedwig, Uri_Herrera, vblazquez, Yahoo [Bot]