Reply to topic

[Solved] Missing Brush Strokes

User avatar Ohjin
Registered Member
Posts
26
Karma
0

[Solved] Missing Brush Strokes

Tue Jun 18, 2013 9:30 am
Randomly my brush strokes aren't being picked up my Krita.

I will be sketching away then Ill see that i have started a new stroke, but there is nothing appearing on the canvas.
Even when I add pressure still nothing.
If I lift my pen off the tablet and reapply pressure it will draw a line normally again, this happens every 5/10 lines drawn.

Last edited by Ohjin on Tue Jul 02, 2013 12:48 pm, edited 1 time in total.


User avatar boudewijn
KDE Developer
Posts
1378
Karma
7
OS

Re: Missing Brush Strokes

Tue Jun 18, 2013 10:54 am
Which version of Krita are you using, which OS and which tablet?
User avatar Ohjin
Registered Member
Posts
26
Karma
0

Re: Missing Brush Strokes

Tue Jun 18, 2013 12:52 pm
Thanks for the reply. Im using Version 2.8 Pre-Alpha.

Im using Windows Vista SP2

And Im using an A4 Wacom Intuos 3

I tried a reinstall of Krita, but the same thing happens. Ill try and record a video.


User avatar Ohjin
Registered Member
Posts
26
Karma
0
User avatar JoseConseco
Registered Member
Posts
111
Karma
0

Re: Missing Brush Strokes

Tue Jun 18, 2013 2:43 pm
I can confirm this too. At work on latest windows version, win7 64bit. From time to time Krita is stuck in no draw mode - so I have to right click to get out of brush hang. I use wacom bamboo. I think this problem was present some time ago in older windows version, but then it was happening much more often that it is now.
User avatar Ohjin
Registered Member
Posts
26
Karma
0

Re: Missing Brush Strokes

Wed Jun 19, 2013 8:37 am
Correction: Im using a wacom Intuos 2. Hopefully wont make a difference.


User avatar boudewijn
KDE Developer
Posts
1378
Karma
7
OS

Re: Missing Brush Strokes

Thu Jun 20, 2013 1:24 pm
It shouldn't make a difference -- though when we were fixing the original bug, we saw a lot of difference between versions of wacom drivers.
User avatar Ohjin
Registered Member
Posts
26
Karma
0

Re: Missing Brush Strokes

Thu Jun 20, 2013 5:07 pm
boudewijn wrote:It shouldn't make a difference -- though when we were fixing the original bug, we saw a lot of difference between versions of wacom drivers.


I reinstalled the latest Wacom Intuos 2 Driver, but it made no difference. Im really loving Krita, but the random missing strokes really ruin the flow. It is very annoying.


User avatar Ohjin
Registered Member
Posts
26
Karma
0

Re: Missing Brush Strokes

Thu Jun 20, 2013 5:22 pm
I have tried disabling my second monitor, I have deactivated any processor or gpu tracking software. But I still get the issue.


User avatar Ohjin
Registered Member
Posts
26
Karma
0

Re: Missing Brush Strokes

Fri Jun 21, 2013 12:18 pm
I know your doing everything you can, but it is getting really annoying now. Its stopping me from having any faith in where I'm putting my lines. Is there any updates on this bug at all?


User avatar boudewijn
KDE Developer
Posts
1378
Karma
7
OS

Re: Missing Brush Strokes

Fri Jun 21, 2013 1:00 pm
No... I have been fixing a lot of bugs in the past two days, but I haven't got a system where I can reproduce it, and that makes it really hard to figure out a fix.
User avatar RamonMiranda
Registered Member
Posts
148
Karma
0
OS

Re: Missing Brush Strokes

Fri Jun 21, 2013 2:03 pm
Have you tried to disable the open GL in preferences? is not the best choice but seems to work.


User avatar Ohjin
Registered Member
Posts
26
Karma
0

Re: Missing Brush Strokes

Fri Jun 21, 2013 3:55 pm
RamonMiranda wrote:Have you tried to disable the open GL in preferences? is not the best choice but seems to work.


That was the first thing I did, but didn't seem to help. :(


ghevan
Registered Member
Posts
83
Karma
0
OS

Re: Missing Brush Strokes

Fri Jun 21, 2013 5:21 pm
This happens to me also, it tends to happen most frequently when I'm working with quick and repeated strokes as well as doing very soft pressure strokes. This was an issue to me, but as I become comfortable with the tablet the problem has vastly improved. It probably is related to some threshold, perhaps while the pen is slightly touching the surface it's actually sending, because of the hand shakiness, a lot of on/off events so the software decides to ignore the pen event to save CPU. At least that's my supposition as it has become a non issue (it almost never happens) as I get more confident with the tool.

This never happens with mypaint or gimp, so I'm sure it's software related.

In case it's useful, Im on an Intuos 2, git master


User avatar Ohjin
Registered Member
Posts
26
Karma
0

Re: Missing Brush Strokes

Fri Jun 21, 2013 9:11 pm
I'm glad its not just me then. And you gave a very accurate description of the problem. Thank you. The only difference being, is that as soon as I start to get confidence, Krita misses a stroke, and then I'm left being un confident through fear of when the next missing stroke might occur.



 
Reply to topic

Bookmarks



Who is online

Registered users: AGB, airdrik, alake, Alexa [Bot], anditosan, Artmessiah, asevens, Baidu [Spider], belnac, Bing [Bot], colomar, Exabot [Bot], garthecho, Google [Bot], google01103, GreatEmerald, kainz.a, koriun, La Ninje, MiceAreVeryNice, mmistretta, nezumi, parzt, Philippe44, scummos, SeaJey, SurfFalke, Tuukka, wolfi323, Yahoo [Bot]