Reply to topic

Krita - Keeps Zooming in?

MisterIvy
Registered Member
Posts
8
Karma
0

Krita - Keeps Zooming in?

Fri Jan 10, 2014 1:26 am
Hi, I recently just installed Krita; well, firstly, I had a really tough time installing it onto my laptop in the first place (I really couldn't figure out why, I googled for possible solutions too). Anywho, I ended up getting Krita to finally run, and at the time, I was navigating with my mouse, and I just drew a simple stroke on the canvas with my mouse, and it worked.
Then I tried it with my tablet stylus, and I literally do not know know why, but as soon as my stylus comes in contact with the tablet (with the cursor on the Krita canvas), it just starts zooming in on it's own.
It's really peculiar, and I couldn't find any solutions to it, if anyone knows what the problem could be, please let me know! If you need any additional information I'll try my best to provide it, thanks! :-\
finticemo
Registered Member
Posts
18
Karma
0

Re: Krita - Keeps Zooming in?

Fri Jan 10, 2014 2:08 am
At minimum it's crucial to know your platform (Linux, Mac, Windows) and it wouldn't hurt to know what brand of tablet either.

I personally only know about tablets on Linux. If you are running some flavour of Linux, you can probably run 'xinput list' to get a list of the input devices X knows of, and then do a few other possible things: 'xinput get-button-map <device id number>' (in case button 4/5 events (scrollwheel events, normally used for zooming) have gotten assigned to button #1 of your tablet somehow), 'xinput set-button-map <device id number> [button number] [button number]..' (to fix such a scenario), 'xinput disable <device id>' (some tablets register multiple input devices, and this can interfere with the proper operation of the 'real' tablet device), and finally 'xinput enable <device id>' (in the case where you disabled the wrong device and your pointer is not moving).
MisterIvy
Registered Member
Posts
8
Karma
0

Re: Krita - Keeps Zooming in?

Fri Jan 10, 2014 4:31 am
finticemo wrote:At minimum it's crucial to know your platform (Linux, Mac, Windows) and it wouldn't hurt to know what brand of tablet either.

I personally only know about tablets on Linux. If you are running some flavour of Linux, you can probably run 'xinput list' to get a list of the input devices X knows of, and then do a few other possible things: 'xinput get-button-map <device id number>' (in case button 4/5 events (scrollwheel events, normally used for zooming) have gotten assigned to button #1 of your tablet somehow), 'xinput set-button-map <device id number> [button number] [button number]..' (to fix such a scenario), 'xinput disable <device id>' (some tablets register multiple input devices, and this can interfere with the proper operation of the 'real' tablet device), and finally 'xinput enable <device id>' (in the case where you disabled the wrong device and your pointer is not moving).

Well, I've installed Krita on a Windows pc, and my tablet is Wacom Bamboo Splash. I've heard that there are discrepancies on Krita when using tablets not made by Wacom; but I have a Wacom tablet so I assume that the issue is not my tablet?

Is the method you provided only to be used in Linux?
finticemo
Registered Member
Posts
18
Karma
0

Re: Krita - Keeps Zooming in?

Fri Jan 10, 2014 11:54 am
Yes. X only exists on Linux/Unix, so xinput etc are not available.

However the general button-mapping idea still applies -- your tablet control panel should have a section where you can remap its buttons, and experimenting with that may help.
MisterIvy
Registered Member
Posts
8
Karma
0

Re: Krita - Keeps Zooming in?

Sat Jan 11, 2014 5:19 am
finticemo wrote:Yes. X only exists on Linux/Unix, so xinput etc are not available.

However the general button-mapping idea still applies -- your tablet control panel should have a section where you can remap its buttons, and experimenting with that may help.

Okay, I'll see if I can manipulate anything based on your suggestion, but I'm not exactly tech-savvy so we'll just have to see. Thanks for your suggestion :)

Does anyone know any other possible solutions?
User avatar vascobasque
Registered Member
Posts
49
Karma
0
OS

Re: Krita - Keeps Zooming in?

Sat Jan 11, 2014 10:39 am
I would try the following:

1. Disable the Touchpad of your Laptop if it has one (system settings/hotkey)
2. Disable Windows Multitouch/Gesture Input (Control Panel -> Pen & Touch)
3. Uninstall additional Wacom Applications
4. Reset your wacom Tablet to Default settings or re-install the wacom Driver (check if the driver is up-to-date)
5. Does the tablet work normally in other painting apps (maybe you have artrage as bundled software or you can install mypaint (free) to check that.
6. Navigate to your userfolder of Krita (possibly here - C:\Users\username\AppData\Roaming\.kde\share\apps) and delete the folder named input


MisterIvy
Registered Member
Posts
8
Karma
0

Re: Krita - Keeps Zooming in?

Sat Jan 11, 2014 9:49 pm
vascobasque wrote:I would try the following:

1. Disable the Touchpad of your Laptop if it has one (system settings/hotkey)
2. Disable Windows Multitouch/Gesture Input (Control Panel -> Pen & Touch)
3. Uninstall additional Wacom Applications
4. Reset your wacom Tablet to Default settings or re-install the wacom Driver (check if the driver is up-to-date)
5. Does the tablet work normally in other painting apps (maybe you have artrage as bundled software or you can install mypaint (free) to check that.
6. Navigate to your userfolder of Krita (possibly here - C:\Users\username\AppData\Roaming\.kde\share\apps) and delete the folder named input

Thanks for the suggestion, I'll be sure to try it out ASAP. Also, to answer your question, I've used my tablet on Photoshop CS4 and Paint tool SAI, and it works perfectly.
MisterIvy
Registered Member
Posts
8
Karma
0

Re: Krita - Keeps Zooming in?

Mon Jan 13, 2014 4:07 am
Anyone have any other suggestions?
MisterIvy
Registered Member
Posts
8
Karma
0

Re: Krita - Keeps Zooming in?

Tue Jan 14, 2014 10:13 pm
Bump?
MisterIvy
Registered Member
Posts
8
Karma
0

Re: Krita - Keeps Zooming in?

Sat Jan 18, 2014 11:59 pm
Bump.
MisterIvy
Registered Member
Posts
8
Karma
0

Re: Krita - Keeps Zooming in?

Sun Jan 26, 2014 12:20 am
Bump.
User avatar boudewijn
KDE Developer
Posts
1375
Karma
7
OS

Re: Krita - Keeps Zooming in?

Sun Jan 26, 2014 10:40 am
Sorry, I cannot reproduce that issue, I'm afraid, so I simply can't offer any suggestions...
galley
Registered Member
Posts
1
Karma
0

Re: Krita - Keeps Zooming in?

Fri Mar 28, 2014 3:48 am
I have the same problem as well ! D: I have searched all over for a solution but have found nothing. :(
I'm running on Windows (64bit) and using a wacom bamboo splash tablet.
User avatar Azzart
Registered Member
Posts
16
Karma
0

Re: Krita - Keeps Zooming in?

Fri Mar 28, 2014 12:05 pm
That's what I got when I upgraded the Companion from windows 8 to windows 8.1: reinstalling the latest wacom drivers solved the problem.
You might want to give it a try.

 
Reply to topic

Bookmarks



Who is online

Registered users: AGB, Baidu [Spider], Bing [Bot], boudewijn, colomar, Cris70, einar, Exabot [Bot], gldvorak, Google [Bot], GreatEmerald, jstaniek, ken300, khsien, koriun, Majestic-12 [Bot], metzman, MSN [Bot], odysseus-art, pbCyanide, r2rStep, scummos, seal20, sir_herrbatka, TheraHedwig, Tuukka, Yahoo [Bot]