The Discussions and Opinions forum is a place for open discussion regarding everything related to KDE, within the boundaries of KDE Code of Conduct. If you have a question or need a solution for a KDE problem, please post in the apppropriate forum instead.
Reply to topic

KDE Nvidia Tearing

User avatar xazero
Registered Member
Posts
5
Karma
0
OS

KDE Nvidia Tearing

Mon May 31, 2010 1:22 am
place move my thread if it isnt in the right place. thanks

Hi all

Ive been experiencing tearing (whole screen not only xv) when composite is enabled and the nvidia drivers installed, even if i have vsync turned on (and some other problems like the window title gets messy if using aurorae).

also see

http://ohioloco.ubuntuforums.org/showth ... ?t=1493721
http://www.nvnews.net/vbulletin/showthr ... ost2261238

also i have to say that if i enable the snow effect the tearing completely disappears and the fps plugin says kwin is running exactly at 61 fps (which is the right value) but if i turn of the snow effect the tearing eventually comes back.
that makes me think that only opengl apps are getting the vsync. (and the snow effect makes the whole desktop to be opengl drawn i guess)

BTW anyone knows if they are planing to implement the QT --graphicssystem opengl option? that'd be awesome to have a complete gpu-rendered desktop, and that would fix my problem i believe.

Thanks in advance.

PS
btw do you know if ~/.xinitrc gets sourced in kubuntu?

same behavior in my macbook pro and my hp 311 (same GPU)

HW:macbook pro 5,5
-GPU: nvidia geforce 9400m

SW: Kubuntu 10.04
-nvidia drivers: 195.36.15
-Xorg(server vendor version): 1.7.6
-KDE SC: 4.4.3
-QT:4.6.dontknow

Config:

-xorg.conf
...
Option "NoLogo" "True"
Option "TripleBuffer" "True"
Option "DynamicTwinView" "False"
Option "BackingStore" "True"
Option "RenderAccel" "True"
Option "DamageEvents" "True"
Option "PixmapCacheSize" "1024000"
Option "AddARGBGLXVisuals" "True"
Option "AllowIndirectPixmaps" "True"
...
Driver "nvidia"
...


-~/.xinitrc
export __GL_SYNC_TO_VBLANK=1
#export QT_GRAPHICSSYSTEM=opengl ##I KNOW IT DOESN'T WORK BUT I WISH IT DID
nvidia-settings --load-config-only
nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
. /etc/X11/xinit/xinitrc


kwinrc
[Compositing]
AnimationSpeed=2
Backend=OpenGL
CheckIsSafe=true
DisableChecks=true
Enabled=true
GLDirect=true
GLMode=TFP
GLTextureFilter=2
GLVSync=true
HiddenPreviews=6
RefreshRate=60
UnredirectFullscreen=true
#XRenderSmoothScale=true
...


.nvidia-settings-rc
...
0/SyncToVBlank=1
...
0/OpenGLImageSettings=1 # dont know what's this for
...
0/XVideoTextureSyncToVBlank=1
...


...

Reply to topic

Bookmarks



Who is online

Registered users: AGB, airdrik, alake, Alexa [Bot], anditosan, Artmessiah, asevens, Baidu [Spider], belnac, Bing [Bot], colomar, Exabot [Bot], garthecho, Google [Bot], google01103, GreatEmerald, kainz.a, koriun, La Ninje, MiceAreVeryNice, mmistretta, nezumi, parzt, Philippe44, scummos, SeaJey, SurfFalke, Tuukka, wolfi323, Yahoo [Bot]