The Discussions and Opinions forum is a place for open discussion regarding everything related to KDE, within the boundaries of KDE Code of Conduct. If you have a question or need a solution for a KDE problem, please post in the apppropriate forum instead.
Reply to topic

gnome-terminal automatically resizes to be the minimum size

bmartin
Registered Member
Posts
4
Karma
0
tl;dr skip to the part below =====================

I couldn't ask this question in "Ask a question", apparently, because there's no gnome-terminal available from the selection list. I realize it's a GNOME app and not a KDE app, but the following behavior violates the principle of least surprise, so I'm going to ask anyways.

I'm using Ubuntu 11.10. I just upgraded. To my dismay, GNOME 2 is gone. I find Unity appalling. Despite having been less than impressed with KDE 3, I decided to give KDE 4 a try.

It's excellent! None of the other desktop environments or window managers have cut it for me. The "wave of the future" DEs are grids of icons... I want something a little more classic. I really want KDE to work for me and so far, it looks good.

==================

I like gnome-terminal. I really, really like gnome-terminal. When I open it in KDE, the window animatedly shrinks until it's the minimum size. I've disabled all windows effects, which has caused it to shrink even faster. I can resize it, and sometimes it'll stay resized, but sometimes it doesn't.

Is there a way I can stop this from happening?
User avatar google01103
Manager
Posts
4960
Karma
17
OS
2 thoughts:
1) after resizing the window, right click gnome-terminal title bar -> advanced -> special application settings -> size and position -> size -> apply initially (not real knowledge about all the options so you may need to do some testing especially initially|remember|force)
2) find and rename the gnome-terminal rc file and see if that fixes it

bonus thought:
Konsole, try it - it is really nice


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
bmartin
Registered Member
Posts
4
Karma
0
google01103 wrote:2 thoughts:
1) after resizing the window, right click gnome-terminal title bar -> advanced -> special application settings -> size and position -> size -> apply initially (not real knowledge about all the options so you may need to do some testing especially initially|remember|force)

This worked, though I had to apply the settings a couple times. When I go back and look, the options are unchecked, but my terminal no longer resizes itself.

Thank you for your help!

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], google01103, Hans, koriun, La Ninje, MSNbot Media, north, odysseus-art, pesto, SecretCode, Sentynel, Yahoo [Bot], z-uo