Reply to topic

Nepomuk file indexer is always idle KDE SC 4.10

begonia
Registered Member
Posts
44
Karma
0
OS
After the first start Ksysguard tells me that Nepomuk takes the resources. After quite some time Nepomuk appears to be done. After a reboot it is "virtuoso-t" that constantly uses all of the cpu it can get.
The search and index widget informs me that there is being looked if there are files changed since the last time it looked. Does that take so long?
I read on the internet that there is a cure for this: switching off and on the desktop search and index. I did that. I believe it helped but after rebooting the story repeated itself.
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Unusual, and there are no other processes using the CPU intensively?

Just wondering - is this a clean database with the KDE 4.10 update, and if not, have you run "nepomukcleaner"?
(Be aware, it may take several hours to complete).


System Settings and Device Actions KCM maintainer
Image
begonia
Registered Member
Posts
44
Karma
0
OS
Ksysguard says "virtuoso-t" does.
begonia
Registered Member
Posts
44
Karma
0
OS
What I meant is that after a reboot "virtuoso-t" is taking all system recourses for ever.

Not only did I run the nepomuk cleaner, I completely whiped out the nepomuk folder and akonadi stuff and so on.

But it makes no difference
vHanda
KDE Developer
Posts
21
Karma
0
OS
begonia wrote:What I meant is that after a reboot "virtuoso-t" is taking all system recourses for ever.

Not only did I run the nepomuk cleaner, I completely whiped out the nepomuk folder and akonadi stuff and so on.

But it makes no difference


Could you please provide the following information?

1. Nepomuk Storage backtrace
2. Virtuoso status

The backtrace can be obtained by doing the following -
$ ps aux | grep nepomuk | grep storage
$ gdb --pid <pid>
> thread apply all backtrace

The Virtuoso status command can be run by using isql-vt and then typing status();. If isql-vt is not working for you, you might want to use the script over here - http://techbase.kde.org/Projects/Nepomu ... o_virtuoso
roger_rabbig
Registered Member
Posts
9
Karma
0
OS
Hi everyone,
I have a very similar problem although I have KDE 4.10.1. When I enable Nepomuk the file indexer works very intensively at startup for five minutes then it stops. The file indexer is then "idle" and 0 files have been indexed. When I search for any file via Dolphin or Krunner I get no results. The desktop search is on the folders that nepomuk tries to index are not empty. Does anyone have an idea how I could get Nepomuk working?
Thanks in advance

roger_rabbig
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Is your system running on battery power, or otherwise under high load?


System Settings and Device Actions KCM maintainer
Image
roger_rabbig
Registered Member
Posts
9
Karma
0
OS
No its not running on battery power and also not otherwise under a high load.
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Have you checked http://userbase.kde.org/Nepomuk/FileIndexer to see if anything mentioned there helps?


System Settings and Device Actions KCM maintainer
Image
roger_rabbig
Registered Member
Posts
9
Karma
0
OS
Ok I will check that. One thing I havent mentioned yet is that before I updated nepomuk worked not properly, one thing i did (this is from the kubuntu forum: http://www.kubuntuforums.net/showthread.php?60893-Desktop-Search-issue/page2&highlight=nepomuk) is :
Code: Select all
qdbus org.kde.NepomukServer /nepomukserver org.kde.NepomukServer.quit
rm -rf ~/.kde/share/apps/nepomuk
rm -rf ~/.kde4/share/apps/nepomuk



to clean out the DB. It didnt help on kde 4.9.5 (this was a different problem though). Afterwards I upgraded.
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
That should not have caused an issue in general (as ideally it should have left you with a new Nepomuk database, which was generated by KDE 4.10 based Nepomuk). Did the wiki page suggestions help?

One possible thing I am thinking of is that the new indexing system does not support the types of files you are trying to index.
What are they exactly?


System Settings and Device Actions KCM maintainer
Image
roger_rabbig
Registered Member
Posts
9
Karma
0
OS
Ok so I tried the wiki suggestions it did not change anything. It is still the same: when I enable nepomuk it indexes files for 5 minutes afterwards its idle and 0 files are indexed. The files I am trying to index are mostly .pdf some .tex .bib and some .dta. I cant find any files via Krunner and Dolphin. This is really strange because what I read so far nepomuk seems to be working fine in 4.10.1.
I am unsure how to find the error log file. Where is $KDEDIR on Kubuntu 12.10?
User avatar Ignacio Serantes
Registered Member
Posts
448
Karma
1
OS
You can obtain some information about what nepomukserver is doing running it in console.

1) Open a console.
2) Run "kdebugdialog", check all about nepomuk and accept the changes.
3) Shutdown nepomukserver executin command: "qdbus org.kde.NepomukServer /nepomukserver quit"
4) Wait until command "ps -A | grep nepomukserver" returns an empty line.
5) Run "nepomukserver"

Now you could see all debug information emitted by nepomukserver so you can try to figure what is happening.


Ignacio Serantes, proud to be a member of KDE forums since 2008-Nov.
roger_rabbig
Registered Member
Posts
9
Karma
0
OS
Thanks man! I followed your instructions, if I understand correctly I have an error, the bad thing is that I dont know what to do with it (google answers and error message are way above my newbie skills... :| ) This is what I get and its the same for other files.

Code: Select all
[/usr/bin/nepomukservicestub] nepomukfileindexer(4323)/nepomuk (strigi service) Nepomuk2::BasicIndexingQueue::shouldIndex: "/home/roger_rabbig/Neuer Ordner/LaTeX Hilfestellungen/LaTeX.pdf"
[/usr/bin/nepomukservicestub] nepomukfileindexer(4323)/nepomuk (strigi service) Nepomuk2::BasicIndexingQueue::index: "/home/roger_rabbig/Neuer Ordner/LaTeX Hilfestellungen/LaTeX.pdf"
[/usr/bin/nepomukservicestub] nepomukfileindexer(4323)/nepomuk (strigi service):  SimpleIndexError:  "Cannot set values for abstract property '<http://nepomuk.kde.org/ontologies/2010/11/29/kext#indexingLevel>'."
[/usr/bin/nepomukservicestub] nepomukfileindexer(4323)/nepomuk (strigi service) Nepomuk2::BasicIndexingQueue::slotIndexingFinished: "Cannot set values for abstract property '<http://nepomuk.kde.org/ontologies/2010/11/29/kext#indexingLevel>'."
User avatar Ignacio Serantes
Registered Member
Posts
448
Karma
1
OS
You have and outdated shared desktop ontologies. Are you running KDE 4.10.1?


Ignacio Serantes, proud to be a member of KDE forums since 2008-Nov.

 
Reply to topic

Bookmarks



Who is online

Registered users: Artmessiah, Baidu [Spider], Bing [Bot], Buddlespit, Exabot [Bot], garthecho, Google [Bot], Hans, koriun, La Ninje, valoriez, whatthefunk, Yahoo [Bot]