Reply to topic

Nepomuk file indexer is always idle KDE SC 4.10

roger_rabbig
Registered Member
Posts
9
Karma
0
OS
Kinfocenter says I am running KDE SC 4.10.1.
And according to synaptic i have shared-desktop-ontologies 0.10.0-1
User avatar Ignacio Serantes
Registered Member
Posts
448
Karma
1
OS
Ok, then try to update your version to last git version. Execute next commands in console (you need git installed and probably KDE development packages).
Code: Select all
git clone git://oscaf.git.sourceforge.net/gitroot/oscaf/shared-desktop-ontologies/
cd shared-desktop-ontologies
mkdir build && cd build && cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` -DCMAKE_BUILD_TYPE=Release .. && make && sudo make install

Stop nepomukserver using the method I explained and restart it again in console.

If you have errors compiling then start again removing directory build using command "rm -Rf build"

Check if you don't have error "Cannot set values for abstract property '<http://nepomuk.kde.org/ontologies/2010/11/29/kext#indexingLevel>' in console output.


Ignacio Serantes, proud to be a member of KDE forums since 2008-Nov.
roger_rabbig
Registered Member
Posts
9
Karma
0
OS
Ok i followed your suggestions and i get this:
Code: Select all
[/usr/bin/nepomukservicestub] nepomukfileindexer(8909)/nepomuk (strigi service) Nepomuk2::BasicIndexingQueue::shouldIndex: "/home/roger_rabbig/shared-desktop-ontologies/build/Makefile"
[/usr/bin/nepomukservicestub] nepomukfileindexer(8909)/nepomuk (strigi service) Nepomuk2::BasicIndexingQueue::index: "/home/roger_rabbig/shared-desktop-ontologies/build/Makefile"
[/usr/bin/nepomukservicestub] nepomukfileindexer(8909)/nepomuk (strigi service): SimpleIndexError:  "Cannot set values for abstract property '<http://nepomuk.kde.org/ontologies/2010/11/29/kext#indexingLevel>'."
[/usr/bin/nepomukservicestub] nepomukfileindexer(8909)/nepomuk (strigi service) Nepomuk2::BasicIndexingQueue::slotIndexingFinished: "Cannot set values for abstract property '<http://nepomuk.kde.org/ontologies/2010/11/29/kext#indexingLevel>'."

I have the error : "Cannot set values for abstract property '<http://nepomuk.kde.org/ontologies/2010/11/29/kext#indexingLevel>'."
User avatar Ignacio Serantes
Registered Member
Posts
448
Karma
1
OS
Something still is not updated but I'm don't know if this is a problem with the packages or a problem with your system. :/

Check if all packages related to Nepomuk are installed and check if you have an old Nepomuk package installed doing a mess. I don't know the names in ubuntu but in openSUSE packages are:

nepomuk-core 4.10.1
soprano-backend-virtuoso 2.9.0
virtuoso 6.1.6
strigi 0.7.7

try to remove other Nepomuk related packages not in this list if dependencies allow it.


Ignacio Serantes, proud to be a member of KDE forums since 2008-Nov.
roger_rabbig
Registered Member
Posts
9
Karma
0
OS
I tried to find the packages, nepomuk-core is right and virtuoso as well. I dont know for strigi and soprano-backend-virtuoso since I dont know what their names are in Kubunutu. When I search for "strigi" in Synaptic I have almost all packages installed from version 0.77 (except for developer tools etc.) but none of the packages available is called "Strigi". Same for soprano (packages installed are libsoprano4 and soprano-daemon both version is 2.9.0+1dfsg.1-0ubur)
I have only one package that is old: libnepomuksync4 4:4.9.5-0ubuntu0.1 this is also the latest available package according to synaptic. I removed it without an effect. So its back now.
With regard to removing packages I am a bit scared since i dont know the "real" names of the packages you mentioned.
User avatar Ignacio Serantes
Registered Member
Posts
448
Karma
1
OS
roger_rabbig wrote:With regard to removing packages I am a bit scared since i dont know the "real" names of the packages you mentioned.

Names can vary between linux distributions so this is not a problem.

Try to locate other KDE packages with version 4.9 and if it's safe and don't remove any application you need try to delete all. Finally try to restart again with a fresh database without data.


Ignacio Serantes, proud to be a member of KDE forums since 2008-Nov.
roger_rabbig
Registered Member
Posts
9
Karma
0
OS
Ok, it works. I have 9133 indexed files and a working nepomuk, that thing is genious once it works.

Thank you very much Ignacio Serantes and bcooksley!!!

Here is what I did:
before i read Ignacios last post I completly reinstalled my laptop with kubuntu 12.10 amd 64 (kde 4.9.5) here Nepomuk worked. Then I got KDE 4.10.1 from the kubuntu backports. Afterwards nepomuk was dead again.
As suggested by Ignacio i searched for other 4.9 kde-packages and removed libokularcore1abi1 4:4.9.5 and python3-kde4 4:4.9.4 then wiped out the database and restarted then it worked.
User avatar Ignacio Serantes
Registered Member
Posts
448
Karma
1
OS
Good to know. Please mark the entry as solved.


Ignacio Serantes, proud to be a member of KDE forums since 2008-Nov.

 
Reply to topic

Bookmarks



Who is online

Registered users: afiestas, avishekk, Baidu [Spider], bcooksley, Bing [Bot], bjoernbalazs, brankko, colomar, Cris70, david_edmundson, einar, Exabot [Bot], ggael, Google [Bot], Heiko Tietze, joshaughnessy, ken300, koriun, La Ninje, lueck, Majestic-12 [Bot], metalbrick, mmagnusson, ooker, ozim, paulus3005, rossdv8, seal20, starbuck, stavallo, steltsop, steph, SysGhost, valoriez, vHanda, Yahoo [Bot]