Reply to topic

Akonadi / Kmail2 / KDE 4.11

blue_tiger300
Registered Member
Posts
11
Karma
0
OS

Akonadi / Kmail2 / KDE 4.11

Sun Aug 25, 2013 12:01 pm
Until recently I had indexing (email and files) turned off. With the announced improvements I got curious and enabled this feature.
Unfortunately I ran into the following bug https://bugs.kde.org/show_bug.cgi?id=323929 (comments 3 and 4)
At the moment it looks like a problem with akonadi and IMAP accounts. Has anybody an idea on how to debug this problem ?
I don't have a problem with only my POP account and google contacts setup in akonadi. The problems start when one or more IMAP accounts are added. Then akonadi seems to get into an infinite loop and never recovers.
Has anyone an idea on how to debug this situation ? The debug information from akonadiconsole did not reveal anything useful (at least for me).
Thanks
Peter


Kubuntu 12.10 / KDE 4.11 from backports ppa
blue_tiger300
Registered Member
Posts
11
Karma
0
OS

Re: Akonadi / Kmail2 / KDE 4.11

Sun Aug 25, 2013 7:48 pm
Got the following workaround which also worked for me. I won't mark this issue as solved as I am not sure if this will be permanent.
--- Comment #6 from arcanis
Who gets this bug try:
mv ~/.local/share/akonadi/ ~/.local/share/akonadi_old
akonadictl restart
And try to start kmail. It works for me.


Kubuntu 12.10 / KDE 4.11 from backports ppa
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Akonadi / Kmail2 / KDE 4.11

Mon Aug 26, 2013 8:02 am
Considering that all that is contained in ~/.local/share/akonadi/ is the internal state of Akonadi - namely it's cache of your PIM data, I suspect this is likely a temporary fix. Please update this topic and the bug report if the behaviour recurs for you again so we can investigate further as to the cause.


System Settings and Device Actions KCM maintainer
Image
blue_tiger300
Registered Member
Posts
11
Karma
0
OS

Re: Akonadi / Kmail2 / KDE 4.11

Mon Aug 26, 2013 11:10 am
The workaround seems to be permanent. I have restarted my machine twice since I applied the fix and kontact is back to a useable state. I can access my IMAP accounts and email indexing is also enabled.
I am on Kubuntu 12.10 and I have done several KDE upgrades through the backports ppa, it makes me believe that this faulty behaviour was caused by a residual mysql DB schema.
Are there any steps you want me to go through for a further evaluation of the problem ?
best regards
Peter


Kubuntu 12.10 / KDE 4.11 from backports ppa
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Akonadi / Kmail2 / KDE 4.11

Tue Aug 27, 2013 8:41 am
At this point it is fairly hard to determine the cause of the issue considering it is now functioning correctly - good to hear it does appear to be a permanent fix though. It is probably bad handling of data stored by a older version of Akonadi, which is not 100% valid.


System Settings and Device Actions KCM maintainer
Image
blue_tiger300
Registered Member
Posts
11
Karma
0
OS

Re: Akonadi / Kmail2 / KDE 4.11

Thu Aug 29, 2013 12:12 pm
Hello Ben, "Murphy's law" just struck me. The akonadiserver just got into a loop again.
Well I can get around this with the fix, but it makes no sense to scrap the akonadi DB every now and then. I can see the akonadiconsole looping, but I can't really figure out where it hangs.
Is there a documentation somewhere or can you guide me through this ?
Thanks
Peter


Kubuntu 12.10 / KDE 4.11 from backports ppa
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Akonadi / Kmail2 / KDE 4.11

Fri Aug 30, 2013 8:10 am
I'm afraid there is no documentation available as such. Does Akonadi Console indicate what it is trying to do when it gets into a loop?


System Settings and Device Actions KCM maintainer
Image
blue_tiger300
Registered Member
Posts
11
Karma
0
OS

Re: Akonadi / Kmail2 / KDE 4.11

Sat Aug 31, 2013 2:28 pm
That's the problem. Akonadiconsole shows a lot of information once the debugger is enabled. I have tried to parse the saved log file for the usual strings (error, problem, etc), but it doesn't shows anything useful.
But the good news is that the most likely associated bug has been set to "confirmed" (https://bugs.kde.org/show_bug.cgi?id=323929).
Best regards


Kubuntu 12.10 / KDE 4.11 from backports ppa
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Akonadi / Kmail2 / KDE 4.11

Mon Sep 02, 2013 10:13 am
As the bug has been confirmed (particularly if it was done so by a developer, rather than by popular vote), I would suggest you follow it as workarounds or information on when a solution will be made available will likely be posted there.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, brand, doublerainbow64, edmael, Exabot [Bot], franku, Google [Bot], Hans, i4dnf, jgrulich, jstaniek, khsien, koriun, lazyit, lbaran, Majestic-12 [Bot], metzman, MiceAreVeryNice, MSNbot Media, nezumi, ooker, pedrorodriguez, Tuukka, Yahoo [Bot]