Reply to topic

KDE 4.2 locks up at startup when starting Akonadi server

wellofsouls
Registered Member
Posts
1
Karma
0
I have just upgraded to KDE 4.2 today, using the Arch Linux pacman package manager, and out of five times, four times it locks up immediately after login, with something called "kres-migrator" running and starting Akonadi server, and then everything freezes :-(

Any idea how to solve this problem?
User avatar lukrop
Registered Member
Posts
1
Karma
0
OS
I'm using archlinux on two machines and this problem didn't occur :/
User avatar anda_skoa
KDE Developer
Posts
777
Karma
4
OS
Open Systemsettings -> Advanced Tab -> Akonadi configuration.

Does it report any Error?

On its second tab it has the possibility for a self test. Try to run that and post the test log.

Cheers,
_


anda_skoa, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
Are you running any 3D effects? Additionally, does the Caps lock key still respond?

Last edited by bcooksley on Fri Jan 30, 2009 12:52 am, edited 1 time in total.


System Settings and Device Actions KCM maintainer
Image
lanzinc
Registered Member
Posts
1
Karma
0
I have the same problem

it said just like this that "akonadi server can not regist on dbus".

after about 1 min , the mouse is active ,but no any panel on the desktop.
In output of ps can find the "plasma"
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
Assuming that you have no data in Akonadi, it would be safe to destroy its configuration and data files ( they could be corrupt )

Code: Select all
killall mysqld & killall akonadictl & killall akonadi_control & killall akonadiserver & rm -rf ~/.config/akonadi/ & rm -rf ~/.local/share/akonadi


System Settings and Device Actions KCM maintainer
Image
User avatar mossgix
Registered Member
Posts
7
Karma
0
OS
Same problem, but I've noticed that turning off 3d acceleration the problem didn't occur.


Don't look back.
Image
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
This means it is probably unrelated to Akonadi.

All those affected: Distro + Graphics card please.


System Settings and Device Actions KCM maintainer
Image
User avatar anda_skoa
KDE Developer
Posts
777
Karma
4
OS
And for those having problems starting Akonadi server:
if you are running Kubuntu, check that the Akonadi Server Configuration (Systemsettings -> Advanced Tab -> Akonadi Configuration ->second tab) has the Kubuntu override executable mysqld-akonadi set.

We've had reports that it would still be mysqld and thus causing problems with Kubuntu's AppArmor Setup.

Cheers,
_


anda_skoa, proud to be a member of KDE forums since 2008-Oct.
User avatar mossgix
Registered Member
Posts
7
Karma
0
OS
bcooksley wrote:This means it is probably unrelated to Akonadi.

All those affected: Distro + Graphics card please.


Kubuntu

nvidia geforce 8600GT


Don't look back.
Image
markus46
Registered Member
Posts
2
Karma
0
OS
Same problem here.
"Akonadi control process not registered at D-Bus"
Distro ArchLinux+kdemod
Graphics = nvidia but no 3D. Composite enabled.

Luckily however, my system doesn't hand when this happens.

Self-test report follows...
Akonadi Server Self-Test Report
===============================

Test 1: SUCCESS
--------

Database driver found.
Details: The QtSQL driver 'QMYSQL' is required by your current Akonadi server configuration.
The following drivers are installed: QSQLITE, QMYSQL3, QMYSQL, QODBC3, QODBC, QPSQL7, QPSQL.
Make sure the required driver is installed.

File content of '/root/.config/akonadi/akonadiserverrc':
[%General]
Driver=QMYSQL

[QMYSQL]
Name=akonadi
User=
Password=
Options="UNIX_SOCKET=/root/.local/share/akonadi/db_misc/mysql.socket"
ServerPath=/usr/sbin/mysqld
StartServer=true


Test 2: SUCCESS
--------

MySQL server found.
Details: You currently have configured Akonadi to use the MySQL server '/usr/sbin/mysqld'.
Make sure you have the MySQL server installed, set the correct path and ensure you have the necessary read and execution rights on the server executable. The server executable is typically called 'mysqld', its locations varies depending on the distribution.

Test 3: SUCCESS
--------

MySQL server is executable.
Details: MySQL server found: 090208 15:44:18 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
090208 15:44:18 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
/usr/sbin/mysqld Ver 5.0.75 for pc-linux-gnu on i686 (Source distribution)


Test 4: SUCCESS
--------

No current MySQL error log found.
Details: The MySQL server did not report any errors during this startup into '/root/.local/share/akonadi/db_data/mysql.err'.

Test 5: SUCCESS
--------

MySQL server default configuration found.
Details: The default configuration for the MySQL server was found and is readable at /usr/share/config/akonadi/mysql-global.conf.

File content of '/usr/share/config/akonadi/mysql-global.conf':
#
# Global Akonadi MySQL server settings,
# These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf
#
# Based on advice by Kris Köhntopp
#
[mysqld]
skip_grant_tables
skip_networking

# strict query parsing/interpretation
# TODO: make Akonadi work with those settings enabled
#sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_user,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes_as_concat
#sql_mode=strict_trans_tables

# use InnoDB for transactions and better crash recovery
default_storage_engine=innodb
# case-insensitive table names, avoids trouble on windows
lower_case_table_names=1
character_set_server=latin1
collation_server=latin1_general_ci
table_cache=200
thread_cache_size=3
log_bin=mysql-bin
expire_logs_days=3
#sync_bin_log=0
# error log file name, relative to datadir
log_error=mysql.err
log_warnings=2
# log all queries, useful for debugging but generates an enormous amount of data
#log=mysql.full
# log queries slower than n seconds, log file name relative to datadir
log_slow_queries=mysql.slow
long_query_time=1
# log queries not using indices, debug only, disable for production use
log_queries_not_using_indexes=1
# maximum blob size
max_allowed_packet=32M
max_connections=256
# makes sense when having the same query multiple times
# makes no sense with prepared statements and/or transactions
query_cache_type=0
query_cache_size=0

innodb_file_per_table=1
innodb_log_buffer_size=1M
innodb_additional_mem_pool_size=1M
# messure database size and adjust
# SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema");
innodb_buffer_pool_size=80M
# size of average write burst, keep Innob_log_waits small, keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables)
innodb_log_file_size=64M
innodb_flush_log_at_trx_commit=2



Test 6: SKIP
--------

MySQL server custom configuration not available.
Details: The custom configuration for the MySQL server was not found but is optional.

Test 7: SUCCESS
--------

MySQL server configuration is usable.
Details: The MySQL server configuration was found at /root/.local/share/akonadi/mysql.conf and is readable.

File content of '/root/.local/share/akonadi/mysql.conf':
#
# Global Akonadi MySQL server settings,
# These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf
#
# Based on advice by Kris Köhntopp
#
[mysqld]
skip_grant_tables
skip_networking

# strict query parsing/interpretation
# TODO: make Akonadi work with those settings enabled
#sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_user,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes_as_concat
#sql_mode=strict_trans_tables

# use InnoDB for transactions and better crash recovery
default_storage_engine=innodb
# case-insensitive table names, avoids trouble on windows
lower_case_table_names=1
character_set_server=latin1
collation_server=latin1_general_ci
table_cache=200
thread_cache_size=3
log_bin=mysql-bin
expire_logs_days=3
#sync_bin_log=0
# error log file name, relative to datadir
log_error=mysql.err
log_warnings=2
# log all queries, useful for debugging but generates an enormous amount of data
#log=mysql.full
# log queries slower than n seconds, log file name relative to datadir
log_slow_queries=mysql.slow
long_query_time=1
# log queries not using indices, debug only, disable for production use
log_queries_not_using_indexes=1
# maximum blob size
max_allowed_packet=32M
max_connections=256
# makes sense when having the same query multiple times
# makes no sense with prepared statements and/or transactions
query_cache_type=0
query_cache_size=0

innodb_file_per_table=1
innodb_log_buffer_size=1M
innodb_additional_mem_pool_size=1M
# messure database size and adjust
# SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema");
innodb_buffer_pool_size=80M
# size of average write burst, keep Innob_log_waits small, keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables)
innodb_log_file_size=64M
innodb_flush_log_at_trx_commit=2



Test 8: SUCCESS
--------

akonadictl found and usable
Details: The program '/usr/bin/akonadictl' to control the Akonadi server was found and could be executed successfully.
Result:
Akonadi Control: stopped
Akonadi Server: stopped


Test 9: ERROR
--------

Akonadi control process not registered at D-Bus.
Details: The Akonadi control process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.
User avatar anda_skoa
KDE Developer
Posts
777
Karma
4
OS
Hmm, strange.

Is there probably more than one Akonadi version installed?

If you run qdbus in a terminal window, does it show any Akonadi processes?

If not, does

% akonadictl start

report errors?

Cheers,
_


anda_skoa, proud to be a member of KDE forums since 2008-Oct.
markus46
Registered Member
Posts
2
Karma
0
OS
The results of trying to start the akonadi service from the console gave me the clue. I got a message about starting the mysql deamon as root. Didn't I mention I was logged on as root? :)

Anyway, logging on as a regular user works fine. I can stop & start the service from the command line or from the System Settings application. I see org.freedesktop.Akonadi.Control and org.freedesktop.Akonadi in qdbus.

Thanks heaps!

Mark

anda_skoa wrote:Hmm, strange.

Is there probably more than one Akonadi version installed?

If you run qdbus in a terminal window, does it show any Akonadi processes?

If not, does

% akonadictl start

report errors?

Cheers,
_
msdark
Registered Member
Posts
1
Karma
0
OS
(sorry for my english)
It's strage... if i suspend the graphics effect akonadi server start succesfully, but with graphics effect enabled.. akonadi don't work...
and nepomunk too...
User avatar JanGerrit
Moderator
Posts
647
Karma
3
OS
Moved to Office & Productivity.


Image

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], Majestic-12 [Bot], mmistretta, MSNbot Media, onesandzeros, shmerl, Uri_Herrera, Yahoo [Bot]