Reply to topic

Desktop Effects no longer work after new card and monitor

ProtoJazz
Registered Member
Posts
2
Karma
0
For the past year or so Ive been using Linux Mint with KDE and had it set up the way I wanted it, The border around my windows was translucent, so was my taskbar, as well as the background on my konsole windows.

Last Night I installed a new graphics card (An additional one.) And set up a 3rd monitor. It looked just fine untill I noticed the few wigits I had previusly on the 2nd monitor were gone, and each of the monitors was its own seprate workspace with no ability to move windows from one to the other. Feeling this defeated the purpose of additional monitors I enabled Xininema. And that got them to flow like I wanted them to, but now none of my desktop effect work. If I switch the rendeing mode to xrenderer They work. But all 3 monitors show the same thing as monitor 1, and there still seems to be aditional displays I cant see. As In I can move windows off to the right, but never see where they go. If I do switch to xrender I can not switch back to open gl. It refuses to switch, or if it does it does not allow me to activate anything.

Im running 2 Nvidia GTX 550 ti 's, not sli. Im just not sure what the problem could be, I mean I didnt change all that much. And if it worked with one I dont see how having 2 could sudenly be a massive driver isse. But Then again Im not really an expert on linux yet so I cant really say.

Any help would be appreciated. I greatly enjoy having transparency available
luebking
Registered Member
Posts
928
Karma
7
A splendid multi-gpu X.

1. you'll not be able to run a single desktop across 2 GPUs. Period.
Ie. if you attach one screen to one GPU and another one to the other GPU, you'll be stuck on multihead and therefore see https://bugs.kde.org/show_bug.cgi?id=256242 (while actually no longer really a problem in the WM, dbus and therefore global shortcuts and whatnot don't work correctly)

2. The problem about transparency is that kwin (the WM) temporarily tags compositing as broken (atm) during startup, so if the driver crashes, it will not attempt to activate it again.
Unfortunately for two screens (multihead, NOT multiscreen) the two kwin instances operate on the same settings, so if they're started at the same time, one will run into the "compositing is broken" flag of the other. Restart kwin on that screen (or start them scheduled)

You can expect the situation to be worse on other Desktop Environments.
Long story short: multihead for single users on X11 does not really work and for sure not out of the box :-(
ProtoJazz
Registered Member
Posts
2
Karma
0
Hmmm... I had not read anything about multi head vs multi screen before, at least now I have a better idea of what to search for. From what I've read X cinema I'd want I don't really want a giant twin view kind of thing.

What would be the best way or how would I get kwin to start without crashing or disabling composting?

This might also be a good time to sample some of the other desktops Linux offers. I started with gnome/kde and preferred kde. But I guess one of the downsides is I like kde so much lve never tried anything else despite how easy it is.
luebking
Registered Member
Posts
928
Karma
7
What would be the best way or how would I get kwin to start without crashing or disabling composting?

If it actually crashes at startup: file a bug containing the crashtrace.
Otherwise delaying the start of the second kwin instance by a couple of seconds (1-3) should do.

 
Reply to topic

Bookmarks



Who is online

Registered users: afiestas, avishekk, Baidu [Spider], bcooksley, Bing [Bot], bjoernbalazs, brankko, colomar, Cris70, david_edmundson, einar, Exabot [Bot], ggael, Google [Bot], Heiko Tietze, joshaughnessy, ken300, koriun, La Ninje, lueck, Majestic-12 [Bot], metalbrick, mmagnusson, ooker, ozim, paulus3005, rossdv8, seal20, starbuck, stavallo, steltsop, steph, SysGhost, valoriez, vHanda, Yahoo [Bot]