Reply to topic

Configuring the KDE 4.8 pager not to be "live"?

HippoMan
Registered Member
Posts
5
Karma
0
I'm using KDE 4.8 under linuxmint 13, and I have an issue with the pager widget that I'm wondering if anyone can help me with.

Within the pager widget, there are "shadows" of all of the applications which are open in each virtual desktop. We're able to drag those shadows around, and this causes the corresponding applications to move around on their desktops.

I'd like to disable this functionality, because I often end up accidentally moving my application windows when all I want to do is click on a pager indicator in order to switch to a different desktop. I realize that this unwanted behavior is simply due to the clumsiness of my mouse usage; nonetheless, I'd like to disable it, since I doubt I'll be able to improve the over-all dexterity of my fat fingers. :)

I can't find any options in the pager's configuration screen which control this "live" behavior, and I'm hoping there might be some other way to turn off this functionality.

Any thoughts or suggestions?

Thanks in advance.

Last edited by HippoMan on Sat Nov 24, 2012 9:12 pm, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
Unfortunately a check of the code reveals there is no setting to disable this behaviour.
However - what you could do instead is increase the "Drag start distance" in System Settings > Input Devices > Mouse > Advanced which may help alleviate the issue to an extent.


System Settings and Device Actions KCM maintainer
Image
HippoMan
Registered Member
Posts
5
Karma
0
Thank you very much.

I'll see if the mouse's "Drag start distance" setting might indeed mitigate this problem for me.

If it doesn't, I'm thinking of diving into the KDE source code and hacking my own version of the pager widget. There will be a learning curve, since I haven't ever looked at the KDE source, but it will be a fun, long-term project for me.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
If you are looking into customising the codebase, you are after the Git repository "kde-workspace", folder "plasma/desktop/applets/pager". You probably want to change the code in pager.cpp, around line 833.


System Settings and Device Actions KCM maintainer
Image
HippoMan
Registered Member
Posts
5
Karma
0
Thank you very much! That will save me a lot of time.

 
Reply to topic

Bookmarks



Who is online

Registered users: Alastair, apater, Baidu [Spider], Bing [Bot], Exabot [Bot], garthecho, ggael, Google [Bot], google01103, Horus, jitseniesen, Joif, kde-jriddell, ken300, La Ninje, Mamarok, mmistretta, Nuc!eoN, psbot [Picsearch], rbruce, renatoatilio, sacarde, sinclair, stephans, TheraHedwig, tienhung, wolfi323, Yahoo [Bot]