Reply to topic

Application defaults: seems badly mangled

janpla
Registered Member
Posts
41
Karma
0
I have been wasting a few hours now, trying to set the default PDF reader to evian; I like KDE, but I don't like the default PDF reader. But it does not change anything; I have been into system settings, deleted all references to anything but evince - no difference. I have even deleted the default package with Synaptic; now the default is GIMP when I click on a PDF link in IceWeasel. I mean seriously? If I remove GIMP, will it then default to Inkscape or vim?

I would like to understand where this kind of nonsense comes from in the system, and I would very much like to sort it out, so I can use my computer without feeling aggrieved and insulted. I think it is bad when GNOME or Windows begin to look attractive.

The system is Debian 6.0.6, with whatever version of KDE it comes with, on AMD64.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Please find out the version of KDE - it is available from any KDE application at Help > About KDE.

Which areas in System Settings did you change? The appropriate place to go would be System Settings > File Associations > [ select application/pdf ].
If this is what you did, please try running in a terminal:
Code: Select all
kbuildsycoca4 --noincremental


You can ignore any output generated by that command. Afterwards, logout and back in again to ensure everything is fully applied.


System Settings and Device Actions KCM maintainer
Image
janpla
Registered Member
Posts
41
Karma
0
Hi bcooksley;

My KDE is version 4.4.5.

I've tried both your redommendations, but it didn't make any difference.

I went to System Settings -> Advanced User Settings -> File Associations -> application/pdf, where it says 'Document viewer'. I checked in 'Edit' that this is evince.

I ran 'kbuildsycoca4 --noincremental' - the last message was:

kbuildsycoca4(2667) KBuildServiceFactory::createEntry: Invalid Service : "/usr/share/applications/kde4/koffice.desktop"

- I'm not sure if that matters, but it made no difference. It is all a bit bizarre.

AQnyway, thank you for trying to help, I appreciate that.
luebking
Registered Member
Posts
922
Karma
7
ignoring that 4.4.5 is *slightly* dated (no idea about possible bugs), the main question is
"how do you attempt to open the pdf" (dolphin, bash, ...)

in dolphin rightclick a pdf file, select "open with" (is evince in that list at all?) and click "other..."
in the dialog select evince from the menu entries and check to remember the assignment.

Next comes an update progress dialog and afterwards pdf files should be opened in evince and you should have the link configured in ~/.local/share/applications/mimeapps.list (so also ensure you actually have writing permissions on that file)
janpla
Registered Member
Posts
41
Karma
0
Hi luebking,

Where I have the problem is Iceweasel, I don't use Dolphin or Konqueror; there are two entries in Iceweasel's settings concerning PDF:

PDF Document (application/pdf) - set to '"Always ask"
PDF Document (application/save-as) - set to '"Always ask"

This seems to work, in that it always asks me, by displaying a dialog. In the dialog I can choose between 'Open with' and 'Save'; evince is listed under 'Open with', so the problem is minimal, but annoying, especially since it seems that it ought to be a simple thing to get it to work. If I choose 'Open with' and evince, it remembers this setting until I choose to save instead; after that, when I click on a link to a PDF file, the 'Open with' option shows anything but evince, which I will have to find in the drop-down.

And it really seems to be 'anything but' evince; initially it would show 'Kooka', I believe. I removed that from the installation, and it showed something else, which I removed, and now it suggests GIMP. One could easily get the impression that somebody has gone out of their way to make sure that you don't use evince. Yes, it is absurd, I know.
luebking
Registered Member
Posts
922
Karma
7
Iceweasel is debians Firefox fork - i have no idea where it takes its idea about mimetypes from, but apparently evince is not listed there.
The funny part is that this is a problem between evince and iceweasel, KDE is not part of that game at all (neither uses any KDE library)

You'd best ask iceweasrl/FF devs what they account for those application list or simply strace & grep iceweasel for "suspicious" files (cont. "appl" or "mime")
My wild guess is that your copy of evince comes w/o a deskto service file and the one you create with the fairly dated KDE settings dialog places it into some ~/.kde subdir where iceweasel doesn't look for it.
But that's impossible to say w/o looking into the system.

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], boudewijn, colomar, edmael, Exabot [Bot], garthecho, Google [Bot], google01103, Hans, jitseniesen, ken300, koriun, mayankasthana, mgraesslin, mixoff, mmistretta, pedrorodriguez, scummos, SeaJey, SecretCode, Sentynel, Sogou [Bot], urgo, Yahoo [Bot]