Reply to topic

Get rid off "white selection line" / "focus indicator"

User avatar fakd
Registered Member
Posts
176
Karma
0
OS
Hello,
how do I get rid off the "white selection line" or whatever it is called, see below screenshot for better explanation:
Image

I already looked in the system settings, but couldn't find the option.

TIA
richard

Last edited by fakd on Mon Mar 18, 2013 7:27 pm, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Which application appearance style are you using? This "white selection line" is likely created by it (using colours from your selected colour set).


System Settings and Device Actions KCM maintainer
Image
User avatar fakd
Registered Member
Posts
176
Karma
0
OS
bcooksley wrote:Which application appearance style are you using? This "white selection line" is likely created by it (using colours from your selected colour set).
The screenshot was with "caledonia6" AFAIK. Now I have Honeycomb and it is still white. However, I don't care about the color - I just don't want to see this line at all!

You write there is a setting in the color set, do you know which one it is? - I couldn't find it. Maybe it is possible then to change the color to none?
User avatar scummos
KDE Developer
Posts
613
Karma
4
OS
I think this line is drawn by oxygen, and I think its purpose is to indicate the item which currently has keyboard focus. I don't know of an option to disable it currently. But I agree that it looks a bit ugly in some widgets ;)

Greetings,
Sven


User avatar Hans
Administrator
Posts
3120
Karma
20
OS
System Settings -> Application Appearance -> (Style ->) Configure... button (next to "Oxygen") -> Views tab -> uncheck "Draw focus indicator".

The major thing you'll miss, in my opinion, is the selection indicator in Dolphin (e.g. when you've selected a file and want to select other files using Ctrl+arrow keys and space). I personally don't like the white line so I've disabled it.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
User avatar fakd
Registered Member
Posts
176
Karma
0
OS
Hans wrote:System Settings -> Application Appearance -> (Style ->) Configure... button (next to "Oxygen") -> Views tab -> uncheck "Draw focus indicator".
Ah, thanks Hans - that did the trick!

Hans wrote:The major thing you'll miss, in my opinion, is the selection indicator in Dolphin (e.g. when you've selected a file and want to select other files using Ctrl+arrow keys and space). I personally don't like the white line so I've disabled it.
Ah, true, thats also the first occurence where I noted that current selection and keyboard focus doesn't coincide.
Maybe it would be useful to have an option "Draw focus indicator only when it doesn't coincide with selection" or it should be limited to useful applications...
User avatar Hans
Administrator
Posts
3120
Karma
20
OS
fakd wrote:Maybe it would be useful to have an option "Draw focus indicator only when it doesn't coincide with selection" or it should be limited to useful applications...


You could suggest it, although I can understand if the developers think that's too many options. Instead of adding another option, why draw it when it's not needed? "Draw focus indicator only when it doesn't coincide with selection" should be the default behavior (unless I'm missing something).


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], brand, cylverbak, dgraf, Exabot [Bot], garthecho, glepore70, Google [Bot], google01103, Hans, jensreuterberg, kainz.a, koriun, Kver, La Ninje, mcaceres, MrGlaceon, MSNbot Media, nezumi, pbCyanide, pedrorodriguez, SecretCode, starbuck, Steve T, tparrott, Yahoo [Bot], šumski