Reply to topic

No internet after resume from hibernation (wlan1)

User avatar google01103
Manager
Posts
4959
Karma
17
OS
after resuming from hibernation NetWorkManager daemon is running but there is no internet (wlan1)

killing and then restarting NetWorkManager brings back internet access

when using a wired connection this was not an issue but the router has been relocated and must use wireless

resuming from suspend is not a problem, internet is there

there is an appropriate bug report but it is not confirmed nor duplicatable https://bugs.kde.org/show_bug.cgi?id=247890

NetworkManage 0.9.4.0
NetworkManager-kde4-libs 0.9.2.65
libQtNetworkManager 0.9.0


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Just to isolate this to either NetworkManager or KDE - does logging out and back in again have any impact?


System Settings and Device Actions KCM maintainer
Image
User avatar google01103
Manager
Posts
4959
Karma
17
OS
logging out and logging back in does not help


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Unfortunately there is not much that can be done at the KDE level then (as it is a defect in NetworkManager or the kernel driver).
Does reloading the kernel driver (rmmod <modname> && sleep 5s && modprobe <modname>) kick any life into NetworkManager?


System Settings and Device Actions KCM maintainer
Image
User avatar google01103
Manager
Posts
4959
Karma
17
OS
I was hoping to be able to use nmcli with notifications and "lost wireless network" -> run command -> "nmcli nm wifi on" but that doesn't bring it back

will try modprode at next boot


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar google01103
Manager
Posts
4959
Karma
17
OS
# modprobe -r cfg80211
FATAL: Module cfg80211 is in use.


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar google01103
Manager
Posts
4959
Karma
17
OS
fyi - this issue has gone away, wondering if resolved by up'ing kernel to 3.7 series


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
'cfg80211' was likely the wrong module. On my system, I have to kick the 'ath9k' module (as my machine has a Atheros card). I actually added this into a /etc/pm/sleep.d/ script, so it is done automatically.

If you want to determine the appropriate driver to remove, then search the output of "lspci -vv", which will contain this information.
It very well could have been fixed by a kernel update.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], asevens, Baidu [Spider], Bing [Bot], bjoernbalazs, Exabot [Bot], Google [Bot], GordieGii, Hans, isadora, koriun, lueck, Majestic-12 [Bot], mmistretta, MSNbot Media, nezumi, Yahoo [Bot]