Reply to topic

Thunderbird still opens links in Firefox

kde-deshmukh
Registered Member
Posts
63
Karma
0
I am running KDE 4.10.3 on Ubuntu 13.04.

In my default applications, I have set-up rekonq as default web-browser.

For emails, I use thunderbird. Every time I click on any link in an email, it is opened in Firefox.

How do I get thunderbird to open links in rekonq -- default web-browser?
User avatar google01103
Manager
Posts
4966
Karma
17
OS
as T-bird is not a KDE app it might be getting the default browser elsewhere
what is
Code: Select all
 printenv|grep browser


You can also try this Ubuntu thread http://askubuntu.com/questions/130158/h ... n-chromium


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar metzman
Registered Member
Posts
84
Karma
2
OS
kde-deshmukh wrote:I am running KDE 4.10.3 on Ubuntu 13.04.

In my default applications, I have set-up rekonq as default web-browser.

For emails, I use thunderbird. Every time I click on any link in an email, it is opened in Firefox.

How do I get thunderbird to open links in rekonq -- default web-browser?


Hi,

To set the browser(s) from within Thunderbird. Not exactly intuitive... and I don't have rekonk installed.

First:
Edit > Preferences > Attachments > Incoming
Then:
For 'Content Type(s)' http https
From the 'Action' Dropdown Menu select 'Use Other' (Opens File Picker)

Image

Navigate to the location of rekonk and select.
rekonk should now be set as the default 'Action'


Image 13.1 ~ KDE 4.12 --- Regards, Paul ---

If it isn't broken yet, then you've not fixed it enough. ;)
kde-deshmukh
Registered Member
Posts
63
Karma
0
Here are answers to both the comments.

@google1103:

printenv | grep browser
output is blank, empty.

@metzman

Edit - Preferences - Attachments - Incoming does not have http/ https as an item. There is no button/ link to add one either!

What needs to be done now?
User avatar google01103
Manager
Posts
4966
Karma
17
OS
close Thunderbird
in konsole:
Code: Select all
export BROWSER=/usr/bin/rekonq
thunderbird

note: T-bird must be opened in the same Konsole tab as the export command
if the above works you would need to add the export line to your .bashrc

also, did you try the Ubuntu thread I linked to in my earlier post


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar metzman
Registered Member
Posts
84
Karma
2
OS
kde-deshmukh wrote:@metzman
Edit - Preferences - Attachments - Incoming does not have http/ https as an item. There is no button/ link to add one either!
What needs to be done now?


Should only be necessary to click on an URL in an existing T-Bird e-mail. As in the example below, clicking on 'Part Num.' brings up the dialogue box.

Image

Failing that, in your T-Bird profile directory, normally ~/.thunderbird/xxxxxxxx.default/ where xxxxxxxx is a random string. Close T-Bird and Back-up 'mimeTypes.rdf'. Temporarily replace it with the following:

Code: Select all
<?xml version="1.0"?>
<RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#"
         xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
  <RDF:Description RDF:about="urn:scheme:handler:https"
                   NC:alwaysAsk="true">
    <NC:possibleApplication RDF:resource="urn:handler:local:/usr/bin/firefox"/>
    <NC:externalApplication RDF:resource="urn:scheme:externalApplication:https"/>
  </RDF:Description>
  <RDF:Description RDF:about="urn:scheme:http"
                   NC:value="http">
    <NC:handlerProp RDF:resource="urn:scheme:handler:http"/>
  </RDF:Description>
  <RDF:Description RDF:about="urn:scheme:handler:http"
                   NC:alwaysAsk="true">
    <NC:possibleApplication RDF:resource="urn:handler:local:/usr/bin/firefox"/>
    <NC:externalApplication RDF:resource="urn:scheme:externalApplication:http"/>
  </RDF:Description>
  <RDF:Description RDF:about="urn:root"
                   NC:en-GB_defaultHandlersVersion="-1"
                   NC:en-US_defaultHandlersVersion="-1" />
  <RDF:Description RDF:about="urn:mimetypes">
    <NC:MIME-types RDF:resource="urn:mimetypes:root"/>
  </RDF:Description>
  <RDF:Description RDF:about="urn:scheme:externalApplication:https"
                   NC:prettyName="firefox"
                   NC:path="/usr/bin/firefox" />
  <RDF:Seq RDF:about="urn:schemes:root">
    <RDF:li RDF:resource="urn:scheme:http"/>
    <RDF:li RDF:resource="urn:scheme:https"/>
  </RDF:Seq>
  <RDF:Description RDF:about="urn:scheme:externalApplication:http"
                   NC:prettyName="firefox"
                   NC:path="/usr/bin/firefox" />
  <RDF:Description RDF:about="urn:handler:local:/usr/bin/firefox"
                   NC:prettyName="firefox"
                   NC:path="/usr/bin/firefox" />
  <RDF:Description RDF:about="urn:schemes">
    <NC:Protocol-Schemes RDF:resource="urn:schemes:root"/>
  </RDF:Description>
  <RDF:Description RDF:about="urn:scheme:https"
                   NC:value="https">
    <NC:handlerProp RDF:resource="urn:scheme:handler:https"/>
  </RDF:Description>
  <RDF:Seq RDF:about="urn:mimetypes:root">
  </RDF:Seq>
</RDF:RDF>


Restart T-Bird, hopefully you will then have both http and https content types listed, from there, as my first post.

If that fails... Sorry, clean out of ideas.


Image 13.1 ~ KDE 4.12 --- Regards, Paul ---

If it isn't broken yet, then you've not fixed it enough. ;)
kde-deshmukh
Registered Member
Posts
63
Karma
0
@google01103

OK. The Ubuntu thread did provide the solution.

Here is what I did:

The right way to do it now is open your about:config (from the menu: Edit > Preferences > Advanced). Open the Configuration Editor and search for both network.protocol-handler.warn-external.http and network.protocol-handler.warn-external.https. These two are most likely to have a value of false. Change it to true and the next time you’ll try to open a link from some e-mail it’ll ask you which browser to use. Chromium isn’t likely to be shown in the list of choices, so use the navigate button. You can find Chromium at /usr/bin/chromium-browser.

Post-that, on clicking a link, it asked me what application do I want to use. On selecting /usr/bin/rekonq, on saving my preference, it opens links in Rekonq.

I also get a file-type as http in Preferences - Attachments - Incoming. I can set it back and forth now.

Thanks!!

 
Reply to topic

Bookmarks



Who is online

Registered users: Alastair, apater, Baidu [Spider], Bing [Bot], Exabot [Bot], garthecho, ggael, Google [Bot], google01103, Horus, jitseniesen, Joif, kde-jriddell, ken300, La Ninje, Mamarok, mmistretta, Nuc!eoN, psbot [Picsearch], rbruce, renatoatilio, sacarde, sinclair, stephans, TheraHedwig, tienhung, wolfi323, Yahoo [Bot]