Reply to topic

Konqueror (KHTML), left click does not work on Duck Duck Go

User avatar google01103
Manager
Posts
4970
Karma
17
OS


using webkit


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar Dimitrios
Registered Member
Posts
644
Karma
0
OS
Ok, i set webkit as default engine and it worked
Better, now it works with khtml too
:)
Sorry for the little noise that i made.


«The magic continues...»
http://www.mageia.org
Image
User avatar Dimitrios
Registered Member
Posts
644
Karma
0
OS
Finally i have always the same problem. After some restarts the problem comes back.
I filled a bug report here:
https://bugs.kde.org/show_bug.cgi?id=318456
also i took a video of the behaviour:
http://glenbox.free.fr/files/searchbar.ogv 6.7M


«The magic continues...»
http://www.mageia.org
Image
User avatar zuargo
Registered Member
Posts
60
Karma
0
OS
Dimitrios wrote:But you can have other engine than google as default in the search bar (at the top right of konqueror) ?)


I can, no issues here, with this.

Dimitrios wrote:If i uncheck google, in the searchbar after restart konqueror there is no engine selected by default (at the top right bar)


What does mean that? Can you show us it with a snapshot?
User avatar Dimitrios
Registered Member
Posts
644
Karma
0
OS
Yes it is like this:
Image

No search engine. I type something inside, i press enter and nothing happens

Now, i found a solution, i replace the url of the Google with the url of duckduckgo, so it says Google , but the url is this of duckduckgo and the icon too.


«The magic continues...»
http://www.mageia.org
Image
User avatar zuargo
Registered Member
Posts
60
Karma
0
OS

Thu Apr 18, 2013 3:01 pm
My experience by years using KDE, says me, these "little" issues, are due to how the different distros packs the KDE software. I think, this is why only you have the issue, and me and other users not.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
This quite possibly occurs because the relevant web shortcut is not marked as "Preferred" - can you check that setting?


System Settings and Device Actions KCM maintainer
Image
User avatar Dimitrios
Registered Member
Posts
644
Karma
0
OS
If you mean here:
http://bugsfiles.kde.org/attachment.cgi?id=78963
it is done already


«The magic continues...»
http://www.mageia.org
Image
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
Unusual - does this occur with engines other than Duck Duck Go such as Wikipedia?


System Settings and Device Actions KCM maintainer
Image
User avatar Dimitrios
Registered Member
Posts
644
Karma
0
OS
Yes this happens with all engines. Only this one of google can be by default
I asked other users with Mageia 2 , and they can reproduce it. But they cannot with the next version of Mageia (3).


«The magic continues...»
http://www.mageia.org
Image
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
Okay, this is very likely to be a packaging issue with Mageia 2 then, or a bug specific to the versions of Qt / KDE used in Mageia 2. I could not reproduce the issue here - I got the general web page icon when it did not have an appropriate icon for the site, and that was switched automatically for the appropriate site icon after my first Konqueror visit to that site.


System Settings and Device Actions KCM maintainer
Image
User avatar Dimitrios
Registered Member
Posts
644
Karma
0
OS
I installed Mageia 3 with kde 4.10.2 and i have the same problem, i cannot switch to search engines , i have always google as default.
I deleted the section
[SearchBar]
from konquerorrc, and now i have the duckduckgo engine as default, this is good. If try to switch to another engine, this is impossible now. After restart it has always the duckduckgo.
However in konquerorrc i have no [SearchBar] entry now.

Normaly it has to write something in the config file.
I see from the code that it prefers to set google first:
http://quickgit.kde.org/?p=kde-baseapps ... rchbar.cpp


«The magic continues...»
http://www.mageia.org
Image
User avatar Dimitrios
Registered Member
Posts
644
Karma
0
OS
I loaded the profile 'borwse with tabs' and since then it works fine.
Even if i change profile to 'browse' it still works
so everything is ok
:)


«The magic continues...»
http://www.mageia.org
Image
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
I suspect this was likely caused by Konqueror having lost the configuration of the current profile you were using - preventing it from writing the preferences properly.


System Settings and Device Actions KCM maintainer
Image
User avatar Dimitrios
Registered Member
Posts
644
Karma
0
OS
I did this before (i tried to load other profiles) without succes but before delete the [SearchBar] entry, or something like this , i dont remember excactly the order because i tried for 3 - 4 hours now 8) ...


«The magic continues...»
http://www.mageia.org
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], bjoernbalazs, braystacey, Dimitrios, edmael, einar, Exabot [Bot], flotho, Google [Bot], google01103, ivan, Joif, ken300, maarten, Majestic-12 [Bot], mmistretta, nezumi, peje, rdong, SecretCode, skywolfblue, stephans, Steve T, TheraHedwig, tienhung, Yahoo [Bot]