Reply to topic

Monitor resolution not recognized when using extension cable

Duber
Registered Member
Posts
10
Karma
0
After adding a VGA extension cable krandrtray recognizes less resolution modes than before. Specifically, I used to have my monitor at 1280x1024 and 75Hz and now its capped and automatically set during boot at 1024x768 at 60 Hz.

If I take away the cable extension the 1280 resolution is recognized again, and if I put back the extension after the 1280 was recognized, it is maintained. But after rebooting with the extension cable 1280 is missing again.

I have temporally fixed this by manually adding a new mode with xrandr and forcing it to be used:
Code: Select all
xrandr --newmode "1280x1024" 138.75  1280 1368 1504 1728  1024 1027 1034 1072 -hsync +vsync
xrandr --addmode VGA-0 1280x1024
xrandr --output VGA-0 --mode 1280x1024

Also, I obtained the details for the new mode from:
Code: Select all
cvt 1280 1024 75


Any idea how could I get the system to recognize the proper resolutions again ? Or how to set up the 1280 resolution from boot instead of changing it afterwards by the means of xrandr ?

Thanks in advance
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
One question that comes to my mind: did you check the cable?


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
Duber
Registered Member
Posts
10
Karma
0
Mamarok wrote:One question that comes to my mind: did you check the cable?

What do you mean ? The cable is not broken and seems to be properly connected. I have found its not uncommon that with some cables the resolutions are not properly recognized.

Yet those resolutions that are not recognized still works if you manage to set them up. I'm looking how could I extend the range of available resolutions beyond those recognized by the system.

Thanks for your time
User avatar bcooksley
Administrator
Posts
18592
Karma
83
OS
The detection of resolutions depends on the passing of EDID data from the monitor to the graphics card/computer. The behaviour you are reporting indicates that the cable is failing to allow this crucial data to be exchanged. It is likely therefore that certain pins are not wired in the cable, or the cable is damaged partially.


System Settings and Device Actions KCM maintainer
Image
Duber
Registered Member
Posts
10
Karma
0
bcooksley wrote:The detection of resolutions depends on the passing of EDID data from the monitor to the graphics card/computer. The behaviour you are reporting indicates that the cable is failing to allow this crucial data to be exchanged. It is likely therefore that certain pins are not wired in the cable, or the cable is damaged partially.

I see, thank you for the information. I supposed it had to be something like that.

Any idea how can I force the system to set a specific resolution at startup ?
User avatar bcooksley
Administrator
Posts
18592
Karma
83
OS
You should be able to do this by adding a executable script into ~/.config/autostart/ with the appropriate xrandr commands to add the mode lines and change the resolution.

Be aware that this may cause startup to take slightly longer (you could also move it into ~/.kde4/env/ which will run much sooner, before the KDE splash screen runs even).


System Settings and Device Actions KCM maintainer
Image
Duber
Registered Member
Posts
10
Karma
0
I was looking to set the resolution at the time its recognized during boot instead of changing it afterwards, but anyway your answer will make it for now.

Thanks

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], apater, Baidu [Spider], bcooksley, Bing [Bot], eagleton, Exabot [Bot], Google [Bot], google01103, GreatEmerald, hmethorst, khsien, koriun, La Ninje, lazyit, Majestic-12 [Bot], SecretCode, Sentynel, Steve T, urgo, Yahoo [Bot]

cron