Reply to topic

No sound in KDE applications after upgrade to SuSE 12.3

benbrewster
Registered Member
Posts
9
Karma
0
I have just upgraded to SuSE 12.3. I now find I have no sound in KDE applications (Amarok, etc.) or Firefox, or KDE system sounds, though all worked fine in SuSE 12.2. (I am now using KDE 4.10.00). The Audio Setup dialog only offers "Dummy Output" for Audio playback, the test button produces no sound, and the Audio Hardware Setup has the sound card button greyed out and the Sound Device button highlighted but unresponsive. The Phonon back end is GStreamer. On the other hand, YaST's hardware configuration detects the sound card as AMD-811 AC97 Audio with driver snd_intel8x0, and the test button gives the test sound OK, so presumably there is nothing wrong with the hardware. (The sound isn't muted, either--I did once spend weeks puzzling about absence of sound only to find it was muted on boot-up, but this isn't the case now.)

Ben
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
Please check that you do not have some missing packages, as Firefox for example doesn't use Phonon, Amarok does. Somewhere in your basic sound installation something is wrong. Have a look at the installation of Alsa and Pulseaudio in particular.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
User avatar bcooksley
Administrator
Posts
18577
Karma
83
OS
It may also help to remove ~/.pulse/ outside KDE, as the Pulseaudio configuration may be incompatible.


System Settings and Device Actions KCM maintainer
Image
benbrewster
Registered Member
Posts
9
Karma
0
Removing ~/.pulse and then rebooting made no difference--there was still no sound, and all the configuration dialogues looked the same. The alsa and pulseaudio packages all seem to be installed, and for the main packages the files listed for them in the packagemanager are all there. Should I uninstall and reinstall these packages, or some of them (if the latter, which would you recommend)?

Ben
User avatar google01103
Manager
Posts
4956
Karma
17
OS
can you test with a new user


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
benbrewster
Registered Member
Posts
9
Karma
0

Fri Apr 19, 2013 7:48 pm
I created a new user and logged in as that user. The situation with sound was just the same: no sound, and the only option in device preference for sound and video configuration was "Dummy Output".
User avatar google01103
Manager
Posts
4956
Karma
17
OS

Fri Apr 19, 2013 10:16 pm
I would try a force reinstall all the pulse and phonon packages making sure all required packages were installed

This is a list of what I have installed (some may not be required):

    phonon-backend-vlc-0.6.3git.1360397092-39.1.x86_64
    phonon-backend-gstreamer-0_10-4.6.3-31.1.x86_64
    libphonon4-32bit-4.6.0-95.4.x86_64
    libphonon4-4.6.0-95.4.x86_64

    pulseaudio-equalizer-2.7rev4-1.3.noarch
    libpulse0-32bit-3.0-1.6.1.x86_64
    alsa-plugins-pulse-32bit-1.0.26-1.1.2.x86_64
    vlc-aout-pulse-2.0.6-116.2.x86_64
    pulseaudio-module-x11-3.0-1.6.1.x86_64
    pulseaudio-3.0-1.6.1.x86_64
    libpulse-mainloop-glib0-3.0-1.6.1.x86_64
    pulseaudio-utils-3.0-1.6.1.x86_64
    libpulse-mainloop-glib0-32bit-3.0-1.6.1.x86_64
    libxine2-pulse-1.2.2-83.2.x86_64
    libpulse-devel-3.0-1.6.1.x86_64
    alsa-plugins-pulse-1.0.26-1.1.2.x86_64
    libpulse0-3.0-1.6.1.x86_64


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18577
Karma
83
OS
It may also help to check the permissions of /dev/snd, as well as the output of "aplay -l".
Your user may need to be added to the relevant groups, likely 'audio'.


System Settings and Device Actions KCM maintainer
Image
benbrewster
Registered Member
Posts
9
Karma
0

Sat Apr 20, 2013 4:26 pm
ls -l /dev/snd gave the directory as
drwxr-xr-x 2 root root
and the files in it as
crw-rw---- 1 root audio 116

and alsa -l gave: device_list:267: no sound cards found ...

I'm a bit out of my depth as to how to add my username to the group audio, which I suppose is what I need to do. Yast's user and group management module only lists users as a group for my username, though /etc/group (accessed as user) has a long list, including audio:x:17:pulse.How should I proceed?

Ben
User avatar google01103
Manager
Posts
4956
Karma
17
OS
yast -> security and users -> user and group mgt -> select user -> edit (bottom of window) -> details tab -> additional groups -> check groups you wish to be incuded in

note: I only have pulse as a member of group=audio and pulse as the only member of group=pulse, so I don't think this is you problem (though it could be a solution)


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
benbrewster
Registered Member
Posts
9
Karma
0

Sat Apr 20, 2013 6:53 pm
It worked. I added my username to groups audio and pulse in the way suggested, rebooted, and the Audio Setup dialogue could now see the sound card, and when I had put it as top choice, the sound system worked.

Many many thanks.

Best wishes

Ben
cmevoli
Registered Member
Posts
1
Karma
0
I had the same problem after doing a system update. My sound was working fine until I did my latest update and then I had the dummy sound problem. When logged in as my userid, I would get no devices found with:

Code: Select all
aplay -l


If I ran it as root it would show my sound cards. After adding my userid to the audio group it fixed my problem.

My question is what changed? Did something change in the security with a patch? All I did was reboot after the patch and no sound. My userid was not in the audio group before and it worked fine after installing the initial os release.

I'm using Opensuse 12.3 as well.
User avatar bcooksley
Administrator
Posts
18577
Karma
83
OS
It is very likely that a security patch was applied to the system that restricted access to the audio devices - and which caused you to lose audio support.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Alexa [Bot], Baidu [Spider], Bing [Bot], Blingy, Deevad, edmael, einar, Exabot [Bot], garthecho, Google [Bot], google01103, GreatEmerald, haroldtejada, jfredrickson, koriun, lazyit, legnaVI, Majestic-12 [Bot], newtonnickel, parzt, pedrorodriguez, Tuukka, W3C [Validator], Yahoo [Bot]