Reply to topic

skanlite problem

luislupe
Registered Member
Posts
2
Karma
0
OS

skanlite problem

Wed Sep 22, 2010 11:05 pm
Hi,

I'm using Slackware64 13.1, an upgrade from 13.0.
In 13.0, skanlite worked well with my Epson CC-570L flatbed scanner.
In 13.1, when I run it with `skanlite -d epson` it works fine.
But when I run it with no -d option, it opens a dialog box so that I can choose from:
1. Epson: CC-570L epson2:libusb:006:003
2. Noname: Acer Crystal Eye webcam v4l:/dev/video0

I choose 1 (as normally I did in 13.0), and when I press the scan button I get an error: "Invalid argument".

In /etc/sane.d/ I have, among others, two files:
# cat epson.conf | grep -v '^#'
usb
usb /dev/usbscanner1

and

# cat epson2.conf | grep -v '^#'
usb
usb /dev/usbscanner1

In /dev there is no usbscanner1, though.

What should I change to have it working fine?
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: skanlite problem

Thu Sep 23, 2010 4:24 am
Have you checked your configuration using sane-test?


System Settings and Device Actions KCM maintainer
Image
luislupe
Registered Member
Posts
2
Karma
0
OS

Re: skanlite problem

Thu Sep 23, 2010 4:43 pm
Thank you for your answer, but I couldn't perform the tests.

$ scanimage -d test
scanimage: output is not a file, exiting

$ scanimage --test
libusb couldn't open USB device /dev/bus/usb/001/001: Permission denied.
libusb requires write access to USB device nodes.
(several others)
libusb couldn't open USB device /dev/bus/usb/008/002: Permission denied.
libusb requires write access to USB device nodes.
scanimage: sane_start: Invalid argument

xscanimage test
opens a dialog window but it does not scan when I press the button 'scan'.

What else should I try?

Luis
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: skanlite problem

Fri Sep 24, 2010 4:03 am
This looks like either a permissions problem for saned ( which should be either running as a daemon or via xinetd ) or a general breakage in SANE.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], boudewijn, colomar, edmael, Exabot [Bot], garthecho, Google [Bot], google01103, Hans, jitseniesen, ken300, koriun, mayankasthana, mgraesslin, mixoff, mmistretta, pedrorodriguez, scummos, SeaJey, SecretCode, Sentynel, Sogou [Bot], urgo, Yahoo [Bot]