Reply to topic

Kaffeine/Dragon Player problems-Mplayer/VLC no problems

User avatar jdkaye
Registered Member
Posts
16
Karma
0
OS
I think all the relevant information is here.
Summary:
Kaffeine: Video No Audio
Dragon Player: Audio No video
Details:
Debian Wheezy 3.0.0-6.dmz.1-liquorix-amd64
Using Alsa not Pulse
01:00.1 Audio device: ATI Technologies Inc RV710/730
Subsystem: ASUSTeK Computer Inc. Device aa38
Kernel driver in use: HDA Intel
01:00.0 VGA compatible controller: ATI Technologies Inc RV710 [Radeon HD 4350]
Subsystem: ASUSTeK Computer Inc. Device 02a8
Kernel driver in use: radeon
Phono Audio Output HDA ATI SB (ALC887 Analog)
cat /proc/asound/cards
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfbdf4000 irq 16
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xfbeec000 irq 44


KDE 4.6.5
Kaffeine v.1.2.2

video works 2 secs
audio device unavailable window appears and stops the film

Dragon Player 2.0
audio works fine
no video

VLC
both audio and video work

MPlayer
both audio and video work

KMplayer
Phonon Movie Player
audio works fine
no video
Mplayer Movie Player
both audio and video work

GMplayer
Works with X11(Ximage/Shm)
Works with X11/Xv
Works with OpenGL
X11/VIDIX sound no video
VDPAU sound no video
User avatar jdkaye
Registered Member
Posts
16
Karma
0
OS
Ok, it turns out that the Kaffeine problem is distinct from the Phonon problem. Don't you love it when two unrelated problems appear simultaneously?
The solution to the kaffeine problem is to edit the ~/.kde/share/apps/kaffeine/xine-config file You need to need to change this:

Code: Select all
# audio driver
# { auto  pulseaudio  sndio  alsa  oss  jack  none  file }, default: 0
# audio.driver:auto

into this by modifying the last line above.
Code: Select all
# audio driver
# { auto  pulseaudio  sndio  alsa  oss  jack  none  file }, default: 0
audio.driver:alsa


I found the solution here: http://debianforum.de/forum/viewtopic.php?f=25&t=131827: My German was just good enough.
This fixes the Kaffeine problem.
Please note that the Dragon/Phonon problem remains as described before. Audio but no video.
Thanks,
jdk
User avatar jdkaye
Registered Member
Posts
16
Karma
0
OS
In the system settings, if I reconfigure Phonon to use the xine backend instead of gstreamer, then Dragon Player works normally. I thought xine was dead??
User avatar Mamarok
Manager
Posts
2916
Karma
8
OS
jdkaye wrote:In the system settings, if I reconfigure Phonon to use the xine backend instead of gstreamer, then Dragon Player works normally. I thought xine was dead??

Yes, it is, please use the vlc backend instead.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
User avatar jdkaye
Registered Member
Posts
16
Karma
0
OS
Yes, that's what I've done. All has returned to normal. Thanks for the advice.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], google01103, Hans, koriun, La Ninje, MSNbot Media, north, odysseus-art, pesto, SecretCode, Sentynel, Yahoo [Bot], z-uo