Reply to topic

gwenview import from camera

zebulon
Registered Member
Posts
264
Karma
2
OS

gwenview import from camera

Sat Feb 09, 2013 10:40 pm
When I hook up my digital camera to an USB port, the KDE notifier does not pop up. I have no idea how I can import my pics. I did install kamera, rebooted, nothing helped. Anyone knows how to fix this? Thanks.
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: gwenview import from camera

Sat Feb 09, 2013 10:58 pm
did it ever?

does this help viewtopic.php?f=19&t=84364

did you try the digital camera kcm in systemsettings?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
zebulon
Registered Member
Posts
264
Karma
2
OS

Re: gwenview import from camera

Sat Feb 09, 2013 11:10 pm
I have another ubuntu machine where it worked just fine. The notifier popped up as soon as I hooked up the camera. I cannot use it because kdm is broken after an upgrade to 12.04, but that's another story.
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: gwenview import from camera

Sat Feb 09, 2013 11:49 pm
does it show in dmesg? after connecting type
Code: Select all
dmesg|tail -n 30


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS

Re: gwenview import from camera

Sat Feb 09, 2013 11:53 pm
Do you know if the camera uses PTP or MTP to transfer pictures?
If it uses PTP, then it should be detected by the system. To double check this, you can try opening the camera:/ kio slave in Dolphin or Konqueror and see if your camera appears there.

It may also be worthwhile checking the output of "lsusb" to see if the camera is being detected there.


System Settings and Device Actions KCM maintainer
Image
zebulon
Registered Member
Posts
264
Karma
2
OS

Re: gwenview import from camera

Sun Feb 10, 2013 2:58 am
This is the output of dmesg (last 30 lines)
Code: Select all
[12671.044017] [drm] nouveau 0000:01:00.0: Setting dpms mode 0 on vga encoder (output 0)
[19086.883042] [drm] nouveau 0000:01:00.0: Setting dpms mode 1 on vga encoder (output 0)
[19686.892700] [drm] nouveau 0000:01:00.0: Setting dpms mode 2 on vga encoder (output 0)
[21687.500792] [drm] nouveau 0000:01:00.0: Setting dpms mode 0 on vga encoder (output 0)
[25034.182115] [drm] nouveau 0000:01:00.0: Setting dpms mode 1 on vga encoder (output 0)
[25634.193262] [drm] nouveau 0000:01:00.0: Setting dpms mode 2 on vga encoder (output 0)
[26744.538339] [drm] nouveau 0000:01:00.0: Setting dpms mode 0 on vga encoder (output 0)
[30192.672060] usb 1-1: new full speed USB device using uhci_hcd and address 8
[30192.835367] usb 1-1: configuration #1 chosen from 1 choice
[30427.040079] usb 1-1: USB disconnect, address 8
[30429.512025] usb 1-1: new full speed USB device using uhci_hcd and address 9
[30429.675673] usb 1-1: configuration #1 chosen from 1 choice
[30437.704103] usb 1-1: USB disconnect, address 9
[30440.424054] usb 1-1: new full speed USB device using uhci_hcd and address 10
[30440.648396] usb 1-1: configuration #1 chosen from 1 choice
[33318.720090] usb 1-1: USB disconnect, address 10
[34510.448504] [drm] nouveau 0000:01:00.0: Setting dpms mode 1 on vga encoder (output 0)
[34691.029225] [drm] nouveau 0000:01:00.0: Setting dpms mode 0 on vga encoder (output 0)
[36468.624943] [drm] nouveau 0000:01:00.0: Setting dpms mode 1 on vga encoder (output 0)
[37068.633758] [drm] nouveau 0000:01:00.0: Setting dpms mode 2 on vga encoder (output 0)
[37360.418706] [drm] nouveau 0000:01:00.0: Setting dpms mode 0 on vga encoder (output 0)
[37614.989356] e100: eth0 NIC Link is Down
[37622.988276] e100: eth0 NIC Link is Up 100 Mbps Full Duplex
[38868.180235] [drm] nouveau 0000:01:00.0: Setting dpms mode 1 on vga encoder (output 0)
[39468.189591] [drm] nouveau 0000:01:00.0: Setting dpms mode 2 on vga encoder (output 0)
[45486.989335] e100: eth0 NIC Link is Down
[45542.967827] [drm] nouveau 0000:01:00.0: Setting dpms mode 0 on vga encoder (output 0)
[45736.989294] e100: eth0 NIC Link is Up 100 Mbps Full Duplex
[46140.064042] usb 1-1: new full speed USB device using uhci_hcd and address 11
[46140.228246] usb 1-1: configuration #1 chosen from 1 choice
zebulon
Registered Member
Posts
264
Karma
2
OS

Re: gwenview import from camera

Sun Feb 10, 2013 3:10 am
bcooksley wrote:Do you know if the camera uses PTP or MTP to transfer pictures?
The manual says Hi-Speed USB; Datatransfer protocol: MTP, PTP

bcooksley wrote:If it uses PTP, then it should be detected by the system. To double check this, you can try opening the camera:/ kio slave in Dolphin or Konqueror and see if your camera appears there.
There is no directory kio under the root directory.

bcooksley wrote:It may also be worthwhile checking the output of "lsusb" to see if the camera is being detected there.
Yes:
Code: Select all
Bus 001 Device 011: ID 04b0:041e Nikon Corp.
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: gwenview import from camera

Sun Feb 10, 2013 11:38 am
camera kio:/ slave is accessed by typing camera:/ in an Dolphin address bar


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: gwenview import from camera

Sun Feb 10, 2013 1:15 pm
not something I really understand but in my system dmesg identifies the camera when plugged in
[65508.830351] usb 1-1.3: new full-speed USB device number 30 using ehci_hcd
[65508.918737] usb 1-1.3: New USB device found, idVendor=04a9, idProduct=3075
[65508.918743] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[65508.918746] usb 1-1.3: Product: Canon Digital Camera
[65508.918749] usb 1-1.3: Manufacturer: Canon Inc.


lusub output
Bus 001 Device 030: ID 04a9:3075 Canon, Inc. IXUS 400 Camera


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
zebulon
Registered Member
Posts
264
Karma
2
OS

Re: gwenview import from camera

Sun Feb 10, 2013 1:58 pm
Dolphin does not show an address bar for me, but I found this "Editable Location Bar" under "View." Nothing happens if I type "camera kio:/" there.
zebulon
Registered Member
Posts
264
Karma
2
OS

Re: gwenview import from camera

Sun Feb 10, 2013 5:21 pm
Progress: I opened konqueror and typed in "camera:/" in the address bar. I was able to navigate to the photos and open them.

Just wondering why the notifier does not work.
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: gwenview import from camera

Sun Feb 10, 2013 5:34 pm
seems the camera kio only works as root in Dolphin

theres a bug report https://bugs.kde.org/show_bug.cgi?id=264020, please post and confirm the bug on bugs.kde.org


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: gwenview import from camera

Sun Feb 10, 2013 5:42 pm
did you try using digikam?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
zebulon
Registered Member
Posts
264
Karma
2
OS

Re: gwenview import from camera

Sun Feb 10, 2013 6:45 pm
I tried Dolphin as root; The camera is recognized but when I click on it, I get "Could not read file Could not lock device"
Should I open a new bug for the notifier not popping up, or confirm #264020 with my observations?

BTW I have kde 4.4.5.

Thanks.
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: gwenview import from camera

Sun Feb 10, 2013 7:12 pm
can you update KDE 4.4.5 is pretty old and may have bugs that have been fixed

ps - camera:/ in Dolphin now gives me an error
Unknown error code 150
Bad parameters
Please send a full bug report at http://bugs.kde.org.


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bcooksley, Bing [Bot], claydoh, Deusdies, Exabot [Bot], garthecho, Google [Bot], Hans, jpwhiting, La Ninje, Majestic-12 [Bot], Mamarok, MetaNova, MSN [Bot], renatoatilio, rossdv8, Uri_Herrera, Yahoo [Bot], šumski