Reply to topic

Kmail will not send out mail

paulliao
Registered Member
Posts
2
Karma
0

Kmail will not send out mail

Sat Dec 29, 2012 3:00 pm
Hi, first off new here, usually hang around Linuxquestions, so please be gentle!

Have a fresh install of Slackware 14, left my home folder intact so didn't expect any issues. However kmail simply cannot send out mail via smtp to gmail (I don't have any other accounts so can't really check if it is a kmail/gmail combo problem or just a kmail/smtp problem in general). As a control I have used Thunderbird and it can send out mail to Gmail without problems. I have tried different port and authentification types as stated by Gmail but to no avail. When I try to send out mail I get this error message back.

Code: Select all
Failed to transport message. Your SMTP server does not support PLAIN. Choose a different authentication method. The server responded: 5.7.1 Username and Password not accepted. Learn more at 5.7.1 http://support.google.com/mail/bin/answer.py?answer=14257 i1sm22249732pav.35


The user/pw is correct as I can log on to my Gmail account via a browser.

Also, it does not matter what authentification method is chosen in the account set up it still complains about 'plain' even when 'plain' is plainly not the selected auth method!

If kmail is started from the command line I get

Code: Select all
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kmail2(2656)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
[u]kmail2(2656)/kdepimlibs (mailtransport): Could not access Outbox. [/u][b][/b]


Last line might be a clue?? I have been told/read that there should be a 'Local Folders' folder but I appear not to have one and one is not automatically created. I do have this

Code: Select all
/home/mrt/.local/share/local-mail
/home/mrt/.local/share/local-mail/inbox
/home/mrt/.local/share/local-mail/inbox/cur
/home/mrt/.local/share/local-mail/inbox/new
/home/mrt/.local/share/local-mail/inbox/tmp
/home/mrt/.local/share/local-mail/trash
/home/mrt/.local/share/local-mail/trash/cur
/home/mrt/.local/share/local-mail/trash/new
/home/mrt/.local/share/local-mail/trash/tmp
/home/mrt/.local/share/local-mail/drafts
/home/mrt/.local/share/local-mail/drafts/cur
/home/mrt/.local/share/local-mail/drafts/new
/home/mrt/.local/share/local-mail/drafts/tmp
/home/mrt/.local/share/local-mail/sent-mail
/home/mrt/.local/share/local-mail/sent-mail/cur
/home/mrt/.local/share/local-mail/sent-mail/new
/home/mrt/.local/share/local-mail/sent-mail/tmp
/home/mrt/.local/share/local-mail/outbox
/home/mrt/.local/share/local-mail/outbox/cur
/home/mrt/.local/share/local-mail/outbox/new
/home/mrt/.local/share/local-mail/outbox/tmp
/home/mrt/.local/share/local-mail/templates
/home/mrt/.local/share/local-mail/templates/cur
/home/mrt/.local/share/local-mail/templates/new
/home/mrt/.local/share/local-mail/templates/tmp


In Kmail accounts, receiving I have 3 gmail mail accounts and a 'Maildir' folder.
In Kmail sending I have only the 3 gmail accounts.

Some more info. Kontact from the command line......
Code: Select all
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kontact(2780)/kdeui (kdelibs): No such XML file "/home/mrt/.kde/share/apps/kontact/default-.rc"
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.


akonadiconsole from the command line gives no messages/errors.

If anyone can help get my mail flowing again I would be most grateful!

Thanks in advance, Liao.
sinclair
Registered Member
Posts
158
Karma
0
OS

Re: Kmail will not send out mail

Mon Dec 31, 2012 6:48 am
I am not sure if this will help you but I took a peek at my gmail account and the "advanced" settings are:
on pop:
encryption ssl/tls
port 995
authentication cleartext

on smtp:
encryption ssl
port 465
authentication login

that works for me, hope it helps you
paulliao
Registered Member
Posts
2
Karma
0

Re: Kmail will not send out mail

Tue Jan 01, 2013 4:38 am
ok guys. Thanks to Sinclair for trying to help. Well I am a little bit more forward as I discovered that by adding myself to the root group all works as normal. A 'Local Folders' was added under setting/account tab and I can send out mail. The only error message I receive is one solitary

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.

Remove myself from root group and we are back to the previous state. So obviously a perms problem. But I am not smart enough to work this out by myself so some help would be greatly appreciated. Any offers??

Thanks in advance
User avatar einar
Administrator
Posts
2268
Karma
5
OS

Re: Kmail will not send out mail

Tue Jan 01, 2013 10:29 am
You should create a Local Folders resource. You can do that from the account setup dialog in KMail.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python

 
Reply to topic

Bookmarks



Who is online

Registered users: AGB, airdrik, alake, Alexa [Bot], anditosan, Artmessiah, asevens, Baidu [Spider], belnac, Bing [Bot], colomar, Exabot [Bot], garthecho, Google [Bot], google01103, GreatEmerald, kainz.a, koriun, La Ninje, MiceAreVeryNice, mmistretta, nezumi, parzt, Philippe44, scummos, SeaJey, SurfFalke, Tuukka, wolfi323, Yahoo [Bot]