Reply to topic

Help! New kmail 4.10.0 and I lost my 40 000 emails :(

User avatar xywa
Registered Member
Posts
47
Karma
0
OS
Hello,

I use Gentoo, I Today I have upgraded my kde from 4.9.5 into 4.10.0. Everything went fine, but I could not start kmail and I had an error:
The akonadi personal information management service is not operational


Someone advised me to recompile with sqlite USE flag, so I did. Someone elese advised to switch in ~/.config/akonadi/akonadiserverrc I switched to
Driver=QMYSQL

After this kmail works are account are fetching emails, but...

I lost all my 40 000 old emails and all the folder (few hundred). HELP! It is possible to solve this?
vootey
Registered Member
Posts
41
Karma
0
OS
xywa wrote:Someone advised me to recompile with sqlite USE flag, so I did. Someone elese advised to switch in ~/.config/akonadi/akonadiserverrc I switched to
Driver=QMYSQL

Afaik by switching to a different database your settings/configs etc. get "lost" (they are stored in the previous database and not automatically transfered). Sounds like you just have to readd your email resource to akonadi.
User avatar xywa
Registered Member
Posts
47
Karma
0
OS
In ~/.config/akonadi/akonadiserverrc I switched to I think previous driver Driver=QSQLITE, and now looks all the folders are back in kmail but I cannot read emails as I have:
Retrieving Folder Contents
Please wait . . .


but when I start akonadiconsole looks like all the emails are in the folders, so I am waiting with finger crossed for kmail to do the job.
User avatar xywa
Registered Member
Posts
47
Karma
0
OS
Right, here is what I have now:

[1] If I use Driver=QSQLITE3 then I have an access to all old emails and folders, but I kmail is busy by "Retrieving Folder Contents
Please wait . . .". I was waiting few hours and nothing. When the folder is with 1 or 2 emails I could read the email, but system is all the time busy.
[2] If I use Driver=QMYSQL then I DO NOT have an access to all old emails and folders, but apart this verything works fine. Kmail is receiving and sending emails. The only problem, after sending an email I can't see any emails in folder SENT.

Is it possible to run kmail now with QSQLITE3 driver or maybe will be easier export data so kmail with QMYSQL driver could read old emails?


My file akonadiserverrc:
Code: Select all
[%General]
Driver=QSQLITE3

[QSQLITE3]
Name=/home/me/.local/share/akonadi/akonadi.db

[Debug]
Tracer=null

[QMYSQL]
Name=akonadi
Host=
Options="UNIX_SOCKET=/home/me/.local/share/akonadi/socket-tux/mysql.socket"
ServerPath=/usr/sbin/mysqld
StartServer=true
vootey
Registered Member
Posts
41
Karma
0
OS
It is absolutely normal that you can't access your emails with Driver=QMYSQL at this state. Let me quote myself:
vootey wrote:Afaik by switching to a different database your settings/configs etc. get "lost" (they are stored in the previous database and not automatically transfered).


I see two different ways of approaching this:
1) Use QSQLITE3 and fix the akonadi resource somehow (this may or may not be possible).
2) As I already told you: use QMYSQL and _readd_ your email resource (which is not there for the above reason => you can't access your emails in this setup atm).

So if you choose way 2 then you should check in your QSQLITE3 setup which email resource is used (in Systemsettings->Personal Information is a list of all used akonadi-resources) and then switch to QMYSQL and add this resource again. (Systemsettings->Personal Information->click Add-button and select the correct resource)
User avatar xywa
Registered Member
Posts
47
Karma
0
OS
I have checked in Systemsettings->Personal Information a list of all used akonadi-resources and both are identical: for Driver=QSQLITE3 or for Driver=QMYSQL. Identical are all the setting, mails and passwords and eg. all the filtres are identical. Only for Driver=QMYSQL I cannot see the old folders and emails. When I made an extra folder for Driver=QMYSQL I can see this folder for Driver=QSQLITE3 but nothing inside.

The easiest way could be archive folders form Driver=QSQLITE3 and then import then into working configuration Driver=QMYSQL. The problem is for Driver=QSQLITE3 kmail is doing something (maybe indexing), system is busy and is impossible to archive folders. Maybe I can copy those data manually?

Maybe will be easier for me in different way to copy those folders to have an access to them under Driver=QMYSQL?

2) As I already told you: use QMYSQL and _readd_ your email resource (which is not there for the above reason => you can't access your emails in this setup atm).

Could you explain this^^, please.
User avatar xywa
Registered Member
Posts
47
Karma
0
OS
Nearly there,

I've realized I have an access to my old folders and emails by akonadiconsole.
Is there any command in akonadiconsole which works the same way like Archiwe_folders in kmail?

With a proper archive I can manage with everything.
vootey
Registered Member
Posts
41
Karma
0
OS
xywa wrote:I have checked in Systemsettings->Personal Information a list of all used akonadi-resources and both are identical: for Driver=QSQLITE3 or for Driver=QMYSQL. Identical are all the setting, mails and passwords and eg. all the filtres are identical. Only for Driver=QMYSQL I cannot see the old folders and emails. When I made an extra folder for Driver=QMYSQL I can see this folder for Driver=QSQLITE3 but nothing inside.

If that's how it is then I clearly was wrong with my assumption. Sorry.

xywa wrote:I've realized I have an access to my old folders and emails by akonadiconsole.
Is there any command in akonadiconsole which works the same way like Archiwe_folders in kmail?

I don't know, sorry. Actually I don't even understand why it shows up in akonadiconsole but not in kmail.
But I'm glad you didn't loose your data at least.
User avatar xywa
Registered Member
Posts
47
Karma
0
OS
My last experience.

Finally, I received my old emails and can smoothly use 4.10.0! :P :P :P :P :P :P :P

What I had to do, it was to delete all old kde configurations files in my /home directory from 4.9.5 (as advised), but I created a virgin new account there, to be 100% sure there is nothing inside from previous version. In this new account I had no problems with anything so far and plasma-desktop 100% CPU was much more rarely. On branch new kmail (which works fine) I created again all account (pop, smtp, etc) and imported all old messages by "Import Messages.." from file menu of kmail. Now kmail works perfect!

To recover my old emails I have made a fresh account on another laptop withs stable kde (4.9.5) and copied into account only this (no any other configurations files, as first time It did work well):
Everything under ~/.local/share/
Everything under ~/.config/akonadi/.

...from this guide
http://userbase.kde.org/KMail/FAQs_Hint ... machine.29
after this I had all emails on other laptop and all I had to do it was - Archive folders, which archives I have moved back into my first computer and imported into kmail 4.10.0.
User avatar einar
Administrator
Posts
2269
Karma
5
OS
Please mark this topic as solved if your issue is no longer there. Thanks!


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], bcooksley, Bing [Bot], Exabot [Bot], garthecho, Google [Bot], koriun, Majestic-12 [Bot], north, rodsherwin, shmerl, Steve Guilford, verbalshadow, Vim, Yahoo [Bot], šumski