Reply to topic

kmail IMAP Error

ppsimon
Registered Member
Posts
3
Karma
0

kmail IMAP Error

Sat Jul 13, 2013 9:02 pm
Hi all,

It's my first post on this forum, so nice to meet you everyone! :)

I have some odd problem with kmail. When I send e-mail via IMAP I get this error:
gmail.com: save failed, server replied: A000241 BAD Could not parse commnad.

I have no idea, why. It has happen, two days ago.
For other server which I use I get similar message. For example:
A000216 bad error in imap commaind uid store invalid uidset

Of course kmail store the message into the folder, but still... What is the reason of that?

Where I should looking for some diagnostic message? .xsession-errors?

KDE 4.10.5
KMAIL: 4.10.5

Best regards and thanks for your help!
Simon
User avatar einar
Administrator
Posts
2288
Karma
5
OS

Re: kmail IMAP Error

Sun Jul 14, 2013 9:06 am
Hello and welcome to the KDE Community Forums!

With regards to your error, it may as well be some issue with GMail's implementation of IMAP (I used to have, in the older days, weird errors about missing folders and what not). ~/.xsession-errors is a possible source of diagnostic information, but if you have access to a different IMAP server it would be nice to test there first, becase from what you wrote I'm thinking that the fault lies with Google and not KMail.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
ppsimon
Registered Member
Posts
3
Karma
0

Re: kmail IMAP Error

Sun Jul 14, 2013 12:02 pm
einar wrote:Hello and welcome to the KDE Community Forums!

With regards to your error, it may as well be some issue with GMail's implementation of IMAP (I used to have, in the older days, weird errors about missing folders and what not). ~/.xsession-errors is a possible source of diagnostic information, but if you have access to a different IMAP server it would be nice to test there first, becase from what you wrote I'm thinking that the fault lies with Google and not KMail.


Hi,

I don't think so that Gmail changed implementation of IMAP 2 days ago or I changed something on my server. I think this issue is on my side, but I don't know where. ;-(

.xsession-error doesn't give any useful information.
When I was sending e-mail:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QObject::connect: Cannot connect (null)::destroyed() to QHostInfoLookupManager::waitForThreadPoolDone()
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20 (X_GetProperty)
Resource id: 0x560026d

Nothing more.

Regards,
Simon
User avatar einar
Administrator
Posts
2288
Karma
5
OS

Re: kmail IMAP Error

Mon Jul 15, 2013 7:01 am
Can you give more information on how you send mails? What type of server do you have configured for sending?


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
ppsimon
Registered Member
Posts
3
Karma
0

Re: kmail IMAP Error

Thu Jul 25, 2013 7:34 pm
einar wrote:Can you give more information on how you send mails? What type of server do you have configured for sending?

Hi,

You mean what? Receive account base on IMAP, send by SMTP. Of course both is configured with TLS.
Authentication PLAIN for every servers, gmail also.

If we are talking about configuration IMAP:
Subscription on servers side is ON.

As I said eariler. I did not change anything. Just happen, every time when I send the message by gmail or other servers I get this message. I do not know why.
What is interesting every e-mails which was send, was stored properly in the appriopate folder on IMAP server. It is only this message... It is very annoying! :(

On dovecot wiki I have found something:

If some Outlook users don't see new or sent mails in the appropriate folders after a migration from UW IMAPd even if they are visible in other clients (e.g. Roundcube, Thunderbird, or on the disk itself), and you get the error message "BAD Error in IMAP command UID: Invalid UID messageset" in the log or rawlog: It helps to remove the problematic IMAP account completely from Outlook and recreating it again there. It speaks a different IMAP afterwards, so there are reasons to believe it caches the details of some server on the first connect and doesn't refresh them even if you change the server's hostname in the account settings.


Is it possible that Kmail keep have some cache which cause this problem?

Regards,
Simon
User avatar einar
Administrator
Posts
2288
Karma
5
OS

Re: kmail IMAP Error

Thu Jul 25, 2013 9:15 pm
If you use disconnected IMAP, yes, it stores a copy of the messages locally. Can you check that? (If so, it can be cleared)
You can find the setting in the account configuration, "Advanced" tab.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
achilleask
Registered Member
Posts
1
Karma
0

Re: kmail IMAP Error

Thu Aug 08, 2013 4:08 pm
Hello ppsimon.

I managed to solve this problem today after ignoring it for a few weeks (it didn't seem to affect anything functionally).
In my identity settings, I had Kmail set up to save outgoing messages in Gmail/[Google mail]/Sent Mail
Apparently this is not required, since Gmail stores copies of outgoing messages automatically in that folder. I suspect Kmail was trying to save the same message there a second time and Gmail was complaining.

So I switched the outgoing mail save folder to the local sent-mail directory and now it's all good. Outgoing messages are still saved in Gmail's "Sent Mail" and no errors appear.

Hope this helps.

EDIT: It might also help to disable the setting named "Act on new/unread mail in this folder" in the folder properties for Gmail's sent mail folder, otherwise you might get new mail notifications for the messages you send and are automatically stored there.

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], bjoernbalazs, braystacey, Dimitrios, edmael, einar, Exabot [Bot], flotho, Google [Bot], google01103, ivan, Joif, ken300, maarten, Majestic-12 [Bot], nezumi, peje, rdong, SecretCode, skywolfblue, stephans, Steve T, TheraHedwig, tienhung, Yahoo [Bot]