Reply to topic

Kmail 4.10.5: "The server did not accept the sender address"

searchfgold6789
Registered Member
Posts
21
Karma
0
OS
Hi everyone,

I am experiencing a bug with Kmail. This is a fresh install of Kubuntu 64 bit, and I also got the bug with a previous installation on another PC - however, there was a solution. I've tried a couple solutions so far, but those instructions are for an earlier version of KDE and I don't have the options the solutions suggest changing.

So the problem is, whenever I send a message with my SMTP Windows Live Hotmail account, a popup notification appears in the system tray:

Failed to transport message. The server did not accept the sender address "Richie@richie-desktop". The server responded: "5.5.4 Invalid Email address"


I wonder why Kmail is using my hostname as the SMTP sender address... that's very weird. And it seems to be the default behavior, which would be a very serious bug. Does anyone know how to fix this? I have already checked my settings in Identities and Accounts.
User avatar einar
Administrator
Posts
2288
Karma
5
OS
Can you check "default domain" in settings -> Accounts -> Sending?


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
searchfgold6789
Registered Member
Posts
21
Karma
0
OS
The "Default domain" is `richie-desktop`. When I attempt to clear it or change it, it goes back to the same.
User avatar einar
Administrator
Posts
2288
Karma
5
OS
I'll ask the developers how to investigate this further.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar einar
Administrator
Posts
2288
Karma
5
OS
Can you double check your "From" address in the identity? Also check the personal information panel in System Settings, to ensure things are consistent.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
searchfgold6789
Registered Member
Posts
21
Karma
0
OS
Everything under Settings > Configure KMail > Identities seems to be correct... including when I click "Modify" and check the Email Address field.

Oddly enough, there is an "SMTP sever" option in System Settings > Account Details ! I set it to smtp.live.com, but that did not help...
User avatar einar
Administrator
Posts
2288
Karma
5
OS
Also check .kde4/share/config/emailidentities just in case.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
searchfgold6789
Registered Member
Posts
21
Karma
0
OS
User avatar einar
Administrator
Posts
2288
Karma
5
OS
Can you provide an image of the SMTP account settings?


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
searchfgold6789
Registered Member
Posts
21
Karma
0
OS
Sincere thanks for the effort so far. Three images: http://imgur.com/1eEuZdT,vdI9DxD,gtqP4Yd
User avatar einar
Administrator
Posts
2288
Karma
5
OS
Enter the configuration for the SMTP server and check the advanced tab. See if you have any hostnames set there.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
searchfgold6789
Registered Member
Posts
21
Karma
0
OS
I changed my SMTP server settings (image: http://imgur.com/KHeGC6v) to match this: http://windows.microsoft.com/en-us/windows/outlook/send-receive-from-app

Still, KMail is using "Richie@richie-desktop" as the sender address, and leaves me unable to change the sender address field in the Accounts window.
User avatar einar
Administrator
Posts
2288
Karma
5
OS
Can you try removing, or creating a new identity also?


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
searchfgold6789
Registered Member
Posts
21
Karma
0
OS
I created a new identity using the same sending account and the problem persists. Have the developers said anything?
User avatar einar
Administrator
Posts
2288
Karma
5
OS
If you have the disk space and the time, try creating a new user account (in the system) and see if setting up KMail there causes the same issue.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python

 
Reply to topic

Bookmarks



Who is online

Registered users: 16777216, Baidu [Spider], Bing [Bot], Buddlespit, eddiej, Exabot [Bot], garthecho, Google [Bot], Hans, housepig, irisuser, La Ninje, Majestic-12 [Bot], Naver Yeti [Spider], orbmiser, paulmcvay, searchfgold6789, Sentynel, soldier9599, tparrott, Uri_Herrera, veqz, Yahoo [Bot]