Reply to topic

Compiling Marble for use in 64-bit Qt in Linux?

fr33
Registered Member
Posts
13
Karma
0
Hi!

Does anyone know if it's possible to create a 64-bit version of the marble library in linux using the available make files in the source code download? Or do I absolutely need to use a 32-bit QT system to integrate the library? The reason I ask is I am using the CentOS 64-bit version, and I can only use the 64 bit version of QT to compile the program.

Any help will be greatly appreciated.

Thanks!
User avatar Earthwings
KDE Developer
Posts
89
Karma
1
OS
I don't have a 64bit Linux around me at the moment, but it's intended to work flawlessly at least. If not, please complain here.
fr33
Registered Member
Posts
13
Karma
0
Earthwings wrote:I don't have a 64bit Linux around me at the moment, but it's intended to work flawlessly at least. If not, please complain here.

I followed the procedure here: http://edu.kde.org/marble/obtain.php

and I am unable to use QT's qmake to build my project. It does not recognize the .so file as a valid file, but I am able to use g++. I am not sure why QT can't use the generated libmarblewidget.so and I would really be greatful if anyone has any suggestions.

I used this to build the qmake .pro file: http://techbase.kde.org/Projects/Marble ... rbleWidget
User avatar Earthwings
KDE Developer
Posts
89
Karma
1
OS
Just tried (on 32bit) the qmake.pro from there with a slight modification to allow using my local Marble installation (in /home/dennis/marble/export-git), which then looks like this:
Code: Select all
TEMPLATE = app
TARGET = marble_weather
DEPENDPATH += .
INCLUDEPATH += /home/dennis/marble/export-git/include
QMAKE_LIBDIR += /home/dennis/marble/export-git/lib
SOURCES += marble_weather.cpp
LIBS += -lmarblewidget


That compiles fine (qmake .; make) and runs when using
Code: Select all
LD_LIBRARY_PATH=~/marble/export-git/lib ./marble_weather


What error message do you get about the .so being invalid?
fr33
Registered Member
Posts
13
Karma
0
Earthwings wrote:Just tried (on 32bit) the qmake.pro from there with a slight modification to allow using my local Marble installation (in /home/dennis/marble/export-git), which then looks like this:
Code: Select all
TEMPLATE = app
TARGET = marble_weather
DEPENDPATH += .
INCLUDEPATH += /home/dennis/marble/export-git/include
QMAKE_LIBDIR += /home/dennis/marble/export-git/lib
SOURCES += marble_weather.cpp
LIBS += -lmarblewidget


That compiles fine (qmake .; make) and runs when using
Code: Select all
LD_LIBRARY_PATH=~/marble/export-git/lib ./marble_weather


What error message do you get about the .so being invalid?

My error message is:
Code: Select all
error: skipping incompatible /usr/lib/qt4/lib/libmarblewidget.so when searching for -lmarblewidget


I compiled this .so file using steps I mentioned above. I have a feeling it has to do with 64 bit system, even though the qmake I am using is the 32 bit version, so I am quite confused. I would be forever in debt if you are able to shed some light to what might be the problem.

Edit: the linker is throwing this error.
fr33
Registered Member
Posts
13
Karma
0
Hey,

I have found my problem is I am compiling the marble library in a 64bit machine, therefore creating the library in 64bit version. Would you be able to aid me in how I'd go about compiling marble to get a 32bit library in a 64bit linux environment? I imagine I'd have to change settings in MakeFiles but I am not sure how to go about this..? Many, Many thanks! o)

Edit: Decided to compile application in 64 bit so this problem has been solved. Thank you for your help.
vonte
Registered Member
Posts
6
Karma
0
fr33 wrote:Hey,

I have found my problem is I am compiling the marble library in a 64bit machine, therefore creating the library in 64bit version. Would you be able to aid me in how I'd go about compiling marble to get a 32bit library in a 64bit linux environment? I imagine I'd have to change settings in MakeFiles but I am not sure how to go about this..? Many, Many thanks! o)

Edit: Decided to compile application in 64 bit so this problem has been solved. Thank you for your help.


hello,fr33
I have the same os with you and can't compile the marble source code. Could you tell me how to compile application in 64 bit.I have little idea about the makefile list.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
@vonte: Your issue is slightly different, please install the Phonon development package(s) as recommended in your topic on this.


System Settings and Device Actions KCM maintainer
Image
vonte
Registered Member
Posts
6
Karma
0
bcooksley wrote:@vonte: Your issue is slightly different, please install the Phonon development package(s) as recommended in your topic on this.

Thanks .I didn't find the phonon-devel for centOS.
fr33
Registered Member
Posts
13
Karma
0
vonte wrote:
fr33 wrote:Hey,

I have found my problem is I am compiling the marble library in a 64bit machine, therefore creating the library in 64bit version. Would you be able to aid me in how I'd go about compiling marble to get a 32bit library in a 64bit linux environment? I imagine I'd have to change settings in MakeFiles but I am not sure how to go about this..? Many, Many thanks! o)

Edit: Decided to compile application in 64 bit so this problem has been solved. Thank you for your help.


hello,fr33
I have the same os with you and can't compile the marble source code. Could you tell me how to compile application in 64 bit.I have little idea about the makefile list.

I didn't end up modifying the makelist at all. My problem was with using the correct bit-version of qmake, which kept creating the application in 32-bit (the problem was with my QCreator installation).

What is exactly the nature of your problem?
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
@vonte: Hmm, your error message is unusual, as the headers should indeed be present.
Have you since reattempted to compile Marble, in case changes to the sources have fixed this?

I suspect it may be due to the camel case differences between the KDE / Qt versions of Phonon, and your distributions use of one or the other when the other one is expected.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bcooksley, Bing [Bot], claydoh, Deusdies, Exabot [Bot], garthecho, Google [Bot], Hans, jpwhiting, La Ninje, Majestic-12 [Bot], Mamarok, MetaNova, MSN [Bot], renatoatilio, rossdv8, Uri_Herrera, Yahoo [Bot], šumski