Reply to topic

Plain view of 'Atlas' map on other computer

vladimirl
Registered Member
Posts
5
Karma
0
Hello everybody :)
I'm working on windows7 with Qt 4.7.3 and mingw 4.4
I'm making the application which works with geographical map (offline application).
When I saw Marble with 'atlas' map (srtm theme) - I've decided it's what I need :)
I compiled marble from git sources and run on my computer (release version). Also i created a simple qt widget application with marblewidget (release version). Everything works as it should, with a relief map.
But when I moved this apps to another computers, also windows7 , I had problems.
The 'atlas' map looks flat with no relief (all green). Allocated only lake.
In the copying directory are such files: compiled Marble.exe, Qt release libraries (core and other), mingw libraries, libmarblewidget.dll and Marble data directory (with maps and other).
I do not understand what the problem is, SRTM data with tiles is 'data \ maps \ earth \ srtm \'.
I have not yet figured out how to post images. with them it would be understandable.
vladimirl
Registered Member
Posts
5
Karma
0
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
Can you verify Marble is loading the STRM map on the other computers?


System Settings and Device Actions KCM maintainer
Image
vladimirl
Registered Member
Posts
5
Karma
0
I understand that Marble not need to download SRTM maps from the internet.
I installed Marble (installer for Microsoft Windows from http://marble.kde.org/install.php) on computers without the interent and everything worked correctly.
So on another computer even two directories with the maps - C:\Program Files\Marble\data\maps\earth\srtm\ and a compiled Marble directory.
vladimirl
Registered Member
Posts
5
Karma
0
Also on the other computers are not installed Qt.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
You're correct - it contains the STRM maps, in the data/ directory, and does not need internet access for them. By loading, I was referring to being able to see the map in the Map selector on those computers.

It is likely that Marble is failing to access or find the various maps on the other computers, as evidenced by it beginning to function when you installed Marble on those systems - which would allow it to find the maps.


System Settings and Device Actions KCM maintainer
Image
vladimirl
Registered Member
Posts
5
Karma
0
There is news that confused me even more. There is a computer № 3 with Qt 4.8.4 (another version) with installed Marble.
Installed Marble shows relief. And Release qt widget application with marblewidget compiled on first computer with Qt 4.7.3 does not show relief.
But when i complied this application on this computer (only the application, Marble libraries are from first computer) - it work correctly.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
This is indeed confusing. I'm going to need to defer to the developers here unfortunately - i've no idea why simply recompiling the application binary would have any effect.

One thing I have thought of - the initial start of the application compiles a "cache" which is then not used for some reason or another. On subsequent starts, the cache is used successfully. If you start the original binary now, does that work?


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], bjoernbalazs, braystacey, Dimitrios, edmael, einar, Exabot [Bot], flotho, Google [Bot], google01103, ivan, Joif, ken300, maarten, Majestic-12 [Bot], nezumi, peje, rdong, SecretCode, skywolfblue, stephans, Steve T, TheraHedwig, tienhung, Yahoo [Bot]