Reply to topic

KDialog and Google Chrome/Chromium

User avatar Liznevada
Registered Member
Posts
5
Karma
0
OS

KDialog and Google Chrome/Chromium

Sun Mar 11, 2012 2:25 am
Hi!

i have a issue regarding KDialog on Chrome/Chromium, i tried to save a website, but theres no "Save Full Webpage" option like on the GTK dialog, so only the HTML file gets saved (not the rest of the website).

Image

Theres any workaround for this? im tired of opening firefox just to save a full webpage(cuz Firefox uses GTK dialogs)

Thanks
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Interesting. Can you provide a screenshot of the Chromium Gtk dialog here?
I am suspecting that unless Chromium has a hidden preference to alter the default it may not be possible to affect this.


System Settings and Device Actions KCM maintainer
Image
User avatar Liznevada
Registered Member
Posts
5
Karma
0
OS
here, GTK Dialog of Chromium (the same as Chrome)
Image
(Pagina Web, Completa) translates "Full Webpage"

(yes, i have Gnome Shell installed, but just for the GTK Stuff)
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Have you tried changing the document type savable with the KDE dialog (should be under "Filtro" in your screenshot).


System Settings and Device Actions KCM maintainer
Image
User avatar Liznevada
Registered Member
Posts
5
Karma
0
OS
theres no more options..
Image
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Hm, they seem to have forgotten to add it.

To try and workaround that, save it using the Gtk Chromium, get the file extension it uses, then try to edit the KDE dialog with *.<ext> when saving. It potentially might not allow you to do the edit though.


System Settings and Device Actions KCM maintainer
Image
User avatar Liznevada
Registered Member
Posts
5
Karma
0
OS
bcooksley wrote:Hm, they seem to have forgotten to add it.

To try and workaround that, save it using the Gtk Chromium, get the file extension it uses, then try to edit the KDE dialog with *.<ext> when saving. It potentially might not allow you to do the edit though.

GTK Saves as HTML and a folder with the files of the website (images, css..)which extension are you talking about

====================================================================
Yay!
i dont know how,(because i not sure how set enviroment variables)
i ask google folks on freenode irc and they give an enviroment variable
Code: Select all
NO_CHROME_KDE_FILE_DIALOG

and reboot. then chrome and chromium now use the gtk dialog!!!

Image
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
I would suggest filing a bug against Chrome/Chromium here regarding it's KDE compatibility - as this functionality should still be offered.


System Settings and Device Actions KCM maintainer
Image
User avatar Liznevada
Registered Member
Posts
5
Karma
0
OS
bcooksley wrote:I would suggest filing a bug against Chrome/Chromium here regarding it's KDE compatibility - as this functionality should still be offered.

i was going to do that, but seems that the bug is already reported on the BugTracker.
http://code.google.com/p/chromium/issues/detail?id=109913
but im going to submit a bug on KDE bugtracker regarding the KDialog issue.
User avatar Malsasa
Registered Member
Posts
53
Karma
0
OS
Liznevada wrote:
bcooksley wrote:Hm, they seem to have forgotten to add it.

To try and workaround that, save it using the Gtk Chromium, get the file extension it uses, then try to edit the KDE dialog with *.<ext> when saving. It potentially might not allow you to do the edit though.

GTK Saves as HTML and a folder with the files of the website (images, css..)which extension are you talking about

====================================================================
Yay!
i dont know how,(because i not sure how set enviroment variables)
i ask google folks on freenode irc and they give an enviroment variable
Code: Select all
NO_CHROME_KDE_FILE_DIALOG

and reboot. then chrome and chromium now use the gtk dialog!!!


Hello, awesome to see you did. But in my Ubuntu, I have tried to googling to set environment variable, and set it. I write the variable into .pam_environment, .bashrc, /etc/environment, but Chromium only use GTK when I run it from bash. It always happen. How if I wanna run it directly from menu? By just clicking on its shortcut?


User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
If you are changing those files, you will need to logout and back in for the changes to take effect.
However, depending on your distribution, and their default shell, the changes may still not be taken into effect.

In that case you should create a executable *.sh file in ~/.kde/env/ with the appropriate commands to set that, which will then be included as part of KDE startup.


System Settings and Device Actions KCM maintainer
Image
User avatar Malsasa
Registered Member
Posts
53
Karma
0
OS
Solved by enter environment variable into /etc/environment and some other files including bashrc and so on. After restart, all setting work like charm! You should restart to get it works :D

Thank you.



 
Reply to topic

Bookmarks



Who is online

Registered users: AElfwine, anditosan, Baidu [Spider], bcooksley, Bing [Bot], doublerainbow64, Exabot [Bot], Google [Bot], google01103, hefeweiz3n, inksi, jensreuterberg, kainz.a, koriun, l3u, moisachedaniela, Paulms, pbCyanide, raphaelpoli, scummos, SecretCode, Sentynel, toad, tparrott, Yahoo [Bot]