Reply to topic

kate can't edit a file while I DO have the write access

wotan
Registered Member
Posts
130
Karma
-2
OS
Code: Select all
cd /home/max/.kde/share/config
ll kdeveloprc
-rw-rw-r-- 1 max max 11016 2012-03-16 23:32 kdeveloprc
kate kdeveloprc

CANT EDIT THE FILE
Code: Select all
chmod +rw kdeveloprc
kate kdeveloprc

STILL CANT EDIT THE FILE ... (CAN EDIT ALL OTHER RC FILES IN THIS FOLDER)
which is quite a shame since
Code: Select all
max@netbook:~/.kde/share/config$ more kdeveloprc
Height 600=601
MenuBar=Disabled
........

and since nothing has been made in Kdevelopp to re-enable the menubar...
User avatar google01103
Manager
Posts
4956
Karma
17
OS
Is kdevelop running when you're trying to edit it?

try copying it, editing the copy, then rename the original and rename to copy to kdeveloprc

--> if the issue is that the menu bar is not displaying try toggling it with ctrl+m <--

ps - I moved this to the KDevelop


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar toad
Global Moderator
Posts
873
Karma
6
OS
You could also try vim for helpful error messages.


Sid
wotan
Registered Member
Posts
130
Karma
-2
OS
-> Kdevelop not running
-> CTRL+M in Kdevelop not working
(I have no "Kdevelop" components when I got to parameter configurations of KDE > Shortcuts. Is it normal)
-> It seems to be more a kate problem than a Kdevelop since Calligra was able to open the file and edit it (although it then saved as .ods which is useless)
-> I have done it the wild way (i.e
Code: Select all
rm kdeveloprc

and now I have my menu bar :)
But still it is weird... i mean i should have been able to edit the stuff and I don't see no reason why it can't appart a bug in kate


About the kdevloprc file: its a file that I had on another comnputer (I import all my stuff by copying the whole ~/ directory) -> Maybe something went wrong when copying right access of this one..?

Should I report this as Kate bug?
User avatar google01103
Manager
Posts
4956
Karma
17
OS
moved to Other KDE software as "It seems to be more a Kate problem"

when saving a text file in Calligra you probably need to do a save as or change the file type in the save dialog to text as ods is the default

I've only seen this once and it was the same thing LibreOffice would edit it but not Kate, if you post a bug kindly post the link to it here


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
If I recall, Kate cannot edit files with lines longer than a certain number of characters, as it will corrupt them.


System Settings and Device Actions KCM maintainer
Image
User avatar google01103
Manager
Posts
4956
Karma
17
OS
the file I can't edit has a very large line, ironically it is a file generated by KDE


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
You should still be able to use vim or kreadconfig/kwriteconfig in this case to edit the configuration file.


System Settings and Device Actions KCM maintainer
Image
User avatar google01103
Manager
Posts
4956
Karma
17
OS
if you wish a gui text editor try leafpad its minimalist with minimal dependencies


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
wotan
Registered Member
Posts
130
Karma
-2
OS
User avatar google01103
Manager
Posts
4956
Karma
17
OS
wotan wrote:https://bugs.kde.org/show_bug.cgi?id=296590

you should also vote on the bug


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
tholy
Registered Member
Posts
9
Karma
0
OS
The same issue bit me. I tried copying the file to a new name, and kate could edit it fine, so I knew it wasn't a problem with the file.

So I poked around in .kde and found this file: ~/.kde/share/apps/kate/metainfos. It seems to contain a listing of metadata for each file in kate's (recent?) history. I found the troublesome file, and saw that the "ReadWrite" tag had been set to "false". I changed it (using a different text editor for safety!), and presto, I can edit my file again.

I have no idea what triggered the ReadWrite setting to change, but now that I know about this, I'll be alert for it. If anyone else discovers the pattern and can reproduce it, clearly that would be helpful to the developers.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
You should have been able to change this setting in KWrite/Kate from the Tools menu > "Read Only Mode". This will automatically be enabled in certain circumstances - such as opening binary files (or files with encodings that KWrite cannot handle), or when the file has lines that exceed the maximum line length setting.

You can change the maximum line length setting at KWrite > Settings > Configure Editor > Open/Save. Change Line Length Limit to 0 or a very large number (such as 10240).


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], garthecho, Google [Bot], koriun, Majestic-12 [Bot], odysseus-art, pedrorodriguez, Steve Guilford, Yahoo [Bot]