Reply to topic

greeter per session setup doesn't work in kdm

dagg
Registered Member
Posts
27
Karma
0
Hello,

I'm having problems defining sessions under kdm login, I want to set up three possible sessions:
  1. session that doesn't shows any user or list and waits for user and password input
  2. another session as above
  3. a session that has a specific user list in the username text field which stays there all the time.
my kdmrc looks as follows:
Code: Select all
[General]
ConfigVersion=2.4
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
DataDir=/var/lib/kdm
GreeterUID=kdm
PidFile=/var/run/kdm.pid
ReserveServers=:3,:4,:5
ServerVTs=-7
StaticServers=:0,:1,:2

[Shutdown]
BootManager=Grub2
HaltCmd=/sbin/shutdown -h -P now
RebootCmd=/sbin/shutdown -r now

[X-*-Core]
AllowNullPasswd=false
AllowRootLogin=false
AllowShutdown=Root
AutoReLogin=false
ClientLogFile=.xsession-errors-%d
Reset=/usr/share/config/kdm/Xreset
Session=/usr/share/config/kdm/Xsession
SessionsDirs=/usr/share/apps/kdm/sessions,/usr/share/xsessions
Setup=/usr/share/config/kdm/Xsetup
Startup=/usr/share/config/kdm/Xstartup

[X-*-Greeter]
AntiAliasing=false
ColorScheme=
FaceDir=/var/lib/kdm/faces
FaceSource=AdminOnly
FailFont=Sans Serif,10,-1,5,75,0,0,0,0,0
ForgingSeed=1340912619
GUIStyle=
GreetFont=Serif,20,-1,5,50,0,0,0,0,0
GreetString=Welcome to %s at %n
GreeterPos=50,50
HiddenUsers=
Language=en_US
LogoArea=Logo
LogoPixmap=/usr/share/apps/kdm/pics/kdelogo.png
MaxShowUID=65000
MinShowUID=1000
Preloader=/usr/bin/preloadkde
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=Sans Serif,10,-1,5,50,0,0,0,0,0
Theme=/usr/share/apps/kdm/themes/KStarboard
UseBackground=true
UseTheme=true
UserCompletion=false
UserList=false

[X-:*-Core]
AllowNullPasswd=true
AllowShutdown=All
NoPassEnable=false
NoPassUsers=
ServerArgsLocal=-nolisten tcp
ServerCmd=/usr/bin/X -br -logverbose 10
ServerTimeout=30
TerminateServer=true

[X-:0-Greeter]
AllowClose=false
DefaultUser=dagg
FocusPasswd=true
LoginMode=DefaultLocal
PreselectUser=None

[X-:1-Greeter]
AllowClose=false
DefaultUser=dagg
FocusPasswd=true
LoginMode=DefaultLocal
PreselectUser=None

[X-:2-Greeter]
DefaultUser=mythtv
LoginMode=DefaultLocal
PreselectUser=mythtv

[X-:0-Core]
AutoLoginEnable=false
AutoLoginLocked=false
AutoLoginUser=
ClientLogFile=.xsession-errors
ServerArgsLocal=-config seat0.conf

[X-:1-Core]
ClientLogFile=.xsession-errors
ServerArgsLocal=-config seat1.conf -sharevts

[X-:2-Core]
AutoLoginLocked=false
AutoLoginUser=mythtv
ClientLogFile=.xsession-errors
ServerArgsLocal=-config seat2.conf -sharevts

[Xdmcp]
Enable=false
Willing=/usr/share/config/kdm/Xwilling


both sessions 1 and 2 are working, but in session 3 I cannot see the username displayed in the username text box.
any ideas what is wrong in my config?

Thanks.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
I can see "AutologinUser" present - so it shouldn't even show a greeter, but proceed immediately to starting a session for that user if I'm correct...
Does removing that option have any impact?


System Settings and Device Actions KCM maintainer
Image
dagg
Registered Member
Posts
27
Karma
0
don't know what was the issue, I've removed all beside DefaultUser=mythtv and only for the last session and it worked.

thanks.

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], Majestic-12 [Bot], mmistretta, MSNbot Media, onesandzeros, renatoatilio, shmerl, Uri_Herrera, Yahoo [Bot]