Reply to topic

[SOLVED]Compose key doesn't work in kate, konqueror, konsole

User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
Hi, I've got my compose key set up so that I hold shift then right alt (then release both). This works fine in most apps (e.g. Firefox, Thunderbird, gedit), but not in kate, konqueror or konsole. For example, normally Compose Key, "o", "o" should produce a degree sign °, but in (at least) the three KDE apps above, I just see "oo". Is there a way to fix this?

In case the settings are important: 3rd level shortcut = Right Alt, Shift+Right Alt is Multi_Key and Keyboard model = Generic | Generic 104-key PC.

I've seen some threads on this, but nothing identical (e.g. running KDE apps within gnome). I am running KDE.

Last edited by sparhawk on Tue Dec 11, 2012 10:00 pm, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
When using the shortcut dialog, does the compose key + o register as anything? I suspect the compose key may somehow be triggering a shortcut of some description, blocking it from working properly.

To the best of my knowledge, the compose key works at the X level - so the behaviour should not change depending on the application.


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
I'm not sure how to check if a particular key combination is a shortcut, but I certainly cannot recall setting a shortcut with the compose key.

Also, the example of Compose, o, o was just one example. I've also tried some other combinations that I use frequently (and set in my custom compose file), such as Compose, -, - (en dash), and Compose, g, a, (α).
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Does a desktop environment neutral application such as xterm work correctly?


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
bcooksley wrote:Does a desktop environment neutral application such as xterm work correctly?

Yes, it works fine.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Okay, this is quite odd... is Qt configured to use the appropriate input system - such as IBus? (see https://bugs.launchpad.net/ubuntu/+sour ... bug/487997 )

To confirm this is a Qt level issue:
Does it work in a Qt-only application such as qdbusviewer?


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
I don't quite understand what Qt is, but I can confirm that the compose key does not work in qdbusviewer.

I also don't quite understand the linked bug. It says "fix released" over 2.5 years ago? Or is there something that I've mis-configured that I've missed?

Thank you for your help so far.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Qt is the toolkit which KDE applications are written in. The equivalent to Gtk for GNOME applications (only Qt provides quite a lot more).
Is the environment variable QT_IM_MODULE set, and is ibus-qt4 installed?


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
ibus-qt4 is installed.
Code: Select all
$ dpkg -l ibus-qt4
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                           Version                      Architecture                 Description
+++-==============================================-============================-============================-==================================================================================================
ii  ibus-qt4                                       1.3.1-2.1ubuntu1             amd64                        qt-immodule for ibus (QT4)


However, QT_IM_MODULE seems to be empty.
Code: Select all
$ echo $QT_IM_MODULE

$ echo $GTK_IM_MODULE
xim

I tried to set it using
Code: Select all
export QT_IM_MODULE=ibus

but I presume I need to log out and in? Or should I set it to xim instead?

Also, I presume it should be set somewhere that is not specific to my user? Is it possible that my installation was a bit shonky? (I installed kubuntu over a stock Unity/Ubuntu installation.)
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Unfortunately I don't know too much about how to configure xim/ibus.
After exporting that command, if you run an application such as "kwrite" from that terminal, compose keys should then hopefully work for that application.


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
I tried setting it to both xim or ibus, but compose key still didn't work. Thank you for your help, though. At least we may have isolated the problem. It seems like I've had a few problems installing kubuntu over vanilla ubuntu, so it might be worth my while doing a clean install.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Have you tried installing the "kubuntu-desktop" package?


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
I installed kubuntu-full (which includes kubuntu-desktop, I believe).
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Can you please have a look at https://bugs.kde.org/show_bug.cgi?id=185717 - it would seem that uninstalling those other input systems (such as ibus) may cause this issue to disappear (regardless of the environment variables).


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
What would the ramifications be of uninstalling ibus? Would I then be unable to send input to gtk apps and/or need to modify GTK_IM_MODULE?

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], brand, cylverbak, dgraf, Exabot [Bot], garthecho, glepore70, Google [Bot], google01103, Hans, jensreuterberg, kainz.a, koriun, Kver, La Ninje, mcaceres, MrGlaceon, MSNbot Media, nezumi, pbCyanide, pedrorodriguez, SecretCode, starbuck, Steve T, tparrott, Yahoo [Bot], šumski