Reply to topic

Kate and Kwrite maximum line length settings

dwlamb
Registered Member
Posts
20
Karma
0
As a PHP/MySQL developer I occasionally have to edit an SQL file manually. Is there a way to disable the maximum line length in either Kate or Kwrite?

Most other text editors don't have a maximum line length limit. If there are other programmers out there using KDE, what is the alternative?
User avatar google01103
Manager
Posts
4960
Karma
17
OS
settings -> configure kate -> editor component -> open/save -> general -> line length limit


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
dwlamb
Registered Member
Posts
20
Karma
0
I know how to change the line length. It just seems no matter what I set, Kwrite or Kate is not satisfied. Even something as long as 1024000.
User avatar google01103
Manager
Posts
4960
Karma
17
OS
seems a bug fixed in master branch https://bugs.kde.org/show_bug.cgi?id=303598


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
dwlamb
Registered Member
Posts
20
Karma
0
This does not solve my issue. The rewrite of the file is not always silent. A dialog box is presented informing certain non-specific lines exceed whatever value I enter in the configuration parameters. I have tried a value as high as 999999 and Kate will either inform Me a line is too long, put the file into read-only mode or a combination of the two.
User avatar google01103
Manager
Posts
4960
Karma
17
OS
what version of KDE? it seems to work ok for me in a simple test under 4.10rc


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
dwlamb
Registered Member
Posts
20
Karma
0
KDE 4.9.4/Kubuntu 12.10

google01103 wrote:what version of KDE? it seems to work ok for me in a simple test under 4.10rc
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Unfortunately that commit did not make it into the KDE/4.9 branch, and so was only part of KDE 4.10, which was recently released.
Only updating to KDE 4.10 will fix your issue in this case I am afraid (and as KDE 4.10 has now been released, no more stable releases of the KDE 4.9 series will be made).


System Settings and Device Actions KCM maintainer
Image
User avatar tobek
Registered Member
Posts
13
Karma
0
OS
I've found that if you set the Line Length Limit to 0 that disables it.

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], bcooksley, Bing [Bot], cylverbak, Exabot [Bot], garthecho, Google [Bot], ken300, koriun, lazyit, Majestic-12 [Bot], Naproxeno, nezumi, normcross, Sogou [Bot], valoriez, vascobasque, whatthefunk, Yahoo [Bot]