Reply to topic

kde daemon crash on vncserver opening

danielsender
Registered Member
Posts
15
Karma
0
I just updated to Ubuntu 13.04 with the kde-full stuff in 2 machines and the problem occurs identically in both machines. When I log in on the main console everything seems to be working fine. However when I set the vncserver (e.g. :1) a crash window appears with the message:

Code: Select all
We are sorry, KDE Daemon closed unexpectedly
Details:
Executable: kdeinit4 PID:11851 Signal: Segmentation fault (11)


Also, the mouse left button does not work on the buttons of the windows. It shows a double horizontal arrow. I disabled special effects on the desktop but the pointer issue remains. If I type "metacity --replace" then I'm able to close or minimize the windows.

Again, as I wrote before, these two problems do not occur when I open the main console (e.g. :0).

Thanks.

Daniel
danielsender
Registered Member
Posts
15
Karma
0
No answer? Am I posting on the right forums group?

In any case, I tried to send the bug report, but the bug report couldn't find appropriate debug package for the operation. So I saved the file and I'm including it here.
Code: Select all
Application: kded4 ($Id$)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.9.0-030900rc6-generic i686
Distribution: Ubuntu 13.04

-- Information about the crash:
<In detail, tell us what you were doing  when the application crashed.>

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0xae6c0d96 in Wacom::TabletDaemon::findTabletDevice() () from /usr/lib/kde4/kded_wacomtablet.so
#7  0xae6c0103 in Wacom::TabletDaemon::TabletDaemon(QObject*, QList<QVariant> const&) () from /usr/lib/kde4/kded_wacomtablet.so
#8  0xae6c1cd3 in ?? () from /usr/lib/kde4/kded_wacomtablet.so
#9  0xb70b249e in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib/libkdecore.so.5
#10 0xb541b356 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kded4.so
#11 0xb541c422 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kded4.so
#12 0xb541e656 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kded4.so
#13 0xb74945d7 in ?? () from /usr/lib/libkdeui.so.5
#14 0xb7494686 in ?? () from /usr/lib/libkdeui.so.5
#15 0xb749480c in ?? () from /usr/lib/libkdeui.so.5
#16 0xb5aff7be in QDBusConnectionPrivate::deliverCall (this=0x8a002b0, object=0x8b384b8, msg=..., metaTypes=..., slotIdx=0) at qdbusintegrator.cpp:951
#17 0xb5b0003a in QDBusConnectionPrivate::activateCall (this=0x8a002b0, object=0x8b384b8, flags=337, msg=...) at qdbusintegrator.cpp:856
#18 0xb5b007e2 in QDBusConnectionPrivate::activateObject (this=0x8a002b0, node=..., msg=..., pathStartPos=145977345) at qdbusintegrator.cpp:1427
#19 0xb5b00bd8 in QDBusActivateObjectEvent::placeMetaCall (this=0x8b37198) at qdbusintegrator.cpp:1541
#20 0xb6d5a48b in QObject::event (this=this@entry=0xbfe01f7c, e=e@entry=0x8b37198) at kernel/qobject.cpp:1194
#21 0xb6d436da in QCoreApplication::event (this=this@entry=0xbfe01f7c, e=e@entry=0x8b37198) at kernel/qcoreapplication.cpp:1758
#22 0xb62363cd in QApplication::event (this=0xbfe01f7c, e=0x8b37198) at kernel/qapplication.cpp:2549
#23 0xb622dc7c in QApplicationPrivate::notify_helper (this=0x8a1ca08, receiver=0xbfe01f7c, e=0x8b37198) at kernel/qapplication.cpp:4567
#24 0xb6230b94 in QApplication::notify (this=0x8b37198, receiver=0xbfe01f7c, e=0x8b37198) at kernel/qapplication.cpp:3949
#25 0xb7490d01 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#26 0xb6d3e90e in QCoreApplication::notifyInternal (this=0xbfe01f7c, receiver=0xbfe01f7c, event=0x8b37198) at kernel/qcoreapplication.cpp:946
#27 0xb6d42721 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x89acf88) at kernel/qcoreapplication.cpp:1570
#29 0xb6d42a8c in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#30 0xb6d70aa4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#31 postEventSourceDispatch (s=0x8a1cd40) at kernel/qeventdispatcher_glib.cpp:279
#32 0xb592c3b3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0xb592c750 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb592c831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0xb6d70c21 in QEventDispatcherGlib::processEvents (this=this@entry=0x89ae2e8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#36 0xb62e4a5a in QGuiEventDispatcherGlib::processEvents (this=0x89ae2e8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#37 0xb6d3d3ec in QEventLoop::processEvents (this=this@entry=0xbfe01de8, flags=...) at kernel/qeventloop.cpp:149
#38 0xb6d3d6e1 in QEventLoop::exec (this=this@entry=0xbfe01de8, flags=...) at kernel/qeventloop.cpp:204
#39 0xb6d433fa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#40 0xb622bfc4 in QApplication::exec () at kernel/qapplication.cpp:3828
#41 0xb541ad40 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kded4.so
#42 0x0804f6df in _start ()

Report to https://bugs.kde.org/

User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Try disabling the "Wacom" service at System Settings > Startup & Shutdown > Service Manager.
The crash is in the "Wacom Tablet Daemon" plugin to kded4.


System Settings and Device Actions KCM maintainer
Image
danielsender
Registered Member
Posts
15
Karma
0
The crash window does not appear now, however the mouse still does not close, maximize nor minimize the windows. However it still can move the windows through the top bar.

Thanks,

Daniel
danielsender
Registered Member
Posts
15
Karma
0
Again, am I in the right forum? Am I the only one who is seeing this problem?
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
You are in the correct forum. I've been a little busy lately, hence the delay in my responses.

The inability of the mouse to close / minimize / etc windows is unusual. Can you check using "xev" to see if the mouse presses are being interpreted correctly?


System Settings and Device Actions KCM maintainer
Image
danielsender
Registered Member
Posts
15
Karma
0
Before your reply and thinking that I was in the wrong forum, I posted the issue in the "Workspace" forum. I checked with "ps aux" and saw that kwin is running. I used the command "gconf-editor" to check on Compositing (apps->metacity->general), but I didn't see the compositing button there. Is there any other way to disable Compositing?
I also ran xev and I got the following lines as I pressed buttons on different windows:

Code: Select all
xev
Outer window is 0x4400001, inner window is 0x4400002

PropertyNotify event, serial 7, synthetic NO, window 0x4400001,
    atom 0x27 (WM_NAME), time 3525986185, state PropertyNewValue

PropertyNotify event, serial 8, synthetic NO, window 0x4400001,
    atom 0x22 (WM_COMMAND), time 3525986185, state
PropertyNewValue

PropertyNotify event, serial 9, synthetic NO, window 0x4400001,
    atom 0x28 (WM_NORMAL_HINTS), time 3525986185, state
PropertyNewValue

CreateNotify event, serial 10, synthetic NO, window 0x4400001,
    parent 0x4400001, window 0x4400002, (10,10), width 50, height
50
border_width 4, override NO

PropertyNotify event, serial 11, synthetic NO, window 0x4400001,
    atom 0x122 (_KDE_NET_WM_USER_CREATION_TIME), time 3525986185,
state PropertyNewValue

PropertyNotify event, serial 11, synthetic NO, window 0x4400001,
    atom 0x122 (_KDE_NET_WM_USER_CREATION_TIME), time 3525986185,
state PropertyNewValue

PropertyNotify event, serial 13, synthetic NO, window 0x4400001,
    atom 0x71 (WM_PROTOCOLS), time 3525986186, state
PropertyNewValue

MapNotify event, serial 14, synthetic NO, window 0x4400001,
    event 0x4400001, window 0x4400002, override NO

ConfigureNotify event, serial 17, synthetic NO, window 0x4400001,
    event 0x4400001, window 0x4400001, (0,0), width 178, height
178,
    border_width 0, above 0x3c00116, override NO

ReparentNotify event, serial 17, synthetic NO, window 0x4400001,
    event 0x4400001, window 0x4400001, parent 0x380278c,
    (0,0), override NO



Thanks again,

Daniel
danielsender
Registered Member
Posts
15
Karma
0
I installed the plasma-widget-toggle-compositing in the panel and verified that compositing is disabled. However the problem still remains.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
KDE applications usually use either configuration built into themselves, or in System Settings to configure themselves. To my knowledge, gconf is GNOME specific and not used by any KDE application.

Interestingly I cannot see any events relating to button presses in that output which might explain the issue.
Just to verify - you were clicking on the area in the 'xev' window right?
Code: Select all
ButtonPress event, serial 32, synthetic NO, window 0x5000001,
    root 0xac, subw 0x5000002, time 190873472, (48,39), root:(50,62),
    state 0x10, button 1, same_screen YES

ButtonRelease event, serial 32, synthetic NO, window 0x5000001,
    root 0xac, subw 0x5000002, time 190873490, (48,39), root:(50,62),
    state 0x110, button 1, same_screen YES


System Settings and Device Actions KCM maintainer
Image
danielsender
Registered Member
Posts
15
Karma
0
Yes, in that as well as in other windows. However, when I press on buttons in the panel, then that action works. So for example if a right click on the panel where it points to the Konsole window that is open, slide it to "close" (or something else), press on "close" then it does work.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Okay, so mouse button presses are only being registered by Plasma Desktop itself (and not any right click menus it opens)?
This sounds like a focus issue. What focus policy and focus stealing prevention policies are you using?

I have "Click to Focus" and "Low" set for those two options respectively.


System Settings and Device Actions KCM maintainer
Image
danielsender
Registered Member
Posts
15
Karma
0
I have the same settings as you.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Hmm. Just to ensure that this is a server issue, and not a client one - can you try a different VNC client please?


System Settings and Device Actions KCM maintainer
Image
danielsender
Registered Member
Posts
15
Karma
0
I already did that. I tried "vncviewer" from within Centos and "xtightvncviewer" from within another Ubuntu system. Both clients work fine on other vncservers.

FYI I'm attaching the "xstartup" file inside ~/.vnc.

Code: Select all
#!/bin/sh

# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
# /etc/X11/xinit/xinitrc
xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
# x-window-manager &
startkde
# Fix to make GNOME work
export XKL_XMODMAP_DISABLE=1
# /etc/X11/Xsession
#gnome-session


The commented lines came from older configurations that I had in the past.

Thanks.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Okay, i'm not sure what it could be.

On the off chance this is caused by the window decoration itself, can you try changing to an alternative style?
This can be done at System Settings > Workspace Appearance > Window Decorations. I'd recommend the least animated options for this instance.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], bcooksley, Bing [Bot], Exabot [Bot], garthecho, Google [Bot], koriun, Majestic-12 [Bot], north, rodsherwin, shmerl, Steve Guilford, verbalshadow, Vim, Yahoo [Bot], šumski