Reply to topic

Auto-run processes randomly not starting up at login

User avatar MirceaKitsune
Registered Member
Posts
131
Karma
0
OS
I thought it would be best to ask on the forum before posting this to the bug tracker; When I log in, I occasionally experience some applications not starting up. This affects both applications remembered from last session, and system processes which should run with KDE at startup. Any process that fails to auto-start opens perfectly fine if I run it manually afterward (in case I find it's missing).

When the issue is severe, nearly nothing starts up after I log in. I have my desktop, a few things in the system tray (like Network Manager and Devices), but nothing else. At other times, only a few system processes forget to start. For example, I earlier noticed it was the case with Klipper when text would no longer copy between applications.

Does this happen to anyone else, and does anyone experience programs or system components randomly not starting up at login? Is this a known issue? If so, when will it be fixed, and what are the known workarounds?
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
When this occurs, it is usually because one process has become "stuck" and has not detached itself from KSMServer. Can you open System Activity (from KRunner) and see if any processes other than kwin are still hanging on to KSMServer? If so - and their names appear to coincide with those of your usual startup applications - try killing them to see if it unsticks the process and gets the remainder started up.


System Settings and Device Actions KCM maintainer
Image
User avatar MirceaKitsune
Registered Member
Posts
131
Karma
0
OS
I don't have a program matching "System Activity" in search. Did you mean KSysGuard? Anyway, next time this happens I will look there, thanks.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
KSysGuard is the fuller version of System Activity. System Activity can be accessed from the activity graph icon (beside the wrench) in KRunner.


System Settings and Device Actions KCM maintainer
Image
User avatar MirceaKitsune
Registered Member
Posts
131
Karma
0
OS
bcooksley wrote:KSysGuard is the fuller version of System Activity. System Activity can be accessed from the activity graph icon (beside the wrench) in KRunner.


Oh, yes... I get that when I press control + esc. Anyway, how do I see if a process is hanging into another process there? I only see a plain process list.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Try selecting "All Processes, Tree" from the drop down in the top right hand corner.


System Settings and Device Actions KCM maintainer
Image
User avatar MirceaKitsune
Registered Member
Posts
131
Karma
0
OS
It happened again today. I looked in KSysGuard but didn't see anything stuck under ksmserver, about a minute after it finished booting and launching the processes it didn't forget.

http://i44.tinypic.com/2exbga8.jpg
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
You might need to unfilter it in this case for the stuck processes to be shown.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], bcooksley, Bing [Bot], claydoh, Exabot [Bot], garthecho, Google [Bot], koriun, Majestic-12 [Bot], north, rodsherwin, shmerl, Steve Guilford, verbalshadow, Vim, Yahoo [Bot], šumski