Reply to topic

Slow dolphin startup

User avatar whashnez
Registered Member
Posts
88
Karma
0
OS

Slow dolphin startup

Fri Feb 15, 2013 5:12 pm
Hello there!

I have Arch Linux with KDE 4.10 installed. Dolphin always takes 2-3 seconds to start, or to open a tab. On the command line here's the output when I run dolphin:

Code: Select all
whashnez@localhost ~ :( $ dolphin
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WCXCG2" : property "Drive" does not exist
"/org/freedesktop/UDisks2/drives/Slimtype_DVD_A__DS8A5SH_110270205663" : property "Drive" does not exist
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WCXCG2" : property "DeviceNumber" does not exist
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WCXCG2" : property "Device" does not exist
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QObject: Cannot create children for a parent that is in a different thread.
(Parent is Nepomuk2::ResourceManager(0x21209e0), parent's thread is QThread(0x1f6e2a0), current thread is QThread(0x258ed00)


I read somewhere that this is an issue with udisks, but I don't know what to do. Help would be appreciated.


Well good job Einstein, why don't we build a rocket in the meantime...
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: Slow dolphin startup

Fri Feb 15, 2013 5:59 pm
is this new issue after upgrade to 4.10 or Arch upgrade?

do those 2 devices mentioned exist on your system?

this seems to suggest replacing plasma will help https://bbs.archlinux.org/viewtopic.php?pid=1229254, you might first wish to try as a new user


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar whashnez
Registered Member
Posts
88
Karma
0
OS

Re: Slow dolphin startup

Fri Feb 15, 2013 6:18 pm
I didn't upgrade, it is a fresh installation, I migrated back to Linux after some time. I do have a DVD drive in my laptop by default. I don't know which one the other device is. How can I check it? I recently installed mtp so that I can connect my xperia phone with the pc. Maybe that is the mentioned device?


Well good job Einstein, why don't we build a rocket in the meantime...
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: Slow dolphin startup

Fri Feb 15, 2013 6:27 pm
the second device is a Seagate harddrive 500gb, so the 2 devices mentioned are you laptops 2 drives

did you try a new user? though if a new install doesn't sound relevant


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: Slow dolphin startup

Fri Feb 15, 2013 6:44 pm
that may not be causing your delay, they could just be trivial warning messages

do you see similar lags with other apps such as Gwenview or Konqueror? The same messages if opened in Konosole?

is the folder opened extremely large? or full of images with file preview enabled?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar whashnez
Registered Member
Posts
88
Karma
0
OS

Re: Slow dolphin startup

Fri Feb 15, 2013 6:49 pm
Hmmmm konqueror opens instantly at the same location. It is my home location, it has nothing but 5 links to other locations.

Edit: However, whenever I click on the places tab in konqueror it also lags a little. Less than dolphin. And the messages printed in konsole are also:

Code: Select all
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WCXCG2" : property "Drive" does not exist
"/org/freedesktop/UDisks2/drives/Slimtype_DVD_A__DS8A5SH_110270205663" : property "Drive" does not exist
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WCXCG2" : property "DeviceNumber" does not exist
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WCXCG2" : property "Device" does not exist


Well good job Einstein, why don't we build a rocket in the meantime...
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: Slow dolphin startup

Fri Feb 15, 2013 7:10 pm
does disabling Nepomuk help? systemsettings -> desktop search -> basic settings

also, I'm moving this to the Dolphin forum


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar whashnez
Registered Member
Posts
88
Karma
0
OS

Re: Slow dolphin startup

Fri Feb 15, 2013 7:48 pm
Nothing happened disabling the Nepomuk. I read somewhere that it is related to udisks. All my disks work correctly though.


Well good job Einstein, why don't we build a rocket in the meantime...
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: Slow dolphin startup

Fri Feb 15, 2013 11:05 pm
if it's a udisk issue I'd ask on Arch's forum, might be distro specific

is there a network drive involved?

try disabling the places panel

during the 2-3 seconds run iotp or Ksysguard and see if there's excessive i/o activity

after opening check the tail of ~/.xsession-errors


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS

Re: Slow dolphin startup

Sat Feb 16, 2013 8:08 am
Unfortunately for the information KDE needs, UDisks2 involves significantly more D-Bus queries than the original UDisks. It would appear that your system is using UDisks2 and is therefore affected by this. I'm not aware of how much can be done to improve this at this time though - i'll ask the relevant developers.


System Settings and Device Actions KCM maintainer
Image
User avatar whashnez
Registered Member
Posts
88
Karma
0
OS

Re: Slow dolphin startup

Sat Feb 16, 2013 12:55 pm
google01103 wrote:if it's a udisk issue I'd ask on Arch's forum, might be distro specific

is there a network drive involved?

try disabling the places panel

during the 2-3 seconds run iotp or Ksysguard and see if there's excessive i/o activity

after opening check the tail of ~/.xsession-errors


Disabling the places panel does not solve it. Howvere there is not any intense i/o activity when waiting to open. The output of the ~/.xsession-errors was:

Code: Select all
KUrl("file:///home/whashnez") KUrl("")
KUrl("file:///home/whashnez") KUrl("")
KUrl("") KUrl("file:///home/whashnez")
kactivitymanagerd(450)/nepomuk (library) Nepomuk2::ResourceData::setProperty: "Unknown protocol '' encountered in 'dolphin'."
kactivitymanagerd(450)/nepomuk (library) Nepomuk2::ResourceData::setProperty: "Unknown protocol '' encountered in 'dolphin'."


Well good job Einstein, why don't we build a rocket in the meantime...
User avatar whashnez
Registered Member
Posts
88
Karma
0
OS

Re: Slow dolphin startup

Sat Feb 16, 2013 12:57 pm
bcooksley wrote:Unfortunately for the information KDE needs, UDisks2 involves significantly more D-Bus queries than the original UDisks. It would appear that your system is using UDisks2 and is therefore affected by this. I'm not aware of how much can be done to improve this at this time though - i'll ask the relevant developers.


Thank you, please provide an information they give to you.


Well good job Einstein, why don't we build a rocket in the meantime...
User avatar google01103
Manager
Posts
4970
Karma
17
OS

Re: Slow dolphin startup

Sat Feb 16, 2013 1:29 pm
supposedly there were patches to fix this unless yours is a different issue, maybe they aren't available yet in Arch, again maybe you should post on the Arch forums

https://git.reviewboard.kde.org/r/107168/
http://kde.6490.n7.nabble.com/Review-Re ... 23204.html
http://web.archiveorange.com/archive/v/ ... dyRuMQH5SY

Also, if Dolphin starts slowly then supposedly Gwenview also will - have you tested Gwenview?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar whashnez
Registered Member
Posts
88
Karma
0
OS

Re: Slow dolphin startup

Sat Feb 16, 2013 1:32 pm
google01103 wrote:supposedly there were patches to fix this unless yours is a different issue, maybe they aren't available yet in Arch, again maybe you should post on the Arch forums

https://git.reviewboard.kde.org/r/107168/
http://kde.6490.n7.nabble.com/Review-Re ... 23204.html
http://web.archiveorange.com/archive/v/ ... dyRuMQH5SY

Also, if Dolphin starts slowly then supposedly Gwenview also will - have you tested Gwenview?


Will ask at their forums. Gwenview starts quickly but lags tiny bit again. The konsole reports the same messages though:

Code: Select all
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WCXCG2" : property "Drive" does not exist
"/org/freedesktop/UDisks2/drives/Slimtype_DVD_A__DS8A5SH_110270205663" : property "Drive" does not exist
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WCXCG2" : property "DeviceNumber" does not exist
"/org/freedesktop/UDisks2/drives/ST9500325AS_S2WCXCG2" : property "Device" does not exist


Thank you for your help.


Well good job Einstein, why don't we build a rocket in the meantime...

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], bjoernbalazs, braystacey, Dimitrios, edmael, einar, Exabot [Bot], flotho, Google [Bot], google01103, ivan, Joif, kdeuserk, ken300, maarten, Majestic-12 [Bot], mmistretta, nezumi, peje, rdong, SecretCode, skywolfblue, stephans, Steve T, TheraHedwig, tienhung, Yahoo [Bot]