Reply to topic

'Open With' dialogue doesn't give me choice of applications

iamsorandom
Registered Member
Posts
32
Karma
0
(I think this is related to dolphin but may be just a question/bug for the KDE desktop in general)

Hi,

I have a problem in that whenever I am in a program and want to open something (e.g. an attachment from thunderbird), if it brings up the 'open with' option/dialogue and I press 'other', rather than taking me to a list of all the applications on my computer, it takes me to a file browser applet (i.e. it will show me my file system and let me select things as with an 'open document' dialogue in something such as libre office).

Given that I'm not sure exactly where all my apps are stored this is a bit annoying - anyone know how to fix this or should I submit a bug report? Using Linux Mint KDE 14, KDE 4.9.5
User avatar google01103
Manager
Posts
4958
Karma
17
OS

Mon Mar 18, 2013 3:01 pm
did it ever work correctly?
does it work correctly for a new/diff user?

what you want
Image

what you get?
Image


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18577
Karma
83
OS
If this only occurs in Firefox and Thunderbird, this is something which is outside the control of KDE.
Unfortunately neither application offers very good integration with regards to this.


System Settings and Device Actions KCM maintainer
Image
iamsorandom
Registered Member
Posts
32
Karma
0
google01103, yes, that's the problem. I can't remember if this was always a problem - I will try with a different user (but trying to think of a way I can test it without setting up my email accounts in thunderbird and all that!).

bcooksley, I'm not sure whether this is thunderbird specific, I will keep an eye out. Can you think of any other applications I could try this with (other than dolphin and thunderbird I guess)?

Cheers.
User avatar google01103
Manager
Posts
4958
Karma
17
OS
I don't think there are many apps that provide that dialog other than file managers, you could try Konqueror and Krusader

I don't use Thunderbird so can't comment on whether it has that level of KDE integration.


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18577
Karma
83
OS
All KDE applications should provide the KDE themed Open With dialog. Other applications, such as GNOME ones will use different dialogs (although they may be similar).

The scenario you are describing is usually only the case in Firefox and Thunderbird.


System Settings and Device Actions KCM maintainer
Image
iamsorandom
Registered Member
Posts
32
Karma
0
OK, fair enough - given how widespread firefox and thunderbird are it does seem like a fairly important bug to deal with - could this be dealt with through a kde-plugin for them both? Or would this need to be brought up with Mozilla developers?

The other thing I wondered is whether there could be a workaround - I know that in dolphin you can type "applications:/" in the location bar to get to applications, but I'm not sure this is the case with the scenario I'm describing
User avatar bcooksley
Administrator
Posts
18577
Karma
83
OS
Unfortunately this would probably need to be dealt with through the Mozilla developers.
From what I understand of how the applications:/ protocol works, it would not be usable by Firefox/Thunderbird (primarily as it is KDE specific).


System Settings and Device Actions KCM maintainer
Image
User avatar google01103
Manager
Posts
4958
Karma
17
OS
for FireFox (and maybe Thunderbird) for Debian and *buntu derived distros see http://blog.martin-graesslin.com/blog/2 ... n-testing/


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
iamsorandom
Registered Member
Posts
32
Karma
0
Hey,
I think this would have to be submitted through the mozilla developers. There is a bug report here: https://bugzilla.mozilla.org/show_bug.cgi?id=886130 - If anyone wants to confirm or add anything to that please do.

Cheers.

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Artmessiah, Baidu [Spider], Bing [Bot], bjoernbalazs, blue_bullet, Charblaze, Cris70, dniitall, edmael, Exabot [Bot], franku, GentooSimon, Google [Bot], google01103, jensreuterberg, jgrulich, jitseniesen, ken300, koriun, La Ninje, lazyit, lucyandfatty, Majestic-12 [Bot], Mamarok, MiceAreVeryNice, odysseus-art, okias, robinh, Steve Guilford, urgo, wes33, Yahoo [Bot]