Reply to topic

Dolphin copies at very low speed to/from NAS

piedro
Registered Member
Posts
175
Karma
1
OS
Hallo!

I can use Dolphin to browse my local network. When copiying to or from a NAS device I get a transfer speed of about 2.2 Mb/sec.
That is very slow and the main reason is the bad netaccess speed of my NAS - but that's not my point.

If I use Smb4k to mount the same network folder as above I get a transfer speed of about 6.5 Mb/sec ... ??

Since Smb4K has a lot of problems in itself (e.g. can't browse workgroups: "Failed to open /var/lib/samba/secrets.tdb
ERROR: Unable to open secrets database"...) I would rather use Dolphin for this very simple setup; it's only one NAS with three shared folders!

So my question is: How can I get at least the same speed with Dolphin as I can get with Smb4K - they both use Samba, don't they?
If there is a misconfiguration on Dolphin which I could fix, I really want to do that ...

thx for reading,
piedro

btw: if I access the NAS via Dolphin I don't get to see how much space there is left on the volume - mounted via Smb4K I get the usaul status of how many Gigs are free on the network folder ...
User avatar bcooksley
Administrator
Posts
18562
Karma
83
OS
What types of files are being handled here? Are they a large number of small files - or a single very large file?


System Settings and Device Actions KCM maintainer
Image
piedro
Registered Member
Posts
175
Karma
1
OS
- big files. in this case it was the iso file for the last kubuntu cd, most of the backups I do here are like that, cause I often Zip files together first ...
User avatar bcooksley
Administrator
Posts
18562
Karma
83
OS
This would indicate there appears to be a bottle neck in the smb:// KIO slave. Could you please file a bug report at bugs.kde.org regarding this?


System Settings and Device Actions KCM maintainer
Image
piedro
Registered Member
Posts
175
Karma
1
OS
thx, ok I will ...

p.
molecule-eye
Registered Member
Posts
277
Karma
0
OS
Wow, crazy. I thought smb transfers were pretty slow (between 1-2MB/s) so I tried transfering through smb4k where I got 6-8MB/s speeds--over 4 times faster!

piedro, did you file a bug for this and could you provide the link if so?
piedro
Registered Member
Posts
175
Karma
1
OS
There was alrady a bug, it's this one I guess:

Bug 255306 - Slow transfers "TO" mounted cifs shares even on 1Gbps link - https://bugs.kde.org/show_bug.cgi?id=255306

and this one

Bug 291835 - KIO very slow when copying from network through fish - https://bugs.kde.org/show_bug.cgi?id=291835


thx for reading,
piedro

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bcooksley, Bing [Bot], brand, capslock, djarvie, Exabot [Bot], Google [Bot], GreatEmerald, jensreuterberg, jgrulich, jitseniesen, korakios, koriun, Kver, lazyit, lueck, Majestic-12 [Bot], MiceAreVeryNice, NickElliott, TheraHedwig, Tuukka, Yahoo [Bot]