Reply to topic

Missing Language Options in System Settings

whatthefunk
Registered Member
Posts
54
Karma
0
I just installed kde-plasma-desktop over ubuntu server edition, 12.04. Updated to KDE 4.9.2.
In System Settings > Locale there is no Language tab like there used to be. I can add system languages in the general Region, Country and Language tab, but can not select an input method and therefore can not get language support up an running. Am I missing a package or missing an obvious configuration option? Trying to install Japanese.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
Are you referring to this tab? http://simplest-image-hosting.net/png-0-kh6188
For KDE translation, you will probably need to install the kde-l10n package which contains the Japanese translations.


System Settings and Device Actions KCM maintainer
Image
whatthefunk
Registered Member
Posts
54
Karma
0
I have that menu, but there is no way to switch input methods. There used to be a third tab in Locale (at least in Kubuntu) called Languages where you could switch input methods. Currently, there appears to be no GUI way to set this up, which is more than a bit of a regression in my opinion.
Anyway, I solved this by doing it in the terminal.
Code: Select all
im-switch -s ibus
whatthefunk
Registered Member
Posts
54
Karma
0
Some visuals to help. Here is the Locale menu from Kubuntu 12.04:

http://imageshack.us/photo/my-images/10 ... resim.png/

Notice the additional System Languages tab and the inuput method selection menu on the bottom right.

Now heres straight up KDE 4.9.2:

http://imageshack.us/photo/my-images/29/whattodos.png/

There is no way to select the input method. Without being able to select the input method, installing additional languages is useless.
whatthefunk
Registered Member
Posts
54
Karma
0
The missing program here is language-selector-kde. installing that brings up the third tab entry for languages. Shouldnt this be default??
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
That module is a distribution specific module, not provided with KDE. As for it being a default, I would suggest asking your distribution regarding that.


System Settings and Device Actions KCM maintainer
Image
whatthefunk
Registered Member
Posts
54
Karma
0
bcooksley wrote:That module is a distribution specific module, not provided with KDE. As for it being a default, I would suggest asking your distribution regarding that.


Thats what I figured. Im using Ubuntu Server with kde-plasma-desktop and this package wasnt included, although it is included in the kubuntu-desktop metapackage. Im just wondering why default KDE desktop doesnt come with some way of assigning input methods.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
This would likely be handled as part of Keyboard configuration (which includes layouts) in System Settings > Input Devices > Keyboard.


System Settings and Device Actions KCM maintainer
Image
pagoda
Registered Member
Posts
108
Karma
1
OS
Jonathan Riddell (jr) wrote on 2012-08-28: #4

Marking invalid for now as we have changed to adding the language-selector functions into KDE's language module directly. That might change if the added functions aren't complete however.
Changed in kde-workspace (Ubuntu Quantal):
status: Confirmed → Invalid
Changed in language-selector (Ubuntu Quantal):
status: Triaged → Invalid


https://bugs.launchpad.net/ubuntu/+sour ... ug/1013626
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
That is for Quantal, which if I am not mistaken will be 12.10. I'm not sure where exactly this functionality will be integrated though.


System Settings and Device Actions KCM maintainer
Image
pagoda
Registered Member
Posts
108
Karma
1
OS
bcooksley wrote:That is for Quantal, which if I am not mistaken will be 12.10. I'm not sure where exactly this functionality will be integrated though.

Yes. Quantal Quetzal w/. KDE 4.9.2. And as I read it, a work in progress...
ooker
Registered Member
Posts
58
Karma
0
When I use sudo apt-get install kubuntu-desktop metapackage or sudo apt-get install language-selector-kde, both don't work. What should I do?
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
Can you please clarify which options you're missing exactly? Your issue may be different to the original poster.


System Settings and Device Actions KCM maintainer
Image
ooker
Registered Member
Posts
58
Karma
0
Should I make another question?

My problem is exactly the same to the OP, but the answers of whatthefunk (install language-selector-kde or kubuntu-desktop metapackage) don't work. Thank you.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
No new topic should be needed if is the same question.

If you've installed those packages and the option is still missing you may wish to try running the following command, and then restart System Settings:
Code: Select all
kbuildsycoca4 --noincremental


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], Majestic-12 [Bot], mmistretta, MSNbot Media, onesandzeros, shmerl, Uri_Herrera, Yahoo [Bot]