Reply to topic

Cannot configure keyboard (repeat, delay, layout, lang...)

sim
Registered Member
Posts
4
Karma
0
Hi

I'm running KDE 4.8.4 on FreeBSD 9.1 on my desktop PC. Recently (unfortunately I can't pin down exactly when) my keyboard settings reverted to the default rate, delay and US layout. No matter what I try, I'm unable to alter any keyboard paramaters - I can't set the rate or delay, or set UK layout. To be clear, the changes are registered in the System Settings panel UI, but they simply have no effect on the keyboard's behaviour.

This used to work. I also have a laptop, similarly s/w configuration, and it's working fine. I've tried rebuilding xorg, KDE, and generally making sure the system it up-to-date, all to no avail. The incorrect keymap in particular is getting a little @trying@ to say the least... ;)

I'd be very grateful for any leads I can investigate.

Thanks

sim
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
Can you reproduce this under a new user?


System Settings and Device Actions KCM maintainer
Image
sim
Registered Member
Posts
4
Karma
0
bcooksley wrote:Can you reproduce this under a new user?


Thanks for the suggestion - it's a good test. I just created a completely new user and the unwanted behaviour remains. Most peculiar!

sim
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
Please open System Settings > Startup & Shutdown > Service Manager, and look under "Startup Services" for "Keyboard Daemon". I suspect it is missing or disabled. It is responsible for applying these settings from what I can tell.

If it is missing - do you have GNOME installed by any chance? (A key file called "keyboard.desktop" originally used by KDE began to be used by GNOME as well at one point which generates quite a nasty conflict)


System Settings and Device Actions KCM maintainer
Image
sim
Registered Member
Posts
4
Karma
0
bcooksley wrote:Please open System Settings > Startup & Shutdown > Service Manager, and look under "Startup Services" for "Keyboard Daemon". I suspect it is missing or disabled. It is responsible for applying these settings from what I can tell.

If it is missing - do you have GNOME installed by any chance? (A key file called "keyboard.desktop" originally used by KDE began to be used by GNOME as well at one point which generates quite a nasty conflict)


We may be homing in on something here. I opened up the list of "Startup Services". There's 16 listed (including Keyboard Daemon), all with a check in the "Use" column, yet all have the status "Not Running". If I attempt to manually start Keyboard Daemon using the Start button, I get an error dialogue: "Unable to start server keyboard."

I'm going to fire up my KDE laptop (which doesn't have this problem) and see what it's Startup Services panel looks like. In the meantime, is there a log that might contain more info about the startup failures?

I've never had GNOME installed so I guess that rules out that line of attack.

Thanks ,

sim
sim
Registered Member
Posts
4
Karma
0
Fixed it! ;D

I fished around and found a stack of errors in the .xsession-errors log, hinting that the system had reached the max number of open files. Looking at the kernel tunables and stats, it seemed that the max-file-per-proc tunable was set unusally low for some reason. Normally it is self-configuring but on this particular install it had been forced to a limit of 2400 file per process. Removing this fixed everything.

Thanks again for your help, you helped me home in on the cause :)

sim

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], boudewijn, brandy_000, bshah, cristian.onet, Exabot [Bot], garthecho, Google [Bot], GreatEmerald, Horus, ken300, koriun, Majestic-12 [Bot], mgraesslin, parzt, peje, Tuukka, vomus, Yahoo [Bot]