Reply to topic

[BUG FILED] Automatically decrypt lukscrypt hard drive

User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
Hi,

I've got an external hard drive that's encrypted with lukscrypt. After it is plugged in, udev triggers a backup script. In KDE, I get a dialogue box popping up saying "Password – KDE Dæmon: 'WD My Book 1130' needs a password to be accessed. Please enter a password." The password field already contains my password, so I just have to hit enter. The problem is that this means my script requires user input before it'll run. (e.g. in Unity/Gnome, the hard drive would automatically decrypt, with no user intervention required.) Is there a way to skip this dialogue box (short of scripting a keypress of "enter" into the backup script)?

Thanks in advance.

Last edited by sparhawk on Tue Dec 18, 2012 2:17 am, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
Can you please try disabling the KDE automounter at System Settings > Startup and Shutdown > Service Manager, and uncheck "Removable device automounter".


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
bcooksley wrote:Can you please try disabling the KDE automounter at System Settings > Startup and Shutdown > Service Manager, and uncheck "Removable device automounter".

Hi bcooksley, and thanks again for the quick response! :)

However, isn't this the opposite of what I'm trying to do? This resulted in the volume not being mounted at all. When I clicked on it in the notifier menu USB plasmoid, KDE asked for access to KDEwallet, and then I was back where I was with automount on, i.e. with the password dialogue and the password field pre-propagated.
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
I've also found something that sounds tantalising in KDE wallet > Access control > Prompt when an application accesses an open wallet. However, unchecking this box does nothing for me. I am still presented with a pre-filled password window.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
Okay, so the automounter was doing what it was supposed to - which is what the objective of that was to confirm.

Unfortunately this is likely unimplemented functionality in the code which handles encrypted partitions and disks. I would suggest filing a feature request at bugs.kde.org against Solid, requesting that it try to use already available credentials before prompting again.


System Settings and Device Actions KCM maintainer
Image
User avatar sparhawk
Registered Member
Posts
267
Karma
0
OS
Thanks. Bug report submitted here.

 
Reply to topic

Bookmarks



Who is online

Registered users: AGB, airdrik, alake, Alexa [Bot], anditosan, Artmessiah, asevens, Baidu [Spider], belnac, Bing [Bot], colomar, Exabot [Bot], garthecho, Google [Bot], google01103, GreatEmerald, kainz.a, koriun, La Ninje, MiceAreVeryNice, mmistretta, nezumi, parzt, Philippe44, scummos, SeaJey, SurfFalke, Tuukka, wolfi323, Yahoo [Bot]